aboutsummaryrefslogtreecommitdiff
path: root/www/trac-email2trac
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-05-27 17:34:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-05-27 17:34:05 +0000
commit7776f4e8b60c3121190ac24cd2cbbf169f3b716b (patch)
tree45840598594e06ad40f6ee6e2555eade84673ac0 /www/trac-email2trac
parent97bdbf20fca2e040ee22d79abe4bb087d77aa115 (diff)
downloadports-7776f4e8b60c3121190ac24cd2cbbf169f3b716b.tar.gz
ports-7776f4e8b60c3121190ac24cd2cbbf169f3b716b.zip
Notes
Diffstat (limited to 'www/trac-email2trac')
-rw-r--r--www/trac-email2trac/Makefile31
-rw-r--r--www/trac-email2trac/distinfo3
-rw-r--r--www/trac-email2trac/pkg-descr12
-rw-r--r--www/trac-email2trac/pkg-plist4
4 files changed, 50 insertions, 0 deletions
diff --git a/www/trac-email2trac/Makefile b/www/trac-email2trac/Makefile
new file mode 100644
index 000000000000..4013a52b7065
--- /dev/null
+++ b/www/trac-email2trac/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: trac-email2trac
+# Date created: May 18 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= email2trac
+PORTVERSION= 0.9.5
+CATEGORIES= www devel python
+MASTER_SITES= ftp://ftp.sara.nl/pub/outgoing/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Convert email to trac tickets
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+GNU_CONFIGURE= yes
+USE_PYTHON= 2.3+
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/delete_spam.py ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/email2trac.py ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/run_email2trac ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/email2trac.conf ${PREFIX}/etc
+
+.include <bsd.port.mk>
diff --git a/www/trac-email2trac/distinfo b/www/trac-email2trac/distinfo
new file mode 100644
index 000000000000..a2b3e6e6aa47
--- /dev/null
+++ b/www/trac-email2trac/distinfo
@@ -0,0 +1,3 @@
+MD5 (email2trac.tar.gz) = 6703f63beb2024f14cb55f6ea672d836
+SHA256 (email2trac.tar.gz) = 33b1eedfdfd4d09a16d8a99ab3f2ec702b59662176c7d05ba13e81c17a7e47f3
+SIZE (email2trac.tar.gz) = 72000
diff --git a/www/trac-email2trac/pkg-descr b/www/trac-email2trac/pkg-descr
new file mode 100644
index 000000000000..f9d88d51595c
--- /dev/null
+++ b/www/trac-email2trac/pkg-descr
@@ -0,0 +1,12 @@
+This is a release of the SARA package email2trac that contains utilities that
+we use to convert emails to trac tickets. The initial setup was made by Daniel
+Lundin from Edgewall Software. SARA has extend the initial setup, with the
+following extensions:
+
+* HTML messages
+* Attachments
+* Use commandline options
+* Use config file to change the behaviour of the email2trac.py program
+* unicode support for special characters in the headers of an email message
+
+WWW: https://subtrac.sara.nl/oss/email2trac
diff --git a/www/trac-email2trac/pkg-plist b/www/trac-email2trac/pkg-plist
new file mode 100644
index 000000000000..1bf22d97d91c
--- /dev/null
+++ b/www/trac-email2trac/pkg-plist
@@ -0,0 +1,4 @@
+bin/delete_spam.py
+bin/email2trac.py
+bin/run_email2trac
+etc/email2trac.conf