aboutsummaryrefslogtreecommitdiff
path: root/www/trac-macropost
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-05-27 15:29:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-05-27 15:29:16 +0000
commitf60fee695e4dc79e1e3f33e7a8274c3ea9ebdc2f (patch)
tree58a779e1788629ef81e8f24d46b203fc1c138060 /www/trac-macropost
parent4b247a711e79d1ca7a73287b0dd8ecec4cc2e1d5 (diff)
Notes
Diffstat (limited to 'www/trac-macropost')
-rw-r--r--www/trac-macropost/Makefile27
-rw-r--r--www/trac-macropost/distinfo3
-rw-r--r--www/trac-macropost/pkg-descr3
-rw-r--r--www/trac-macropost/pkg-plist1
4 files changed, 34 insertions, 0 deletions
diff --git a/www/trac-macropost/Makefile b/www/trac-macropost/Makefile
new file mode 100644
index 000000000000..17943177971e
--- /dev/null
+++ b/www/trac-macropost/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: trac-macropostplugin
+# Date created: 17 May 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= macropost
+PORTVERSION= 0.1
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/download/trac/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Allows Macros to use POST in forms
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/trac-macropost/distinfo b/www/trac-macropost/distinfo
new file mode 100644
index 000000000000..5b7ec11d64a3
--- /dev/null
+++ b/www/trac-macropost/distinfo
@@ -0,0 +1,3 @@
+MD5 (macropostplugin-0.1.tar.gz) = d6bbf8838762c7a9859c625dd546223a
+SHA256 (macropostplugin-0.1.tar.gz) = 1ad2277c6682e57388f21150b9b8831c253f8830a0e86bdcb003bf9c54bfbd4c
+SIZE (macropostplugin-0.1.tar.gz) = 1741
diff --git a/www/trac-macropost/pkg-descr b/www/trac-macropost/pkg-descr
new file mode 100644
index 000000000000..fc25839cdc5d
--- /dev/null
+++ b/www/trac-macropost/pkg-descr
@@ -0,0 +1,3 @@
+The MacroPostPlugin allows macros to use post in forms.
+
+WWW: http://trac-hacks.org/wiki/MacroPostPlugin
diff --git a/www/trac-macropost/pkg-plist b/www/trac-macropost/pkg-plist
new file mode 100644
index 000000000000..10a36ba735a1
--- /dev/null
+++ b/www/trac-macropost/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/TracMacroPost-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg