aboutsummaryrefslogtreecommitdiff
path: root/www/trac-navadd
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2009-01-23 23:04:15 +0000
committerBrooks Davis <brooks@FreeBSD.org>2009-01-23 23:04:15 +0000
commitff7c902ed28761f924e324b440bb141d69603255 (patch)
tree7b5726de28c2eb5fbaa97bbf5f3676bd98b74dcd /www/trac-navadd
parentf49906460bc650e053792938126a043470cacd5b (diff)
downloadports-ff7c902ed28761f924e324b440bb141d69603255.tar.gz
ports-ff7c902ed28761f924e324b440bb141d69603255.zip
Notes
Diffstat (limited to 'www/trac-navadd')
-rw-r--r--www/trac-navadd/Makefile34
-rw-r--r--www/trac-navadd/distinfo3
-rw-r--r--www/trac-navadd/pkg-descr9
3 files changed, 46 insertions, 0 deletions
diff --git a/www/trac-navadd/Makefile b/www/trac-navadd/Makefile
new file mode 100644
index 000000000000..b61918d7c03a
--- /dev/null
+++ b/www/trac-navadd/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: trac-navadd
+# Date created: January 23, 2009
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;:L}
+PORTVERSION= 0.1
+CATEGORIES= www devel python
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= brooks@freebsd.org
+COMMENT= A plugin for adding navigation items into Trac navigation bars
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= 2.3+
+NO_BUILD= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= NavAdd
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+PYDISTUTILS_NOEGGINFO= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+do-build:
+ @${DO_NADA}
+
+.include <bsd.port.mk>
diff --git a/www/trac-navadd/distinfo b/www/trac-navadd/distinfo
new file mode 100644
index 000000000000..89b63466a708
--- /dev/null
+++ b/www/trac-navadd/distinfo
@@ -0,0 +1,3 @@
+MD5 (navaddplugin-0.1.tar.gz) = 126d71b149375c5251a6e3719a9d8814
+SHA256 (navaddplugin-0.1.tar.gz) = be851c37c704e1c031e8043bf9845a259c5c9f3b2e1828be7dcbd5b9f8b0d4fa
+SIZE (navaddplugin-0.1.tar.gz) = 981
diff --git a/www/trac-navadd/pkg-descr b/www/trac-navadd/pkg-descr
new file mode 100644
index 000000000000..6c3291215ff1
--- /dev/null
+++ b/www/trac-navadd/pkg-descr
@@ -0,0 +1,9 @@
+This plugin allows you to add custom items ("buttons") to both the main
+and the meta navigation bar. Item name, title and URL can be specified
+in trac.ini, as well as an optional permission the user is required to
+have to see the item.
+
+The plugin was inspired by and derived from NavMoverPlugin. In contrast
+to NavMoverPlugin this plugin does not hide navigation bars.
+
+WWW: http://trac-hacks.org/wiki/NavAddPlugin