aboutsummaryrefslogtreecommitdiff
path: root/www/trac-ticketimport/Makefile
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2009-12-31 17:53:45 +0000
committerBrooks Davis <brooks@FreeBSD.org>2009-12-31 17:53:45 +0000
commite77540ccc59091d6b7e3d692d2a16ff5da4958f2 (patch)
tree4aec77209ff3a28bfb73c9d55419fdce3a6df40d /www/trac-ticketimport/Makefile
parent5dc9feaf861642dab8c4f7a1ca4294002046fbcf (diff)
downloadports-e77540ccc59091d6b7e3d692d2a16ff5da4958f2.tar.gz
ports-e77540ccc59091d6b7e3d692d2a16ff5da4958f2.zip
Notes
Diffstat (limited to 'www/trac-ticketimport/Makefile')
-rw-r--r--www/trac-ticketimport/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/www/trac-ticketimport/Makefile b/www/trac-ticketimport/Makefile
new file mode 100644
index 000000000000..ff26dba21eb4
--- /dev/null
+++ b/www/trac-ticketimport/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: trac-ticketimport
+# Date created: Dec 31, 2009
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;S;Plugin$;;:L}
+PORTVERSION= 0.7c
+CATEGORIES= www devel python
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+PKGNAMEPREFIX= trac-
+
+MAINTAINER= brooks@freebsd.org
+COMMENT= Import or update tickets from a CSV file or Excel file
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac \
+ ${PYTHON_PKGNAMEPREFIX}xlrd>=0.7.1:${PORTSDIR}/textproc/py-xlrd
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PYDISTUTILS_PKGNAME= TicketImport
+
+# Maintainter targets below this point
+
+# Retrieve the latest version from SVN and package in a tarball.
+.if defined(BOOTSTRAP)
+FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+do-fetch:
+ ${MKDIR} ${WRKDIR}
+ cd ${WRKDIR} && \
+ svn export http://trac-hacks.org/svn/ticketimportplugin/0.11/ \
+ ${DISTNAME}
+ cd ${WRKDIR} && tar cvf ${DISTDIR}/${DISTNAME}.tar.gz ${DISTNAME}
+.endif
+
+# Create a pkg-plist after the package is installed.
+EGGDIR= ${PYTHON_SITELIBDIR}/${PYEASYINSTALL_EGG}
+PLIST_EGGDIR= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+build-plist:
+ ${FIND} ${EGGDIR} -type f | \
+ ${SED} -e 's|${EGGDIR}|${PLIST_EGGDIR}|' | \
+ ${SORT} > pkg-plist
+ ${FIND} ${EGGDIR} -type d | \
+ ${SED} -e 's|${EGGDIR}|@dirrm ${PLIST_EGGDIR}|' | \
+ ${SORT} -r >> pkg-plist
+
+.include <bsd.port.mk>