aboutsummaryrefslogtreecommitdiff
path: root/www/trac-wikitemplates/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-05-27 19:41:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-05-27 19:41:38 +0000
commit093a46bd9e09f707202b9f1b3fb57550a40bcf67 (patch)
treedd97185cb2aceaa652a3c2f1fede58b003d716e9 /www/trac-wikitemplates/Makefile
parent301e41e8c3530179da8f8ddd688689fe90c59d8b (diff)
downloadports-093a46bd9e09f707202b9f1b3fb57550a40bcf67.tar.gz
ports-093a46bd9e09f707202b9f1b3fb57550a40bcf67.zip
Notes
Diffstat (limited to 'www/trac-wikitemplates/Makefile')
-rw-r--r--www/trac-wikitemplates/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/trac-wikitemplates/Makefile b/www/trac-wikitemplates/Makefile
new file mode 100644
index 000000000000..04e0ecb097a2
--- /dev/null
+++ b/www/trac-wikitemplates/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: trac-wikitemplates
+# Date created: May 18 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wikitemplates
+PORTVERSION= 0.3.0p3
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/download/trac/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION:S/p/rc/}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Templates for the Trac wiki
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac \
+ ${PYTHON_SITELIBDIR}/TracCtxtnavAdd-1.1_r1-py${_PYTHON_VERSION}.egg:${PORTSDIR}/www/trac-ctxtnavadd
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION:S/p/rc/} PYTHONVERSION=${_PYTHON_VERSION}
+
+.include <bsd.port.mk>