aboutsummaryrefslogtreecommitdiff
path: root/www/trac-wikitopdf
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2009-01-09 23:57:07 +0000
committerBrooks Davis <brooks@FreeBSD.org>2009-01-09 23:57:07 +0000
commit23fcf54562404bb41380488c8318ac0e3ce15efc (patch)
treec975c98cd816c5cd9f614c4d46695379f27c74ca /www/trac-wikitopdf
parent325ae801edf75020bab9533bbde7853dad7fbf21 (diff)
downloadports-23fcf54562404bb41380488c8318ac0e3ce15efc.tar.gz
ports-23fcf54562404bb41380488c8318ac0e3ce15efc.zip
Notes
Diffstat (limited to 'www/trac-wikitopdf')
-rw-r--r--www/trac-wikitopdf/Makefile35
-rw-r--r--www/trac-wikitopdf/distinfo3
-rw-r--r--www/trac-wikitopdf/pkg-descr15
3 files changed, 53 insertions, 0 deletions
diff --git a/www/trac-wikitopdf/Makefile b/www/trac-wikitopdf/Makefile
new file mode 100644
index 000000000000..f7b8997dc269
--- /dev/null
+++ b/www/trac-wikitopdf/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: trac-wikitopdf
+# Date created: January 9, 2009
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;S;Plugin$;;:L}
+PORTVERSION= 2.2.2
+CATEGORIES= www devel python
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= brooks@freebsd.org
+COMMENT= Plugin to generate PDF documents from the Wiki
+
+RUN_DEPENDS+= htmldoc:${PORTSDIR}/textproc/htmldoc \
+ tracd:${PORTSDIR}/www/trac
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= 2.3+
+NO_BUILD= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= TracWikiToPdfPlugin
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+PYDISTUTILS_NOEGGINFO= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+do-build:
+ @${DO_NADA}
+
+.include <bsd.port.mk>
diff --git a/www/trac-wikitopdf/distinfo b/www/trac-wikitopdf/distinfo
new file mode 100644
index 000000000000..eba782e6383f
--- /dev/null
+++ b/www/trac-wikitopdf/distinfo
@@ -0,0 +1,3 @@
+MD5 (wikitopdfplugin-2.2.2.tar.gz) = 0f1acb3b9150d4412f5e7187b655856b
+SHA256 (wikitopdfplugin-2.2.2.tar.gz) = fdc9ad5a928ba6850f946ada50129c28267a7f3974389422514397c58a3c9f7b
+SIZE (wikitopdfplugin-2.2.2.tar.gz) = 1819454
diff --git a/www/trac-wikitopdf/pkg-descr b/www/trac-wikitopdf/pkg-descr
new file mode 100644
index 000000000000..078708c7a266
--- /dev/null
+++ b/www/trac-wikitopdf/pkg-descr
@@ -0,0 +1,15 @@
+WikiToPdf combines the functionality of CombineWikiPlugin and
+PageToPdfPlugin on only one plugin and allows one to setup a template
+file used to generate the PDF file with a cover and a licence page, for
+example.
+
+At the end of each wiki page there is a link named WikiToPdf and
+works like athomas PageToPdfPlugin plugin but takes into account the
+parameters on trac.ini (see below) and passes them to htmldoc.
+
+Alternatively, it's possible to select one or more wiki pages and
+generate one single PDF file just like coderanger work with a cover and
+a licence from a template file. This feature also takes into account the
+parameters on trac.ini.
+
+WWW: http://trac-hacks.org/wiki/TracWikiToPdfPlugin