aboutsummaryrefslogtreecommitdiff
path: root/www/trac-xmlrpc/Makefile
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2013-01-16 19:29:08 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2013-01-16 19:29:08 +0000
commita05c4be176969ac911400db37a2e93a17fdcfcc2 (patch)
tree74407a643ea4c1cf55eb0676c69b8a098112f5ff /www/trac-xmlrpc/Makefile
parent785fe079060ee54141c6c0d60b36714ccaa7aad1 (diff)
downloadports-a05c4be176969ac911400db37a2e93a17fdcfcc2.tar.gz
ports-a05c4be176969ac911400db37a2e93a17fdcfcc2.zip
Notes
Diffstat (limited to 'www/trac-xmlrpc/Makefile')
-rw-r--r--www/trac-xmlrpc/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/www/trac-xmlrpc/Makefile b/www/trac-xmlrpc/Makefile
index e8b2c1c1d264..da9ad059db02 100644
--- a/www/trac-xmlrpc/Makefile
+++ b/www/trac-xmlrpc/Makefile
@@ -2,25 +2,29 @@
# $FreeBSD$
PORTNAME= xmlrpc
-PORTVERSION= 1.0.6
-PORTREVISION= 3
+PORTVERSION= 1.1.2.r${SVN_REV}
CATEGORIES= www devel python
-MASTER_SITES= http://shuqun.com/files/ \
- LOCAL/glarkin
+MASTER_SITES= http://trac-hacks.org/changeset/latest/xmlrpcplugin?old_path=/&format=zip&filename=
PKGNAMEPREFIX= trac-
-DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+DISTNAME= ${PORTNAME}plugin-r${SVN_REV}
MAINTAINER= glarkin@FreeBSD.org
-COMMENT= Provides an xml rpc interface to Trac
+COMMENT= Provides an XML-RPC interface to Trac
LICENSE= BSD
+SVN_REV= 12168
+
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
-WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin/trunk
+USE_ZIP= yes
USE_PYTHON= -2.7
USE_PYDISTUTILS= easy_install
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
PYDISTUTILS_PKGNAME= TracXMLRPC
+PYDISTUTILS_PKGVERSION= ${PORTVERSION:C/.r${SVN_REV}//g}
PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
.include <bsd.port.mk>