aboutsummaryrefslogtreecommitdiff
path: root/www/trac
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2014-02-08 20:02:33 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2014-02-08 20:02:33 +0000
commit76335c8c63094f1b67f5425c5997aa1a4405b917 (patch)
tree8808f6e66b50f30e13b7fd7f739e74fd6409ddd7 /www/trac
parentaed7be51435796c5159f7210ac8823ae6794b9e0 (diff)
Notes
Diffstat (limited to 'www/trac')
-rw-r--r--www/trac/Makefile106
-rw-r--r--www/trac/files/patch-trac_wiki_formatter.py14
-rw-r--r--www/trac/files/patch-trac_wiki_tests_wiki-tests.txt19
-rw-r--r--www/trac/pkg-descr6
-rw-r--r--www/trac/pkg-message4
-rw-r--r--www/trac/pkg-plist41
6 files changed, 75 insertions, 115 deletions
diff --git a/www/trac/Makefile b/www/trac/Makefile
index e5f87f7c28fb..0334a988b652 100644
--- a/www/trac/Makefile
+++ b/www/trac/Makefile
@@ -3,91 +3,59 @@
PORTNAME= trac
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= www devel python
MASTER_SITES= http://ftp.edgewall.com/pub/trac/ \
ftp://ftp.edgewall.com/pub/trac/
DISTNAME= Trac-${PORTVERSION}
MAINTAINER= clsung@FreeBSD.org
-COMMENT= An enhanced wiki and issue tracking system for software projects
+COMMENT= Enhanced wiki and issue tracking system for software projects
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.6:${PORTSDIR}/textproc/py-genshi \
- ${PYTHON_PKGNAMEPREFIX}Babel>=0.9.5:${PORTSDIR}/devel/py-babel
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+LICENSE= BSD3CLAUSE
-OPTIONS_DEFINE= SILVERCITY DOCUTILS PYGMENTS TZ PGSQL SVN
-OPTIONS_DEFAULT= SILVERCITY DOCUTILS PYGMENTS TZ SVN
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=0.9.5:${PORTSDIR}/devel/py-babel \
+ ${PYTHON_PKGNAMEPREFIX}Genshi>=0.6:${PORTSDIR}/textproc/py-genshi
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=0.9.5:${PORTSDIR}/devel/py-babel \
+ ${PYTHON_PKGNAMEPREFIX}Genshi>=0.6:${PORTSDIR}/textproc/py-genshi
+
+OPTIONS_DEFINE= SILVERCITY DOCUTILS PYGMENTS TZ SVN
+OPTIONS_DEFAULT= SILVERCITY DOCUTILS PYGMENTS TZ SVN SQLITE
+OPTIONS_RADIO= DATABASE
+OPTIONS_RADIO_DATABASE= PGSQL SQLITE
SILVERCITY_DESC= Silvercity for syntax highlighting
DOCUTILS_DESC= Allow additional text markup
PYGMENTS_DESC= Use generic syntax highlighter
TZ_DESC= Process Time Zones
-CONFLICTS= ja-trac-[0-9]*
-
-USE_PYTHON= 2
-USE_PYDISTUTILS= easy_install
-PYDISTUTILS_PKGNAME= Trac
-PYDISTUTILS_NOEGGINFO= yes
-
-USE_RC_SUBR= tracd
-SUB_LIST= PYTHON_CMD=${PYTHON_CMD}
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSILVERCITY}
-RUN_DEPENDS+= ${LOCALBASE}/bin/source2html.py:${PORTSDIR}/textproc/silvercity
-.endif
-
-.if ${PORT_OPTIONS:MDOCUTILS}
-RUN_DEPENDS+= ${LOCALBASE}/bin/rst2html:${PORTSDIR}/textproc/py-docutils
-.endif
-
-.if ${PORT_OPTIONS:MPYGMENTS}
-RUN_DEPENDS+= ${LOCALBASE}/bin/pygmentize:${PORTSDIR}/textproc/py-pygments
-.endif
-
-.if ${PORT_OPTIONS:MTZ}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopg2/__init__.py:${PORTSDIR}/databases/py-psycopg2
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
-.endif
-
-.if ${PORT_OPTIONS:MSVN}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/svn/__init__.py:${PORTSDIR}/devel/py-subversion
-.endif
-
-# This target is only meant to be used by the port maintainer.
-x-generate-plist:
- (${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
- | ${SED} -E \
- 's,.*share/nls/.+$$,,g \
- ;s,@dirrm share/man(/.*)?$$,,g \
- ;s,${PYTHON_SITELIBDIR:S,^${PYTHONBASE}/,,},%%PYTHON_SITELIBDIR%%,g \
- ;s,share/trac,%%DATADIR%%,g \
- ;s,share/examples/trac,%%EXAMPLESDIR%%,g \
- ;s,@dirrm (%%PYTHON_SITELIBDIR%%|${PYTHON_LIBDIR:S,${PYTHONBASE}/,,})$$,,g \
- ' | ${TR} -s '\n') > temp-pkg-plist
-
-pre-install:
- @${REINPLACE_CMD} -i '' -e 's|/usr/bin/python|${PYTHON_CMD}|' ${WRKSRC}/contrib/cgi-bin/trac.fcgi \
- ${WRKSRC}/contrib/cgi-bin/trac.cgi
+SILVERCITY_RUN_DEPENDS= ${LOCALBASE}/bin/source2html.py:${PORTSDIR}/textproc/silvercity
+DOCUTILS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>0:${PORTSDIR}/textproc/py-docutils
+PYGMENTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>0:${PORTSDIR}/textproc/py-pygments
+TZ_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
+PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:${PORTSDIR}/databases/py-psycopg2
+SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
+SVN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}subversion>0:${PORTSDIR}/devel/py-subversion
+
+CONFLICTS= ja-trac-[0-9]*
+PORTEXAMPLES= *
+PORTDATA= *
+
+USES= shebangfix
+SHEBANG_FILES= contrib/cgi-bin/trac.fcgi contrib/cgi-bin/trac.cgi \
+ trac/tests/functional/better_twill.py trac/tests/functional/tester.py \
+ trac/tests/functional/testenv.py trac/tests/functional/compat.py \
+ trac/tests/functional/__init__.py contrib/emailfilter.py \
+ contrib/checkwiki.py contrib/htpasswd.py
+USE_PYTHON= 2
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+USE_RC_SUBR= tracd
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/sample-plugins
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/rpm
- @${INSTALL_DATA} ${WRKSRC}/contrib/rpm/* ${STAGEDIR}${EXAMPLESDIR}/rpm
- @${FIND} ${WRKSRC}/contrib -type f -maxdepth 1 -exec ${INSTALL_DATA} {} ${STAGEDIR}${EXAMPLESDIR}/ \;
-. for d in permissions workflow
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/sample-plugins/${d}
- @${INSTALL_DATA} ${WRKSRC}/sample-plugins/${d}/* ${STAGEDIR}${EXAMPLESDIR}/sample-plugins/${d}/
- @${RM} -rf ${WRKSRC}/contrib/${d}
-. endfor
- @${INSTALL_DATA} ${WRKSRC}/sample-plugins/*.py ${STAGEDIR}${EXAMPLESDIR}/sample-plugins/
+ ${FIND} ${WRKSRC}/contrib -type f -maxdepth 1 -exec ${INSTALL_DATA} {} ${STAGEDIR}${EXAMPLESDIR}/ \;
+ (cd ${WRKSRC}/sample-plugins && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}/sample-plugins)
@${MKDIR} ${STAGEDIR}${DATADIR}/cgi-bin
- @${INSTALL_SCRIPT} ${WRKSRC}/contrib/cgi-bin/* ${STAGEDIR}${DATADIR}/cgi-bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/cgi-bin/* ${STAGEDIR}${DATADIR}/cgi-bin
.include <bsd.port.mk>
diff --git a/www/trac/files/patch-trac_wiki_formatter.py b/www/trac/files/patch-trac_wiki_formatter.py
new file mode 100644
index 000000000000..f4c62953abfd
--- /dev/null
+++ b/www/trac/files/patch-trac_wiki_formatter.py
@@ -0,0 +1,14 @@
+Backported from upstream repo: http://trac.edgewall.org/changeset/11683
+See PR 181419 for details.
+
+--- trac/wiki/formatter.py.orig 2013-02-01 08:47:41.000000000 +0800
++++ trac/wiki/formatter.py 2013-08-20 14:24:46.982232000 +0800
+@@ -575,7 +575,7 @@
+ ns = fullmatch.group('snsbr')
+ target = unquote_label(fullmatch.group('stgtbr'))
+ match = match[1:-1]
+- return '&lt;%s&gt;' % \
++ return u'&lt;%s&gt;' % \
+ self._make_link(ns, target, match, match, fullmatch)
+
+ def _shref_formatter(self, match, fullmatch):
diff --git a/www/trac/files/patch-trac_wiki_tests_wiki-tests.txt b/www/trac/files/patch-trac_wiki_tests_wiki-tests.txt
new file mode 100644
index 000000000000..bcd94e1761e1
--- /dev/null
+++ b/www/trac/files/patch-trac_wiki_tests_wiki-tests.txt
@@ -0,0 +1,19 @@
+Backported from upstream repo: http://trac.edgewall.org/changeset/11683
+See PR 181419 for details.
+
+--- trac/wiki/tests/wiki-tests.txt.orig 2013-08-20 14:02:43.308222000 +0800
++++ trac/wiki/tests/wiki-tests.txt 2013-08-20 14:01:18.000000000 +0800
+@@ -314,6 +314,13 @@
+ ------------------------------
+ <p>
+ nolink:&#34;&lt;blink&gt;&#34;
++</p>
++------------------------------
++============================== Bracketed links
++See <http://en.wikipedia.org/wiki/Mornington_Crescent_(game)>
++------------------------------
++<p>
++See &lt;<a class="ext-link" href="http://en.wikipedia.org/wiki/Mornington_Crescent_(game)"><span class="icon"></span>http://en.wikipedia.org/wiki/Mornington_Crescent_(game)</a>&gt;
+ </p>
+ ------------------------------
+ ============================================================
diff --git a/www/trac/pkg-descr b/www/trac/pkg-descr
index 1abca7ccb2ac..b008fe05e687 100644
--- a/www/trac/pkg-descr
+++ b/www/trac/pkg-descr
@@ -5,7 +5,7 @@ development process and policies.
All aspects of Trac have been designed with one single goal, to simplify
tracking and communication of software issues, enhancements and monitoring
-overall progress.
+overall progress.
What is Trac?
@@ -14,8 +14,8 @@ What is Trac?
* A flexible web-based issue tracker
* An interface to the Subversion revision control system
-At the core of Trac lies an integrated wiki and issue/bug database. Using
+At the core of Trac lies an integrated wiki and issue/bug database. Using
wiki markup, all objects managed by Trac can directly link to other
-issues/bug reports, code changesets, documentation and files.
+issues/bug reports, code changesets, documentation and files.
WWW: http://trac.edgewall.org/
diff --git a/www/trac/pkg-message b/www/trac/pkg-message
index 1b37e393950e..117b034ac451 100644
--- a/www/trac/pkg-message
+++ b/www/trac/pkg-message
@@ -6,10 +6,10 @@ You should be careful to check that the plugins you depend on have
been ported to 1.0.1, as they most probably won't work without adaptation
due to the numerous internal changes that occurred during 1.0.1 development.
-See: http://trac.edgewall.org/wiki/TracDev/ApiChanges/1.0
+See: http://trac.edgewall.org/wiki/TracDev/ApiChanges/1.0
Consult the upgrade instructions at:
- http://trac.edgewall.org/wiki/TracUpgrade
+ http://trac.edgewall.org/wiki/TracUpgrade
*******************************************************************************
diff --git a/www/trac/pkg-plist b/www/trac/pkg-plist
deleted file mode 100644
index 1aea64da30bf..000000000000
--- a/www/trac/pkg-plist
+++ /dev/null
@@ -1,41 +0,0 @@
-%%DATADIR%%/cgi-bin/trac.cgi
-%%DATADIR%%/cgi-bin/trac.fcgi
-%%EXAMPLESDIR%%/README
-%%EXAMPLESDIR%%/bugzilla2trac.py
-%%EXAMPLESDIR%%/checkwiki.py
-%%EXAMPLESDIR%%/emailfilter.py
-%%EXAMPLESDIR%%/htdigest.py
-%%EXAMPLESDIR%%/htpasswd.py
-%%EXAMPLESDIR%%/l10n_diff_index.py
-%%EXAMPLESDIR%%/l10n_reset_en_GB.py
-%%EXAMPLESDIR%%/l10n_revert_lineno_conflicts.py
-%%EXAMPLESDIR%%/migrateticketmodel.py
-%%EXAMPLESDIR%%/rpm/installscript
-%%EXAMPLESDIR%%/rpm/makerpm
-%%EXAMPLESDIR%%/sample-plugins/HelloWorld.py
-%%EXAMPLESDIR%%/sample-plugins/Timestamp.py
-%%EXAMPLESDIR%%/sample-plugins/milestone_to_version.py
-%%EXAMPLESDIR%%/sample-plugins/permissions/debug_perm.py
-%%EXAMPLESDIR%%/sample-plugins/permissions/public_wiki_policy.py
-%%EXAMPLESDIR%%/sample-plugins/permissions/vulnerability_tickets.py
-%%EXAMPLESDIR%%/sample-plugins/revision_links.py
-%%EXAMPLESDIR%%/sample-plugins/workflow/CodeReview.py
-%%EXAMPLESDIR%%/sample-plugins/workflow/DeleteTicket.py
-%%EXAMPLESDIR%%/sample-plugins/workflow/MilestoneOperation.py
-%%EXAMPLESDIR%%/sample-plugins/workflow/StatusFixer.py
-%%EXAMPLESDIR%%/sample-plugins/workflow/VoteOperation.py
-%%EXAMPLESDIR%%/sample-plugins/workflow/enterprise-review-workflow.ini
-%%EXAMPLESDIR%%/sourceforge2trac.py
-%%EXAMPLESDIR%%/trac-pre-commit-hook
-%%EXAMPLESDIR%%/trac-svn-hook
-%%EXAMPLESDIR%%/trac-svn-post-commit-hook.cmd
-%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
-bin/trac-admin
-bin/tracd
-@dirrm %%DATADIR%%/cgi-bin
-@dirrm %%DATADIR%%
-@dirrm %%EXAMPLESDIR%%/sample-plugins/workflow
-@dirrm %%EXAMPLESDIR%%/sample-plugins/permissions
-@dirrm %%EXAMPLESDIR%%/sample-plugins
-@dirrm %%EXAMPLESDIR%%/rpm
-@dirrm %%EXAMPLESDIR%%