aboutsummaryrefslogtreecommitdiff
path: root/www/trafficserver/Makefile
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2011-09-10 13:43:47 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2011-09-10 13:43:47 +0000
commit543e319b95575b915fd537a1cdcee50c1f8846d6 (patch)
treec1a63e07b379f29c8eaa4b7ae22f91c9d6778957 /www/trafficserver/Makefile
parentc0cfdaaccd02fd5e93fa4f4cf98d10cb198e682d (diff)
downloadports-543e319b95575b915fd537a1cdcee50c1f8846d6.tar.gz
ports-543e319b95575b915fd537a1cdcee50c1f8846d6.zip
Notes
Diffstat (limited to 'www/trafficserver/Makefile')
-rw-r--r--www/trafficserver/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/www/trafficserver/Makefile b/www/trafficserver/Makefile
index 1ac42bc3e6b6..12bfce8852a1 100644
--- a/www/trafficserver/Makefile
+++ b/www/trafficserver/Makefile
@@ -6,19 +6,19 @@
#
PORTNAME= trafficserver
-PORTVERSION= 3.0.0
+PORTVERSION= 3.0.1
CATEGORIES= www
MASTER_SITES= APACHE/${PORTNAME}
MAINTAINER= jnlin@csie.nctu.edu.tw
COMMENT= A fast, scalable and extensible HTTP proxy server
+LICENSE= ASL
+
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
expat.6:${PORTSDIR}/textproc/expat2 \
pcre.0:${PORTSDIR}/devel/pcre
-LICENSE= ASL
-
USE_AUTOTOOLS= autoconf automake libtool
USE_BZIP2= yes
USE_ICONV= yes
@@ -26,6 +26,11 @@ USE_OPENSSL= yes
USE_SQLITE= yes
USE_TCL= yes
USE_RC_SUBR= ${PORTNAME}
+USE_LDCONFIG= yes
+
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --with-expat=${LOCALBASE} \
+ --with-pcre=${LOCALBASE}
.include <bsd.port.pre.mk>
@@ -35,7 +40,7 @@ RUN_DEPENDS= xz>0:${PORTSDIR}/archivers/xz
.endif
.if ${OSVERSION} < 800000 && ${ARCH} == "amd64"
-BROKEN= does not compile on 7.X
+BROKEN= does not compile on 7.X/amd64
.endif
.if ${ARCH} == "sparc64"