aboutsummaryrefslogtreecommitdiff
path: root/www/trafficserver/Makefile
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2014-01-30 12:36:23 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2014-01-30 12:36:23 +0000
commite8ef133efbe9fe161c0bc1ccd6ecd390018971bd (patch)
tree39c5b9eee27cdc762580b6de7547c95ff8482dc2 /www/trafficserver/Makefile
parent37e760aca16b9998e18c132f755adc4ade1e7714 (diff)
downloadports-e8ef133efbe9fe161c0bc1ccd6ecd390018971bd.tar.gz
ports-e8ef133efbe9fe161c0bc1ccd6ecd390018971bd.zip
Notes
Diffstat (limited to 'www/trafficserver/Makefile')
-rw-r--r--www/trafficserver/Makefile76
1 files changed, 54 insertions, 22 deletions
diff --git a/www/trafficserver/Makefile b/www/trafficserver/Makefile
index 5cfd4f3c8210..e42254076121 100644
--- a/www/trafficserver/Makefile
+++ b/www/trafficserver/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= trafficserver
-PORTVERSION= 3.2.5
+PORTVERSION= 4.1.2
CATEGORIES= www
MASTER_SITES= APACHE/${PORTNAME}
@@ -12,39 +12,71 @@ COMMENT= Fast, scalable and extensible HTTP proxy server
LICENSE= APACHE20
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libexpat.so:${PORTSDIR}/textproc/expat2 \
- libpcre.so:${PORTSDIR}/devel/pcre
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libxml2.so:${PORTSDIR}/textproc/libxml2 \
+ libboost_system.so:${PORTSDIR}/devel/boost-libs \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libhwloc.so:${PORTSDIR}/devel/hwloc \
+ libluajit-${LUA_VER}.so:${PORTSDIR}/lang/luajit
-USE_AUTOTOOLS= autoconf automake libtool
+USE_AUTOTOOLS= autoconf automake libtool aclocal
+GNU_CONFIGURE= yes
USE_BZIP2= yes
-USES= pkgconfig tcl
+USES= pkgconfig tcl gmake perl5
USE_OPENSSL= yes
USE_SQLITE= yes
USE_RC_SUBR= ${PORTNAME}
+USE_LUA= 5.1+
USE_LDCONFIG= yes
-USE_GCC= any
ONLY_FOR_ARCHS= i386 amd64
+USERS= www
+GROUPS= nogroup
+
+LOGDIR= /var/log/${PORTNAME}
+
+PLIST_SUB= LOGDIR="${LOGDIR}"
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --with-expat=${LOCALBASE} \
+CONFIGURE_ARGS= --with-libxml2=${LOCALBASE} \
--with-pcre=${LOCALBASE} \
- --with-openssl=${OPENSSLBASE}
+ --with-openssl=${OPENSSLBASE} \
+ --with-xml=libxml2 \
+ --with-lua=${LOCALBASE} --enable-luajit \
+ --with-tcl=${TCL_LIBDIR} \
+ --verbose \
+ --enable-cppapi \
+ --with-user=${USERS} \
+ --with-group=${GROUPS}
+
+ACLOCAL_ARGS= -I build
+OPTIONS_DEFINE= WCCP INTERIM
+OPTIONS_RADIO= MEMMAN
+OPTIONS_RADIO_MEMMAN= ALLOCATORS FREELISTS RECLAIM
+OPTIONS_DEFAULT= FREELISTS
+
+WCCP_DESC= Enable WCCPv2 protocol
+INTERIM_DESC= Enable interim cache (SSD)
+ALLOCATORS_DESC= Manage memory with allocators
+FREELISTS_DESC= Manage memory with freelists
+RECLAIM_DESC= Reclaim unused memory in freelists
-.include <bsd.port.pre.mk>
+WCCP_CONFIGURE_ENABLE= wccp
+INTERIM_CONFIGURE_ENABLE= interim-cache
-post-patch:
- @${REINPLACE_CMD} -e 's,|| mv,|| cp -p,' ${WRKSRC}/proxy/config/Makefile.am
+.include <bsd.port.options.mk>
-pre-configure:
- @${FIND} ${WRKSRC}/example ${WRKSRC}/plugins/conf_remap \
- -name Makefile.am | ${XARGS} ${REINPLACE_CMD} \
- -e 's,CFLAGS+=,AM_CFLAGS=,' \
- -e 's,CXXFLAGS+=,AM_CXXFLAGS=,'
- @cd ${WRKSRC} && ${AUTORECONF} -i
+.if ${PORT_OPTIONS:MRECLAIM}
+CONFIGURE_ARGS+= --enable-reclaimable-freelist --enable-freelist
+.elif ${PORT_OPTIONS:MFREELISTS}
+CONFIGURE_ARGS+= --enable-freelist
+.elif ${PORT_OPTIONS:MALLOCATORS}
+CONFIGURE_ARGS+= --disable-freelist
+.else
+FORBIDDEN= No allocation strategy selected
+.endif
-post-configure:
- @${FIND} ${WRKSRC} -name 'Makefile' | ${XARGS} ${REINPLACE_CMD} \
- -e 's,LIBTOOL_LINK_FLAGS = -R -R,LIBTOOL_LINK_FLAGS = -R,' \
- -e 's,LDFLAGS = -rdynamic *-R -R,LDFLAGS = -rdynamic -R,'
+post-install:
+ @${MKDIR} ${STAGEDIR}${ETCDIR}/snapshots
+ @cd ${STAGEDIR}${ETCDIR} && for f in *.config *.config.xml; do ${MV} $$f $$f.default; done
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>