aboutsummaryrefslogtreecommitdiff
path: root/www/udmsearch
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-07-27 16:03:24 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-07-27 16:03:24 +0000
commit599bffd169db2eae83ba50b39ac2169d94321143 (patch)
tree47af3f0d7f8842e08a43dddfb78bd67eeeb9ea78 /www/udmsearch
parent244f7b92bcc6377f160accb2456154f710138ba1 (diff)
downloadports-599bffd169db2eae83ba50b39ac2169d94321143.tar.gz
ports-599bffd169db2eae83ba50b39ac2169d94321143.zip
Notes
Diffstat (limited to 'www/udmsearch')
-rw-r--r--www/udmsearch/Makefile17
-rw-r--r--www/udmsearch/distinfo2
-rw-r--r--www/udmsearch/files/patch-ab11
-rw-r--r--www/udmsearch/pkg-descr5
-rw-r--r--www/udmsearch/pkg-message27
-rw-r--r--www/udmsearch/pkg-plist108
6 files changed, 78 insertions, 92 deletions
diff --git a/www/udmsearch/Makefile b/www/udmsearch/Makefile
index 1ae9e834b675..2e8ea9b4239c 100644
--- a/www/udmsearch/Makefile
+++ b/www/udmsearch/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= udmsearch
-PORTVERSION= 3.0.19
+PORTVERSION= 3.0.20
CATEGORIES= www databases
MASTER_SITES= http://mysearch.udm.net/Download/ \
ftp://ftp.izhcom.ru/pub/unix/UdmSearch/ \
@@ -20,11 +20,8 @@ MAN5= indexer.conf.5
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-charset-guesser \
- --localstatedir=/var/udmsearch \
--sysconfdir=${PREFIX}/etc/udmsearch \
- --bindir=${PREFIX}/libexec/udmsearch \
- --sbindir=${PREFIX}/libexec/udmsearch \
- --sysconfdir=${PREFIX}/etc/udmsearch
+ --localstatedir=/var/udmsearch
.if defined(WITH_POSTGRESQL)
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
@@ -54,13 +51,13 @@ pre-fetch:
.endif
pre-install:
- ${MKDIR} ${PREFIX}/bin/udmsearch
- ${MKDIR} ${PREFIX}/etc/udmsearch
+ @${MKDIR} ${PREFIX}/share/udmsearch
post-install:
- @cp -R ${WRKSRC}/create ${PREFIX}/etc/udmsearch
- @strip ${PREFIX}/libexec/udmsearch/indexer
- @strip ${PREFIX}/libexec/udmsearch/search.cgi
+ @cp -R ${WRKSRC}/create ${PREFIX}/share/udmsearch
+ @${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/udmsearch
+ @strip ${PREFIX}/sbin/indexer
+ @strip ${PREFIX}/share/udmsearch/search.cgi
@${ECHO}
@${CAT} ${PKGMESSAGE}
diff --git a/www/udmsearch/distinfo b/www/udmsearch/distinfo
index 9ead177f76b2..294c10942742 100644
--- a/www/udmsearch/distinfo
+++ b/www/udmsearch/distinfo
@@ -1 +1 @@
-MD5 (udmsearch-3.0.19.tar.gz) = 0983067f3065d1852443bf293f748bd4
+MD5 (udmsearch-3.0.20.tar.gz) = 964330e29b7fed2ca556287f31dd5c26
diff --git a/www/udmsearch/files/patch-ab b/www/udmsearch/files/patch-ab
new file mode 100644
index 000000000000..bfc38ef8b740
--- /dev/null
+++ b/www/udmsearch/files/patch-ab
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Tue Jul 25 18:21:07 2000
++++ src/Makefile.in Thu Jul 27 15:42:08 2000
+@@ -225,7 +225,7 @@
+ @list='$(bin_PROGRAMS)'; for p in $$list; do \
+ if test -f $$p; then \
+ echo " $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
+- $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
++ $(INSTALL_PROGRAM) $$p $(DESTDIR)$(prefix)/share/udmsearch/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
+ else :; fi; \
+ done
+
diff --git a/www/udmsearch/pkg-descr b/www/udmsearch/pkg-descr
index 2ef7aecc0866..fe51080013dc 100644
--- a/www/udmsearch/pkg-descr
+++ b/www/udmsearch/pkg-descr
@@ -4,10 +4,7 @@ engines such as cooking recipies or searching newspaper articles.
Provides pre-built web search frontends in C (via CGI) and PHP.
-Currently, supports using mySQL, msql, or postgresql database backends, with
-mySQL being the default and best supported.
-
-WWW: http://mysearch.udm.net/
+WWW: http://search.mnoGo.ru/
-Kelly
kbyanc@posi.net
diff --git a/www/udmsearch/pkg-message b/www/udmsearch/pkg-message
index 60ecfc159f85..481991891eac 100644
--- a/www/udmsearch/pkg-message
+++ b/www/udmsearch/pkg-message
@@ -1,27 +1,6 @@
-udmsearch is successfully installed.
+Udmsearch is successfully installed.
Now, to use udmsearch you need to create the appropriate mysql database
-manually:
-
- Create mysql database 'udmsearch'.
- You can also use existing MySQL database, skip this step in this case.
-
- $ mysqladmin create udmsearch
-
-
- Create tables.
- If you are installing UdmSearch for the first time:
-
- $ mysql udmsearch < /usr/local/etc/udmsearch/create/mysql/create.txt
-
- IMPORTANT: If you already use UdmSearch and want to upgrade from
- UdmSearch 2.0 or earlier while keep existing data, please do not use
- create.txt. Instead, to upgrade from UdmSearch 2.0, run
-
- $ mysql udmsearch < /usr/local/etc/udmsearch/create/mysql/alter20-21.txt
-
- or, to upgrade from UdmSearch 1.x, run
- $ mysql udmsearch < /usr/local/etc/udmsearch/create/mysql/alter19-20.txt
- $ mysql udmsearch < /usr/local/etc/udmsearch/create/mysql/alter20-21.txt
+manually: Please read INSTALL file located in ${PREFIX}/share/doc/udmsearch.
For more information on how to use udmsearch, please refer to their
-web site at http://mysearch.udm.net/
+web site at http://search.mnoGo.ru/
diff --git a/www/udmsearch/pkg-plist b/www/udmsearch/pkg-plist
index 7add4254fa0a..a1dd64d36bcd 100644
--- a/www/udmsearch/pkg-plist
+++ b/www/udmsearch/pkg-plist
@@ -1,42 +1,45 @@
etc/udmsearch/indexer.conf-dist
etc/udmsearch/search.htm-dist
-etc/udmsearch/create/oracle/create.sql
-etc/udmsearch/create/oracle/multi.sql
-etc/udmsearch/create/sybase/create.sql
-etc/udmsearch/create/sybase/README
-etc/udmsearch/create/stopwords/stop.en.1.txt
-etc/udmsearch/create/stopwords/stop.ru.txt
-etc/udmsearch/create/stopwords/stop.pt.txt
-etc/udmsearch/create/stopwords/stop.no.txt
-etc/udmsearch/create/stopwords/stop.nl.txt
-etc/udmsearch/create/stopwords/stop.fr.txt
-etc/udmsearch/create/stopwords/stop.es.txt
-etc/udmsearch/create/stopwords/stop.en.txt
-etc/udmsearch/create/stopwords/stop.de.txt
-etc/udmsearch/create/stopwords/stop.it.txt
-etc/udmsearch/create/stopwords/stop.ua.txt
-etc/udmsearch/create/stopwords/stop.cz.txt
-etc/udmsearch/create/solid/create.txt
-etc/udmsearch/create/solid/README
-etc/udmsearch/create/solid/multi.txt
-etc/udmsearch/create/pgsql/create.txt
-etc/udmsearch/create/pgsql/crc.txt
-etc/udmsearch/create/pgsql/multi.txt
-etc/udmsearch/create/pgsql/crc-multi.txt
-etc/udmsearch/create/virtuoso/create.txt
-etc/udmsearch/create/virtuoso/multi.txt
-etc/udmsearch/create/virtuoso/crc.txt
-etc/udmsearch/create/mysql/create.txt
-etc/udmsearch/create/mysql/crc.txt
-etc/udmsearch/create/mysql/multi.txt
-etc/udmsearch/create/mysql/crc-multi.txt
-etc/udmsearch/create/mysql/ispell.txt
-etc/udmsearch/create/mssql/create.sql
-etc/udmsearch/create/msql/multi.txt
-etc/udmsearch/create/msql/create.txt
-etc/udmsearch/create/msql/crc.txt
-etc/udmsearch/create/msql/crc-multi.txt
-etc/udmsearch/create/ibase/create.sql
+share/udmsearch/search.cgi
+share/udmsearch/create/oracle/crc-multi.sql
+share/udmsearch/create/oracle/create.sql
+share/udmsearch/create/oracle/multi.sql
+share/udmsearch/create/sybase/create.sql
+share/udmsearch/create/sybase/README
+share/udmsearch/create/stopwords/stop.en.1.txt
+share/udmsearch/create/stopwords/stop.ru.txt
+share/udmsearch/create/stopwords/stop.pt.txt
+share/udmsearch/create/stopwords/stop.no.txt
+share/udmsearch/create/stopwords/stop.nl.txt
+share/udmsearch/create/stopwords/stop.fr.txt
+share/udmsearch/create/stopwords/stop.es.txt
+share/udmsearch/create/stopwords/stop.pl.txt
+share/udmsearch/create/stopwords/stop.en.txt
+share/udmsearch/create/stopwords/stop.de.txt
+share/udmsearch/create/stopwords/stop.it.txt
+share/udmsearch/create/stopwords/stop.ua.txt
+share/udmsearch/create/stopwords/stop.cz.txt
+share/udmsearch/create/solid/create.txt
+share/udmsearch/create/solid/README
+share/udmsearch/create/solid/multi.txt
+share/udmsearch/create/pgsql/create.txt
+share/udmsearch/create/pgsql/crc.txt
+share/udmsearch/create/pgsql/multi.txt
+share/udmsearch/create/pgsql/crc-multi.txt
+share/udmsearch/create/virtuoso/create.txt
+share/udmsearch/create/virtuoso/multi.txt
+share/udmsearch/create/virtuoso/crc.txt
+share/udmsearch/create/mysql/create.txt
+share/udmsearch/create/mysql/crc.txt
+share/udmsearch/create/mysql/multi.txt
+share/udmsearch/create/mysql/crc-multi.txt
+share/udmsearch/create/mysql/ispell.txt
+share/udmsearch/create/mssql/create.sql
+share/udmsearch/create/msql/multi.txt
+share/udmsearch/create/msql/create.txt
+share/udmsearch/create/msql/crc.txt
+share/udmsearch/create/msql/crc-multi.txt
+share/udmsearch/create/ibase/create.sql
include/udm_charset.h
include/udm_common.h
include/udm_conf.h
@@ -52,9 +55,9 @@ include/udm_spell.h
include/udm_utils.h
include/udmsearch.h
lib/libudmsearch.a
-libexec/udmsearch/search.cgi
-libexec/udmsearch/indexer
-libexec/udmsearch/udm-config
+sbin/indexer
+bin/udm-config
+share/doc/udmsearch/INSTALL
share/doc/udmsearch/parsers.txt
share/doc/udmsearch/syslog.txt
share/doc/udmsearch/templates.txt
@@ -72,17 +75,16 @@ share/doc/udmsearch/lib.txt
share/doc/udmsearch/html.txt
share/doc/udmsearch/charset.txt
@dirrm share/doc/udmsearch
-@dirrm libexec/udmsearch
-@dirrm etc/udmsearch/create/ibase
-@dirrm etc/udmsearch/create/msql
-@dirrm etc/udmsearch/create/mssql
-@dirrm etc/udmsearch/create/mysql
-@dirrm etc/udmsearch/create/oracle
-@dirrm etc/udmsearch/create/pgsql
-@dirrm etc/udmsearch/create/solid
-@dirrm etc/udmsearch/create/stopwords
-@dirrm etc/udmsearch/create/sybase
-@dirrm etc/udmsearch/create/virtuoso
-@dirrm etc/udmsearch/create
+@dirrm share/udmsearch/create/ibase
+@dirrm share/udmsearch/create/msql
+@dirrm share/udmsearch/create/mssql
+@dirrm share/udmsearch/create/mysql
+@dirrm share/udmsearch/create/oracle
+@dirrm share/udmsearch/create/pgsql
+@dirrm share/udmsearch/create/solid
+@dirrm share/udmsearch/create/stopwords
+@dirrm share/udmsearch/create/sybase
+@dirrm share/udmsearch/create/virtuoso
+@dirrm share/udmsearch/create
+@dirrm share/udmsearch
@dirrm etc/udmsearch
-@dirrm bin/udmsearch