aboutsummaryrefslogtreecommitdiff
path: root/www/varnish
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-01-25 09:27:18 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-01-25 09:27:18 +0000
commite275f8d7de74f8c5cba5cc544d471689c5466b53 (patch)
treeae93a74063848eddd044c0a23d61376139b0d001 /www/varnish
parent86d431b7f3534be8f10c8a7c604ecb66116b1e12 (diff)
downloadports-e275f8d7de74f8c5cba5cc544d471689c5466b53.tar.gz
ports-e275f8d7de74f8c5cba5cc544d471689c5466b53.zip
Notes
Diffstat (limited to 'www/varnish')
-rw-r--r--www/varnish/Makefile24
-rw-r--r--www/varnish/distinfo4
-rw-r--r--www/varnish/pkg-plist14
3 files changed, 25 insertions, 17 deletions
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
index c38df8310711..4f39af3c4fdb 100644
--- a/www/varnish/Makefile
+++ b/www/varnish/Makefile
@@ -1,16 +1,16 @@
# $FreeBSD$
PORTNAME= varnish
-PORTVERSION= 3.0.4
+PORTVERSION= 3.0.5
CATEGORIES= www
MASTER_SITES= http://repo.varnish-cache.org/source/
MAINTAINER= anders@FreeBSD.org
COMMENT= The Varnish high-performance HTTP accelerator
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
CONFLICTS= varnish-2.*
@@ -20,16 +20,11 @@ USE_PYTHON_BUILD= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX} --enable-tests
CONFIGURE_ENV= RST2MAN=true
USE_LDCONFIG= yes
-USE_AUTOTOOLS= aclocal libtool libtoolize automake autoconf
+USE_AUTOTOOLS= aclocal libtool libtoolize automake autoconf
ACLOCAL_ARGS= -I m4
LIBTOOLFLAGS= --copy --force --disable-static
AUTOMAKE_ARGS= --add-missing --copy --foreign
-MAN1= varnishadm.1 varnishd.1 varnishhist.1 varnishlog.1 \
- varnishncsa.1 varnishreplay.1 varnishsizes.1 \
- varnishstat.1 varnishtest.1 varnishtop.1
-MAN3= vmod_std.3
-MAN7= vcl.7 varnish-cli.7 varnish-counters.7
USE_RC_SUBR= varnishd varnishlog varnishncsa
SUB_FILES= pkg-message
.if defined(NO_INET6) || defined(WITHOUT_INET6)
@@ -37,7 +32,6 @@ BAD_TESTS+= r00832
EXTRA_PATCHES+= ${FILESDIR}/no-inet6.patch
.endif
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|\$$(libdir)/pkgconfig|\$$(prefix)/libdata/pkgconfig|' \
${WRKSRC}/Makefile.am
@@ -59,16 +53,16 @@ post-build:
#
post-install:
- @${MKDIR} ${PREFIX}/share/varnish
- @${INSTALL_SCRIPT} ${WRKSRC}/lib/libvmod_std/vmod.py ${PREFIX}/share/varnish
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/varnish
+ ${INSTALL_SCRIPT} ${WRKSRC}/lib/libvmod_std/vmod.py ${STAGEDIR}${PREFIX}/share/varnish
.for f in cache.h heritage.h steps.h common.h acct_fields.h locks.h body_status.h
- @${INSTALL_DATA} ${WRKSRC}/bin/varnishd/${f} ${PREFIX}/include/varnish
+ ${INSTALL_DATA} ${WRKSRC}/bin/varnishd/${f} ${STAGEDIR}${PREFIX}/include/varnish
.endfor
.for f in vct.h vmod_abi.h vre.h vrt.h vqueue.h vsb.h libvarnish.h miniobj.h vas.h vav.h http_headers.h vcl_returns.h
- @${INSTALL_DATA} ${WRKSRC}/include/${f} ${PREFIX}/include/varnish
+ ${INSTALL_DATA} ${WRKSRC}/include/${f} ${STAGEDIR}${PREFIX}/include/varnish
.endfor
@${CAT} ${PKGMESSAGE}
- @${RM} -f ${PREFIX}/lib/libvarnishapi.*a ${PREFIX}/lib/varnish/lib*a ${PREFIX}/lib/varnish/vmods/lib*a
+ @${RM} -f ${STAGEDIR}${PREFIX}/lib/libvarnishapi.*a ${STAGEDIR}${PREFIX}/lib/varnish/lib*a ${STAGEDIR}${PREFIX}/lib/varnish/vmods/lib*a
.include <bsd.port.pre.mk>
diff --git a/www/varnish/distinfo b/www/varnish/distinfo
index 5fea4bb940d1..c8528b23b262 100644
--- a/www/varnish/distinfo
+++ b/www/varnish/distinfo
@@ -1,2 +1,2 @@
-SHA256 (varnish-3.0.4.tar.gz) = 4e044ccb5c76222bddf89c808f13ea8f66977972675aecb48a920f6800ad0f79
-SIZE (varnish-3.0.4.tar.gz) = 2081361
+SHA256 (varnish-3.0.5.tar.gz) = 302fd6afc771524ca3912f5d945ab197a55762385c012b2054df7d86bf7ae2b7
+SIZE (varnish-3.0.5.tar.gz) = 2116664
diff --git a/www/varnish/pkg-plist b/www/varnish/pkg-plist
index b3ecfa560292..6f4bf4c1417e 100644
--- a/www/varnish/pkg-plist
+++ b/www/varnish/pkg-plist
@@ -43,6 +43,20 @@ lib/varnish/vmods/libvmod_std.so
lib/libvarnishapi.so.1
lib/libvarnishapi.so
libdata/pkgconfig/varnishapi.pc
+man/man1/varnishadm.1.gz
+man/man1/varnishd.1.gz
+man/man1/varnishhist.1.gz
+man/man1/varnishlog.1.gz
+man/man1/varnishncsa.1.gz
+man/man1/varnishreplay.1.gz
+man/man1/varnishsizes.1.gz
+man/man1/varnishstat.1.gz
+man/man1/varnishtest.1.gz
+man/man1/varnishtop.1.gz
+man/man3/vmod_std.3.gz
+man/man7/varnish-cli.7.gz
+man/man7/varnish-counters.7.gz
+man/man7/vcl.7.gz
sbin/varnishd
share/varnish/vmod.py
@exec [ -d %D/varnish ] || mkdir %D/varnish