aboutsummaryrefslogtreecommitdiff
path: root/www/vdr-plugin-live/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-10-18 22:30:17 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-10-18 22:30:17 +0000
commit81d5328249cc672e8e418e8667622b545d54ccf4 (patch)
tree46be221e4e9ceee8b46b53f775e89b25bf624b5d /www/vdr-plugin-live/Makefile
parent3ddb8e0aa3503e91dde80464107f8d748e4881d5 (diff)
downloadports-81d5328249cc672e8e418e8667622b545d54ccf4.tar.gz
ports-81d5328249cc672e8e418e8667622b545d54ccf4.zip
Notes
Diffstat (limited to 'www/vdr-plugin-live/Makefile')
-rw-r--r--www/vdr-plugin-live/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/www/vdr-plugin-live/Makefile b/www/vdr-plugin-live/Makefile
index d2f9366ea63f..ab30c82c483c 100644
--- a/www/vdr-plugin-live/Makefile
+++ b/www/vdr-plugin-live/Makefile
@@ -22,13 +22,26 @@ PORTDOCS= COPYING README HISTORY
WRKSRC= ${WRKDIR}/vdr-plugin-${PLUGIN}
VDR_PLUGIN_MAKEFILES= ${WRKSRC}/httpd/Makefile ${WRKSRC}/pages/Makefile
MAKE_ARGS+= INCLUDES="-I$(LOCALBASE)/include -I${WRKSRC}"
+MAKE_ARGS+= PREFIX="${PREFIX}"
+USES= compiler:features
NO_STAGE= yes
+
.include "${.CURDIR}/../../multimedia/vdr/Makefile.plugins"
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_FEATURES:Mlibc++}
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libcxx
+EXTRA_PATCH_STRIP= -p1
+.endif
+
post-patch: post-patch-plugin
${CP} ${FILESDIR}/gen_version_suffix.h ${WRKSRC}
+pre-install:
+ ${MKDIR} ${PREFIX}/lib/vdr
+
post-install: post-install-pluginlocales
(cd ${WRKSRC}/${PLUGIN} && \
${COPYTREE_SHARE} \* ${PREFIX}/etc/vdr/plugins/${PLUGIN} )
@@ -38,4 +51,4 @@ post-install: post-install-pluginlocales
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>