aboutsummaryrefslogtreecommitdiff
path: root/www/viewml
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-04-13 16:24:57 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-04-13 16:24:57 +0000
commite4b4952703458390145d94ab95579c7892963fd6 (patch)
tree8dcfb05d713c49bcc048c39dc9f5fd9dd732a10c /www/viewml
parent3da122d1e941c65875db5f0f8c54116f38ed1014 (diff)
downloadports-e4b4952703458390145d94ab95579c7892963fd6.tar.gz
ports-e4b4952703458390145d94ab95579c7892963fd6.zip
Notes
Diffstat (limited to 'www/viewml')
-rw-r--r--www/viewml/Makefile35
-rw-r--r--www/viewml/distinfo1
-rw-r--r--www/viewml/files/patch-Makefile98
-rw-r--r--www/viewml/files/patch-config.h7
-rw-r--r--www/viewml/files/patch-html.cpp16
-rw-r--r--www/viewml/pkg-comment1
-rw-r--r--www/viewml/pkg-descr17
-rw-r--r--www/viewml/pkg-plist3
8 files changed, 178 insertions, 0 deletions
diff --git a/www/viewml/Makefile b/www/viewml/Makefile
new file mode 100644
index 000000000000..69bf32b58010
--- /dev/null
+++ b/www/viewml/Makefile
@@ -0,0 +1,35 @@
+# Ports collection Makefile for: viewml
+# Date created: Black Friday (13 April 2001)
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= viewml
+PORTVERSION= 0.21
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.viewml.com/pub/viewml/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
+ wwwzip.1:${PORTSDIR}/www/libwww
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_BISON= yes
+CFLAGS+= -fpermissive -include /usr/include/sys/types.h \
+ -DPREFIX=\\\"${PREFIX}\\\"
+
+do-configure:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKEFILE} ${MAKE_ARGS} depend)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/viewml ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/viewml
+ ${INSTALL_DATA} ${WRKSRC}/khtmlw_dnd.xpm ${PREFIX}/share/viewml
+
+.include <bsd.port.mk>
diff --git a/www/viewml/distinfo b/www/viewml/distinfo
new file mode 100644
index 000000000000..7502aa8baffc
--- /dev/null
+++ b/www/viewml/distinfo
@@ -0,0 +1 @@
+MD5 (viewml-0.21.tar.gz) = 0c34bdc70258f34a31f032270299b1f0
diff --git a/www/viewml/files/patch-Makefile b/www/viewml/files/patch-Makefile
new file mode 100644
index 000000000000..5c2196212fb5
--- /dev/null
+++ b/www/viewml/files/patch-Makefile
@@ -0,0 +1,98 @@
+--- Makefile.orig Thu Nov 9 01:42:05 2000
++++ Makefile Fri Apr 13 14:18:09 2001
+@@ -3,25 +3,25 @@
+
+ ifndef _NANOX
+ # your version of FLTK (1.0.7, please!)
+- FLTK = /home/davet/src/fltk/flmwin
++ FLTK = $(X11BASE)
+ else
+ # your version of Nano-X FLTK (0.88, please!)
+ FLTK = /home/jasonk/projects/flnx
+ endif
+
+ # Where your Xlibs are (not needed for Nano-X/Mwin builds)
+-XLIBS = -L/usr/X11R6/lib -lX11
++XLIBS = -L$(X11BASE)/lib -lX11
+
+ # Where Nano-X is (not needed if building for X only)
+ NANOX = /home/jasonk/projects/microwin
+
+ # Various support libraries
+-IMLIBS = `imlib-config --libs`
+-WWWLIBS = `/usr/bin/libwww-config --libs`
++IMLIBS = `$(X11BASE)/bin/imlib-config --libs`
++WWWLIBS = `$(LOCALBASE)/bin/libwww-config --libs`
+
+ # The everpresent CFLAGS
+ ifndef _NANOX
+- CFLAGS = -g `/usr/bin/libwww-config --cflags`
++ CFLAGS += `$(LOCALBASE)/bin/libwww-config --cflags`
+ else
+ CFLAGS = -g -DNANOX -D_NANOX `libwww-config --cflags`
+ endif
+@@ -32,7 +32,7 @@
+ ################################################################
+
+ ifndef _NANOX
+- LIBS = $(FLTK)/lib/libfltk.a -lfl $(XLIBS) -lpthread $(WWWLIBS) $(IMLIBS)
++ LIBS = $(FLTK)/lib/libfltk.a -lfl $(XLIBS) -pthread $(WWWLIBS) $(IMLIBS)
+ else
+ LIBS = $(FLTK)/lib/libfltk.a -lfl -lpthread $(NANOXLIBS) $(WWWLIBS)
+ endif
+@@ -40,7 +40,7 @@
+ KDEINC = -I../kdecore -I../kimgio -I../kdeui -I../jscript
+
+ ifndef _NANOX
+- INCLUDES = -I$(FLTK)/FL -I$(FLTK) -I./fltk -I. $(KDEINC)
++ INCLUDES = -I$(LOCALBASE)/include/w3c-libwww -I$(FLTK)/include/FL -I$(X11BASE)/include -I$(X11BASE)/include/X11 -I./fltk -I. $(KDEINC)
+ else
+ INCLUDES = -I$(FLTK)/FL -I$(FLTK) -I$(NANOX)/src/include -I./fltk -I. $(KDEINC)
+ endif
+@@ -48,17 +48,18 @@
+ CPPFILES = html.cpp htmlchain.cpp htmlclue.cpp htmldata.cpp htmlfont.cpp \
+ htmliter.cpp htmltable.cpp htmltoken.cpp jscript.cpp htmlview.cpp \
+ htmlframe.cpp htmlobj.cpp debug.cpp htmlform.cpp main.cpp http.cpp \
+- http_.cpp
++ http_.cpp vmlapp.cpp
+
+ OTHERCPP = ../kdecore/kurl.cpp ../kdeui/kcursor.cpp fltk/qtimer.cpp \
+ fltk/qobject.cpp fltk/qpainter.cpp fltk/qdrawutil.cpp \
+ fltk/qfont.cpp fltk/qrect.cpp fltk/qregexp.cpp fltk/qstring.cpp \
+ fltk/kcharsets.cpp fltk/qcolor.cpp fltk/qpixmap.cpp \
+- fltk/qfontinfo.cpp fltk/qwidget.cpp fltk/history.cpp fltk/qscrollbar.cpp
++ fltk/qfontinfo.cpp fltk/qwidget.cpp fltk/history.cpp fltk/qscrollbar.cpp \
++ fltk/drag.cpp fltk/qpushbutton.cpp fltk/qlineedit.cpp
+
+ OBJS = html.o htmlchain.o htmlclue.o htmldata.o htmlfont.o htmliter.o \
+ htmltable.o htmltoken.o jscript.o htmlview.o htmlframe.o htmlobj.o \
+- debug.o htmlform.o main.o http.o http_.o
++ debug.o htmlform.o main.o http.o http_.o vmlapp.o
+
+ OTHEROBJS = ../kdecore/kurl.o ../jscript/builtin.o ../jscript/cpp2bison.o \
+ ../jscript/jsexec.o ../jscript/jstree.o ../jscript/t2.o \
+@@ -66,7 +67,7 @@
+ fltk/qpainter.o fltk/qdrawutil.o fltk/qfont.o fltk/qrect.o \
+ fltk/qregexp.o fltk/qstring.o fltk/kcharsets.o fltk/qcolor.o \
+ fltk/qpixmap.o fltk/qfontinfo.o fltk/qwidget.o fltk/history.o \
+- fltk/qscrollbar.o
++ fltk/qscrollbar.o fltk/drag.o fltk/qpushbutton.o fltk/qlineedit.o
+
+ ################################################################
+
+@@ -75,13 +76,13 @@
+ all: jscript $(OBJS) $(OTHEROBJS) main
+
+ jscript:
+- cd ../jscript && make
++ cd ../jscript && $(MAKE)
+
+ main: $(OBJS) $(OTHEROBJS)
+ $(CXX) $(OBJS) $(OTHEROBJS) -o viewml $(LIBS)
+
+ depend:
+- makedepend -I/usr/include/g++2 -I/usr/include/g++2/std \
++ makedepend -I/usr/include/g++ -I/usr/include/g++/std \
+ $(INCLUDES) $(CPPFILES) $(OTHERCPP)
+
+ .SUFFIXES: .cpp .h .o
diff --git a/www/viewml/files/patch-config.h b/www/viewml/files/patch-config.h
new file mode 100644
index 000000000000..35a2cdb9b8b9
--- /dev/null
+++ b/www/viewml/files/patch-config.h
@@ -0,0 +1,7 @@
+
+$FreeBSD$
+
+--- /dev/null Fri Apr 13 12:29:44 2001
++++ config.h Fri Apr 13 12:29:40 2001
+@@ -0,0 +1 @@
++
diff --git a/www/viewml/files/patch-html.cpp b/www/viewml/files/patch-html.cpp
new file mode 100644
index 000000000000..e728f5f0e013
--- /dev/null
+++ b/www/viewml/files/patch-html.cpp
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- html.cpp 2001/04/13 15:30:05 1.1
++++ html.cpp 2001/04/13 15:31:44
+@@ -246,8 +246,8 @@
+
+ setBackgroundColor( lightGray );
+
+- QString f = kapp->kde_datadir().copy();
+- f += "/khtmlw/pics/khtmlw_dnd.xpm";
++ QString f = PREFIX;
++ f += "/share/viewml/khtmlw_dnd.xpm";
+ dndDefaultPixmap.load( f.data() );
+
+ registerFormats();
diff --git a/www/viewml/pkg-comment b/www/viewml/pkg-comment
new file mode 100644
index 000000000000..66789cd36f13
--- /dev/null
+++ b/www/viewml/pkg-comment
@@ -0,0 +1 @@
+An open source web browser targeted at the embedded platforms
diff --git a/www/viewml/pkg-descr b/www/viewml/pkg-descr
new file mode 100644
index 000000000000..c1cd915e424a
--- /dev/null
+++ b/www/viewml/pkg-descr
@@ -0,0 +1,17 @@
+ViewML (Viewable Markup Language) is the first freely available, open source
+web browser targeted specifically at the embedded platform. The web browser,
+known as The ViewML Project will be developed and maintained with source code
+made available to the public, as well as with contributions from the embedded
+community.
+
+As of now, the ViewML browser along with its interface requires 2.1 MB of RAM,
+with a small disk image foot-print requiring only 760K.
+
+The ViewML Project selected the KDE Desktop's kfm HTML display engine because
+of its superior design and display capabilities. The HTML engine was extracted,
+then ported, using a thin glue layer, to the small but fast FLTK (Fast Light
+Tool Kit, www.fltk.org) applications framework to keep the RAM usage extremely
+small, but still allows to fully implement all of the necessary user interface
+controls.
+
+WWW: http://www.viewml.com/
diff --git a/www/viewml/pkg-plist b/www/viewml/pkg-plist
new file mode 100644
index 000000000000..6ac5efbd62e4
--- /dev/null
+++ b/www/viewml/pkg-plist
@@ -0,0 +1,3 @@
+bin/viewml
+share/viewml/khtmlw_dnd.xpm
+@dirrm share/viewml