aboutsummaryrefslogtreecommitdiff
path: root/www/vtiger-customerportal
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-27 15:25:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-27 15:25:18 +0000
commit7e38f7f22bbb95d238ace43389a3f37453831f1b (patch)
tree53645f2bd45c3d95dc408ed2645e22f4229a1ccd /www/vtiger-customerportal
parent1177f8fa45cec5bb606d27888ba039bea4fba1dd (diff)
downloadports-7e38f7f22bbb95d238ace43389a3f37453831f1b.tar.gz
ports-7e38f7f22bbb95d238ace43389a3f37453831f1b.zip
Notes
Diffstat (limited to 'www/vtiger-customerportal')
-rw-r--r--www/vtiger-customerportal/Makefile58
-rw-r--r--www/vtiger-customerportal/distinfo3
-rw-r--r--www/vtiger-customerportal/files/pkg-message.in7
-rw-r--r--www/vtiger-customerportal/pkg-descr4
-rw-r--r--www/vtiger-customerportal/pkg-plist70
5 files changed, 142 insertions, 0 deletions
diff --git a/www/vtiger-customerportal/Makefile b/www/vtiger-customerportal/Makefile
new file mode 100644
index 000000000000..e908eecefe29
--- /dev/null
+++ b/www/vtiger-customerportal/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: www/vtiger-customerportal
+# Date created: 22 September 2007
+# Whom: Aron Schlesinger <as@bsdgroup.de>
+#
+# $FreeBSD$
+
+PORTNAME= customerportal
+PORTVERSION= 5.0.3
+CATEGORIES= www
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= vtigercrm
+PKGNAMEPREFIX= vtiger-
+DISTNAME= vtigercrm-customerportal-${DISTVERSION}
+
+MAINTAINER= as@bsdgroup.de
+COMMENT= Vtiger Customer Portal is an add-on package for vtiger CRM
+
+NO_BUILD= YES
+NO_WRKSUBDIR= YES
+
+VTIGERDIR?= ${PREFIX}/www/vtiger
+PORTALDIR?= ${PORTNAME}
+WWWDIR?= ${VTIGERDIR}/${PORTALDIR}
+
+RUN_DEPENDS+= ${VTIGERDIR}:${PORTSDIR}/www/vtiger
+
+USE_ZIP= YES
+SUB_FILES= pkg-message
+
+CONFIG= PortalConfig.php
+
+do-install:
+ @${FIND} ${WRKSRC} -type d | ${SED} 's,^${WRKSRC},${WWWDIR},' | ${XARGS} ${MKDIR}
+ @${FIND} -s ${WRKSRC} -type f -not -name '.*' -and -not \
+ -name ${CONFIG} -exec ${SH} -c '${INSTALL_DATA} -v {} \
+ $$(${ECHO} {} | ${SED} "s,^${WRKSRC},${WWWDIR},")' \;
+ ${INSTALL_DATA} ${WRKSRC}/${CONFIG} ${WWWDIR}/${CONFIG}.sample
+
+post-install:
+.if !exists(${WWWDIR}/${CONFIG})
+ ${INSTALL_DATA} ${WWWDIR}/${CONFIG}.sample ${WWWDIR}/${CONFIG}
+ @${CHMOD} u+w ${WWWDIR}/${CONFIG}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+create-plist:
+ @${FIND} -s ${WRKSRC} -type f -not -name '.*' -and -not -name ${CONFIG} \
+ | ${SED} -e 's,^${WRKSRC},%%WWWDIR%%,' > ${PLIST}
+ @${ECHO_CMD} '@unexec if cmp -s %D/%%WWWDIR%%/${CONFIG}.sample %D/%%WWWDIR%%/${CONFIG}; \
+ then ${RM} -f %D/%%WWWDIR%%/${CONFIG}; fi' >> ${PLIST}
+ @${ECHO_CMD} '%%WWWDIR%%/${CONFIG}.sample' >> ${PLIST}
+ @${ECHO_CMD} '@exec if [ ! -f %D/%%WWWDIR%%/${CONFIG} ]; then \
+ ${INSTALL_DATA} %D/%%WWWDIR%%/${CONFIG}.sample %D/%%WWWDIR%%/${CONFIG}; \
+ ${CHMOD} u+w %D/%%WWWDIR%%/${CONFIG}; fi' >> ${PLIST}
+ @${FIND} -ds ${WRKSRC} -type d \
+ | ${SED} -e 's,^${WRKSRC},@dirrm %%WWWDIR%%,' >> ${PLIST}
+
+.include <bsd.port.mk>
diff --git a/www/vtiger-customerportal/distinfo b/www/vtiger-customerportal/distinfo
new file mode 100644
index 000000000000..7c17b142e6f0
--- /dev/null
+++ b/www/vtiger-customerportal/distinfo
@@ -0,0 +1,3 @@
+MD5 (vtigercrm-customerportal-5.0.3.zip) = 107b7028c4826279f3e7132ab994a02a
+SHA256 (vtigercrm-customerportal-5.0.3.zip) = 10fc28e7ea7ab437dba014c83ec2c1c601ab604fc11866f56338dee65cda7988
+SIZE (vtigercrm-customerportal-5.0.3.zip) = 116446
diff --git a/www/vtiger-customerportal/files/pkg-message.in b/www/vtiger-customerportal/files/pkg-message.in
new file mode 100644
index 000000000000..d7af3152fd6e
--- /dev/null
+++ b/www/vtiger-customerportal/files/pkg-message.in
@@ -0,0 +1,7 @@
+***************************************************************************
+To finish the installation modify the PortalConfig.php file present
+under %%WWWDIR%%
+
+See documentation for more information:
+http://wiki.vtiger.com/index.php/Vtiger_Customer_Portal_5.0.3_-_User_Manual
+***************************************************************************
diff --git a/www/vtiger-customerportal/pkg-descr b/www/vtiger-customerportal/pkg-descr
new file mode 100644
index 000000000000..7c33acce809e
--- /dev/null
+++ b/www/vtiger-customerportal/pkg-descr
@@ -0,0 +1,4 @@
+vtiger Customer Portal is an add-on package for vtiger CRM, an Open
+Source Customer Relationship Management solution.
+
+WWW: http://wiki.vtiger.com/index.php/Vtiger_Customer_Portal_5.0.3_-_User_Manual
diff --git a/www/vtiger-customerportal/pkg-plist b/www/vtiger-customerportal/pkg-plist
new file mode 100644
index 000000000000..d405b5f220b1
--- /dev/null
+++ b/www/vtiger-customerportal/pkg-plist
@@ -0,0 +1,70 @@
+%%WWWDIR%%/Acknowledgment.txt
+%%WWWDIR%%/CustomerAuthenticate.php
+%%WWWDIR%%/Faq/FaqDetail.php
+%%WWWDIR%%/Faq/SaveFaqComment.php
+%%WWWDIR%%/Faq/Utils.php
+%%WWWDIR%%/Faq/index.html
+%%WWWDIR%%/Faq/index.php
+%%WWWDIR%%/INSTALLATION.txt
+%%WWWDIR%%/LICENSE_AGREEMENT.txt
+%%WWWDIR%%/MySettings.php
+%%WWWDIR%%/Tickets/NewTicket.php
+%%WWWDIR%%/Tickets/SaveTicket.php
+%%WWWDIR%%/Tickets/TicketDetail.php
+%%WWWDIR%%/Tickets/TicketSearch.php
+%%WWWDIR%%/Tickets/TicketsList.php
+%%WWWDIR%%/Tickets/Utils.php
+%%WWWDIR%%/Tickets/index.html
+%%WWWDIR%%/Tickets/index.php
+%%WWWDIR%%/css/dropdown.css
+%%WWWDIR%%/css/style.css
+%%WWWDIR%%/footer.html
+%%WWWDIR%%/header.html
+%%WWWDIR%%/images/category.gif
+%%WWWDIR%%/images/email.gif
+%%WWWDIR%%/images/faq.gif
+%%WWWDIR%%/images/favorite.gif
+%%WWWDIR%%/images/loginBg.gif
+%%WWWDIR%%/images/loginBgbig.gif
+%%WWWDIR%%/images/loginBgbig.jpg
+%%WWWDIR%%/images/loginBottomBg.gif
+%%WWWDIR%%/images/loginBottomURL.gif
+%%WWWDIR%%/images/loginBtnSignin.gif
+%%WWWDIR%%/images/loginSIBottomLeft.gif
+%%WWWDIR%%/images/loginSIBottomRight.gif
+%%WWWDIR%%/images/loginSITopLeft.gif
+%%WWWDIR%%/images/loginSITopRight.gif
+%%WWWDIR%%/images/loginTopBg.gif
+%%WWWDIR%%/images/loginTopShade.gif
+%%WWWDIR%%/images/loginVtigerCRM.gif
+%%WWWDIR%%/images/minus.gif
+%%WWWDIR%%/images/plus.gif
+%%WWWDIR%%/images/print.gif
+%%WWWDIR%%/images/products.gif
+%%WWWDIR%%/images/tabSeperatorBg.gif
+%%WWWDIR%%/images/vtiger-crm.gif
+%%WWWDIR%%/include.php
+%%WWWDIR%%/index.php
+%%WWWDIR%%/js/acdropdown.js
+%%WWWDIR%%/js/cookies.js
+%%WWWDIR%%/js/general.js
+%%WWWDIR%%/js/getobject2.js
+%%WWWDIR%%/js/modomt.js
+%%WWWDIR%%/language/en_us.lang.php
+%%WWWDIR%%/login.php
+%%WWWDIR%%/nusoap/lib/nusoap.php
+%%WWWDIR%%/pkg-message
+%%WWWDIR%%/supportpage.php
+%%WWWDIR%%/version.php
+@unexec if cmp -s %D/%%WWWDIR%%/PortalConfig.php.sample %D/%%WWWDIR%%/PortalConfig.php; then /bin/rm -f %D/%%WWWDIR%%/PortalConfig.php; fi
+%%WWWDIR%%/PortalConfig.php.sample
+@exec if [ ! -f %D/%%WWWDIR%%/PortalConfig.php ]; then install -o root -g wheel -m 444 %D/%%WWWDIR%%/PortalConfig.php.sample %D/%%WWWDIR%%/PortalConfig.php; /bin/chmod u+w %D/%%WWWDIR%%/PortalConfig.php; fi
+@dirrm %%WWWDIR%%/Faq
+@dirrm %%WWWDIR%%/Tickets
+@dirrm %%WWWDIR%%/css
+@dirrm %%WWWDIR%%/images
+@dirrm %%WWWDIR%%/js
+@dirrm %%WWWDIR%%/language
+@dirrm %%WWWDIR%%/nusoap/lib
+@dirrm %%WWWDIR%%/nusoap
+@dirrm %%WWWDIR%%