aboutsummaryrefslogtreecommitdiff
path: root/www/w3m/Makefile
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2004-11-17 18:24:46 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2004-11-17 18:24:46 +0000
commit8a3c88c719bfdb0e568f62b47711fedb138be844 (patch)
tree0fe1c1f542be6e042de197ebbd06907e8f31f9d4 /www/w3m/Makefile
parent5c3a3ec33d547ad415a56db0e3b40d91623ed810 (diff)
Read the options file of boehm-gc to check necessity of a thread library.
Notes
Notes: svn path=/head/; revision=121826
Diffstat (limited to 'www/w3m/Makefile')
-rw-r--r--www/w3m/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index 0246b570a6cc..e08be27aba63 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -82,7 +82,12 @@ CONFIGURE_ARGS+= --enable-keymap=lynx
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502102
+.if exists(${PORT_DBDIR}/boehm-gc/options)
+.include "${PORT_DBDIR}/boehm-gc/options"
+.endif
+
+.if defined(WITH_THREADING)
+.if ${OSVERSION} < 502102
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="${LIBS} ${PTHREAD_LIBS} -lc_r"
.else
@@ -93,6 +98,7 @@ CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="${LIBS} -lpthread -lc"
.endif
+.endif
pre-everything::
@${ECHO_MSG} "===>"