aboutsummaryrefslogtreecommitdiff
path: root/www/w3m
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2004-11-08 16:50:57 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2004-11-08 16:50:57 +0000
commit92cf45744c7c0538c93f013f4bcd0dd2afb0ab28 (patch)
tree34d7b487e5223623de4dbc3483b6672c24a661ff /www/w3m
parent57be3799e3a7d1baf4b36a808a89e8be807207fe (diff)
downloadports-92cf45744c7c0538c93f013f4bcd0dd2afb0ab28.tar.gz
ports-92cf45744c7c0538c93f013f4bcd0dd2afb0ab28.zip
Notes
Diffstat (limited to 'www/w3m')
-rw-r--r--www/w3m/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index adfb61c24670..409fda58ad52 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -86,8 +86,12 @@ CONFIGURE_ARGS+= --enable-keymap=lynx
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="${LIBS} ${PTHREAD_LIBS} -lc_r"
.else
+# Use -lpthread instead of ${PTHREAD_LIBS} to link libpthread
+# and libc before libgc.
+# This is necessary to avoid build error with boehm-gc with REDIRECT and
+# THREADING options.
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} ${PTHREAD_LIBS} -lc"
+ LIBS="${LIBS} -lpthread -lc"
.endif
pre-everything::