aboutsummaryrefslogtreecommitdiff
path: root/www/w3m
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-10-10 14:41:40 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-10-10 14:41:40 +0000
commitab0888474946627251c31d4ce46e98afc116465a (patch)
treef3d75fe049da395ea3763932298011f779e94958 /www/w3m
parent4f0d16a7d3f80741a3e093c7e3bd181152131ac5 (diff)
downloadports-ab0888474946627251c31d4ce46e98afc116465a.tar.gz
ports-ab0888474946627251c31d4ce46e98afc116465a.zip
Notes
Diffstat (limited to 'www/w3m')
-rw-r--r--www/w3m/Makefile2
-rw-r--r--www/w3m/files/patch-file.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index b92e53f0782b..4f3d7a0acd4c 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -7,7 +7,7 @@
PORTNAME= w3m
PORTVERSION= ${W3M_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= www ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/www/w3m/files/patch-file.c b/www/w3m/files/patch-file.c
new file mode 100644
index 000000000000..957e32f09c93
--- /dev/null
+++ b/www/w3m/files/patch-file.c
@@ -0,0 +1,12 @@
+--- file.c Sun Oct 9 22:12:16 2005
++++ file.c Sun Oct 9 22:11:10 2005
+@@ -262,7 +262,8 @@
+ {
+ return (type == NULL || type[0] == '\0' ||
+ strncasecmp(type, "text/", 5) == 0 ||
+- strncasecmp(type, "message/", sizeof("message/") - 1) == 0);
++ strncasecmp(type, "message/", sizeof("message/") - 1) == 0 ||
++ IS_HTML(type));
+ }
+
+ static int