aboutsummaryrefslogtreecommitdiff
path: root/www/w3m
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2007-02-03 17:42:00 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2007-02-03 17:42:00 +0000
commit216492f9de9cb4c781b1137b7c9814d9a9eb1745 (patch)
tree12e9498a6c8e5c4d9c5bda12f087014f873d74bf /www/w3m
parent532631db95ff2f8d795989960444c2225982a776 (diff)
downloadports-216492f9de9cb4c781b1137b7c9814d9a9eb1745.tar.gz
ports-216492f9de9cb4c781b1137b7c9814d9a9eb1745.zip
Respect PTHREAD_LIBS.
Submitted by: nork
Notes
Notes: svn path=/head/; revision=184047
Diffstat (limited to 'www/w3m')
-rw-r--r--www/w3m/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index 09e09eea95ae..ab7a9f9fae31 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -93,14 +93,14 @@ CONFIGURE_ARGS+= --enable-keymap=lynx
.if defined(WITH_THREADING)
.if ${OSVERSION} < 502102
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} ${PTHREAD_LIBS} -lc_r"
+ LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lc_r/}"
.else
# Use -lpthread instead of ${PTHREAD_LIBS} to link libpthread
# and libc before libgc.
# This is necessary to avoid build error with boehm-gc with REDIRECT and
# THREADING options.
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} -lpthread -lc"
+ LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lpthread/} -lc"
.endif
.else
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include"