aboutsummaryrefslogtreecommitdiff
path: root/www/wadcomblog
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-25 20:09:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-25 20:09:00 +0000
commit4fa309407168717595d782002530f0be6863f02f (patch)
tree26bf8bd6fca2150c4159637bfe456de9cfaadc7e /www/wadcomblog
parent6cbf77b498543f58452f9b9c8162292bc87c0847 (diff)
downloadports-4fa309407168717595d782002530f0be6863f02f.tar.gz
ports-4fa309407168717595d782002530f0be6863f02f.zip
Notes
Diffstat (limited to 'www/wadcomblog')
-rw-r--r--www/wadcomblog/Makefile33
-rw-r--r--www/wadcomblog/distinfo3
-rw-r--r--www/wadcomblog/pkg-descr9
-rw-r--r--www/wadcomblog/pkg-plist27
4 files changed, 72 insertions, 0 deletions
diff --git a/www/wadcomblog/Makefile b/www/wadcomblog/Makefile
new file mode 100644
index 000000000000..84f0a0040b47
--- /dev/null
+++ b/www/wadcomblog/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: wadcomblog
+# Date created: 2008-10-09
+# Whom: Julien Laffaye <kimelto@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WadcomBlog
+PORTVERSION= 0.3
+CATEGORIES= www python
+MASTER_SITES= http://laffaye.free.fr/distfiles/ \
+ http://vss.73rus.com/wadcomblog/files/
+
+MAINTAINER= kimelto@gmail.com
+COMMENT= Simple open-source static blog engine written in Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ @${ECHO_MSG} "installing additional examples to ${EXAMPLESDIR}"
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/sample/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/wadcomblog/distinfo b/www/wadcomblog/distinfo
new file mode 100644
index 000000000000..16f64c49a92f
--- /dev/null
+++ b/www/wadcomblog/distinfo
@@ -0,0 +1,3 @@
+MD5 (WadcomBlog-0.3.tar.gz) = e5981401fb21a5f541b33a9a8f8cea43
+SHA256 (WadcomBlog-0.3.tar.gz) = 350c16448bd7939a4df851634a065c36ce7a0b46294e28504581eed5d899f4e9
+SIZE (WadcomBlog-0.3.tar.gz) = 19801
diff --git a/www/wadcomblog/pkg-descr b/www/wadcomblog/pkg-descr
new file mode 100644
index 000000000000..234ada2ab5be
--- /dev/null
+++ b/www/wadcomblog/pkg-descr
@@ -0,0 +1,9 @@
+WadcomBlog is a simple open-source static blog engine written in Python
+by Vlad Skvortsov and distributed under BSD license.
+It doesn't use any backend database but instead reads a set of plain i
+text files (in RFC2822 format) and creates a tree of interlinked HTML pages
+that may be then published. To update a blog one just needs to add a file
+to the source tree and run the command-line WadcomBlog script
+to regenerate the output.
+
+WWW: http://vss.73rus.com/wadcomblog/
diff --git a/www/wadcomblog/pkg-plist b/www/wadcomblog/pkg-plist
new file mode 100644
index 000000000000..a66957484048
--- /dev/null
+++ b/www/wadcomblog/pkg-plist
@@ -0,0 +1,27 @@
+bin/wadcomblog.py
+bin/wblg-mk-redirects.py
+bin/wblg-new.py
+%%PYTHON_SITELIBDIR%%/lib/__init__.py
+%%PYTHON_SITELIBDIR%%/lib/ezt.py
+%%PYTHON_SITELIBDIR%%/lib/__init__.pyc
+%%PYTHON_SITELIBDIR%%/lib/ezt.pyc
+%%PYTHON_SITELIBDIR%%/lib/__init__.pyo
+%%PYTHON_SITELIBDIR%%/lib/ezt.pyo
+@dirrmtry %%PYTHON_SITELIBDIR%%/lib
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/my.wblg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/static/license.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/static/resume.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/swa/one-entry/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/templates/entry-header.ezt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/templates/entry.ezt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/templates/feed.ezt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/templates/index.ezt
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/src/templates
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/src/swa/one-entry
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/src/swa
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/src/static
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/src
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%