aboutsummaryrefslogtreecommitdiff
path: root/www/waterfox
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-03-21 22:53:55 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-03-21 22:53:55 +0000
commit790a792705f01682db3af961f50e072be671928c (patch)
tree5ef69f5bd27701f0447c54f75da7f98c6ea7c762 /www/waterfox
parentb3a200b757f51606e4bc8d0d0de57dd74bf487aa (diff)
downloadports-790a792705f01682db3af961f50e072be671928c.tar.gz
ports-790a792705f01682db3af961f50e072be671928c.zip
Notes
Diffstat (limited to 'www/waterfox')
-rw-r--r--www/waterfox/Makefile7
-rw-r--r--www/waterfox/distinfo6
-rw-r--r--www/waterfox/files/patch-a-bug139328447
-rw-r--r--www/waterfox/files/patch-bug137727838
-rw-r--r--www/waterfox/files/patch-z-bug86879758
5 files changed, 156 insertions, 0 deletions
diff --git a/www/waterfox/Makefile b/www/waterfox/Makefile
index 9218fcdf979f..d5c5a1840018 100644
--- a/www/waterfox/Makefile
+++ b/www/waterfox/Makefile
@@ -3,8 +3,15 @@
PORTNAME= waterfox
DISTVERSION= 56.0.4-72
DISTVERSIONSUFFIX= -ga9c77bbb9f25
+PORTREVISION= 1
CATEGORIES= www ipv6
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= ad38ad1b4750.patch:-p1 \
+ 557f604cc4b3.patch:-p1 \
+ 75c3dd6b9888.patch:-p1 \
+ ${NULL}
+
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Distilled fork of Firefox
diff --git a/www/waterfox/distinfo b/www/waterfox/distinfo
index a8af16eb85d7..7d071c34767d 100644
--- a/www/waterfox/distinfo
+++ b/www/waterfox/distinfo
@@ -1,3 +1,9 @@
TIMESTAMP = 1521489939
SHA256 (MrAlex94-Waterfox-56.0.4-72-ga9c77bbb9f25_GH0.tar.gz) = 5f492fa42d46cb90c06ac7129a28afff7b979170f13461747deffd77faa03bb4
SIZE (MrAlex94-Waterfox-56.0.4-72-ga9c77bbb9f25_GH0.tar.gz) = 394039973
+SHA256 (ad38ad1b4750.patch) = e012573f35c6eb57730f3de790808edcab03a452f6e89ead972648bb68c3b3f5
+SIZE (ad38ad1b4750.patch) = 621136
+SHA256 (557f604cc4b3.patch) = 369c1cc78d9e82351fdf01cc4246d02ea2571a4ce4b1002d10288e4dfb83994a
+SIZE (557f604cc4b3.patch) = 1719
+SHA256 (75c3dd6b9888.patch) = 5fe2322a643551843d4896c413b39eb8eadd29d7cea3f14599a58d398b1beda7
+SIZE (75c3dd6b9888.patch) = 444694
diff --git a/www/waterfox/files/patch-a-bug1393284 b/www/waterfox/files/patch-a-bug1393284
new file mode 100644
index 000000000000..7f8c03641675
--- /dev/null
+++ b/www/waterfox/files/patch-a-bug1393284
@@ -0,0 +1,47 @@
+commit bbc0805e28db
+Author: Matthew Gregan <kinetik@flim.org>
+Date: Thu Aug 24 16:18:34 2017 +1200
+
+ Bug 1393284 - Update libnestegg to 369d153. r=rillian
+ From 94bad012a2d4ec824d751c574443e3946187c4ea Mon Sep 17 00:00:00 2001
+---
+ media/libnestegg/README_MOZILLA | 2 +-
+ media/libnestegg/include/nestegg.h | 1 +
+ media/libnestegg/src/nestegg.c | 2 +-
+ 3 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git media/libnestegg/README_MOZILLA media/libnestegg/README_MOZILLA
+index b48a8341801d..384a2874d137 100644
+--- media/libnestegg/README_MOZILLA
++++ media/libnestegg/README_MOZILLA
+@@ -5,4 +5,4 @@ Makefile.in build files for the Mozilla build system.
+
+ The nestegg git repository is: https://github.com/kinetiknz/nestegg
+
+-The git commit ID used was af26fc354ec9eadf5fcd34fb01223be3f6f8a773.
++The git commit ID used was 369d153d5d176f58e2742fc843b3ed134d7c64f4.
+diff --git media/libnestegg/include/nestegg.h media/libnestegg/include/nestegg.h
+index 32fc7d602491..998df9e78e78 100644
+--- media/libnestegg/include/nestegg.h
++++ media/libnestegg/include/nestegg.h
+@@ -249,6 +249,7 @@ int nestegg_track_type(nestegg * context, unsigned int track);
+ @param track Zero based track number.
+ @retval #NESTEGG_CODEC_VP8 Track codec is VP8.
+ @retval #NESTEGG_CODEC_VP9 Track codec is VP9.
++ @retval #NESTEGG_CODEC_AV1 Track codec is AV1.
+ @retval #NESTEGG_CODEC_VORBIS Track codec is Vorbis.
+ @retval #NESTEGG_CODEC_OPUS Track codec is Opus.
+ @retval #NESTEGG_CODEC_UNKNOWN Track codec is unknown.
+diff --git media/libnestegg/src/nestegg.c media/libnestegg/src/nestegg.c
+index d9be77aaca1b..b9283c31f5b2 100644
+--- media/libnestegg/src/nestegg.c
++++ media/libnestegg/src/nestegg.c
+@@ -2174,7 +2174,7 @@ nestegg_duration(nestegg * ctx, uint64_t * duration)
+ return -1;
+
+ if (unscaled_duration != unscaled_duration ||
+- unscaled_duration < 0 || unscaled_duration > (double) UINT64_MAX ||
++ unscaled_duration < 0 || unscaled_duration >= (double) UINT64_MAX ||
+ (uint64_t) unscaled_duration > UINT64_MAX / tc_scale)
+ return -1;
+
diff --git a/www/waterfox/files/patch-bug1377278 b/www/waterfox/files/patch-bug1377278
new file mode 100644
index 000000000000..add365cf67bf
--- /dev/null
+++ b/www/waterfox/files/patch-bug1377278
@@ -0,0 +1,38 @@
+commit e7cf058cbba3
+Author: Alfredo.Yang <ayang@mozilla.com>
+Date: Tue Aug 29 15:33:26 2017 +0800
+
+ Bug 1377278 - accept 'matroska' as webm doctype. r=kinetik
+
+ MozReview-Commit-ID: 3SCOrecahPB
+
+ --HG--
+ extra : rebase_source : c94cbc48f0d850f9df19fe4c85066ca594164853
+---
+ media/libnestegg/README_MOZILLA | 2 +-
+ media/libnestegg/src/nestegg.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git media/libnestegg/README_MOZILLA media/libnestegg/README_MOZILLA
+index 384a2874d137..979b4e936dfe 100644
+--- media/libnestegg/README_MOZILLA
++++ media/libnestegg/README_MOZILLA
+@@ -5,4 +5,4 @@ Makefile.in build files for the Mozilla build system.
+
+ The nestegg git repository is: https://github.com/kinetiknz/nestegg
+
+-The git commit ID used was 369d153d5d176f58e2742fc843b3ed134d7c64f4.
++The git commit ID used was 017f480db78bcdc607e6dba36cef806b793edf2c.
+diff --git media/libnestegg/src/nestegg.c media/libnestegg/src/nestegg.c
+index b9283c31f5b2..133732e481bc 100644
+--- media/libnestegg/src/nestegg.c
++++ media/libnestegg/src/nestegg.c
+@@ -2115,7 +2115,7 @@ nestegg_init(nestegg ** context, nestegg_io io, nestegg_log callback, int64_t ma
+
+ if (ne_get_string(ctx->ebml.doctype, &doctype) != 0)
+ doctype = "matroska";
+- if (strcmp(doctype, "webm") != 0) {
++ if (!!strcmp(doctype, "webm") && !!strcmp(doctype, "matroska")) {
+ nestegg_destroy(ctx);
+ return -1;
+ }
diff --git a/www/waterfox/files/patch-z-bug868797 b/www/waterfox/files/patch-z-bug868797
new file mode 100644
index 000000000000..6338015e6f8a
--- /dev/null
+++ b/www/waterfox/files/patch-z-bug868797
@@ -0,0 +1,58 @@
+commit 3114bcb097ba
+Author: Bryce Van Dyk <bvandyk@mozilla.com>
+Date: Wed Feb 28 16:34:05 2018 -0500
+
+ Bug 868797 - Update libnestegg to be more tolerant of blocks with negative timecodes. r=kinetik
+
+ Bump nestegg to commit 89ed0daf2edccb25f744e5faff88b8b4684adceb. This brings
+ across tolerance of blocks with negative timecodes. Instead of rejecting these
+ the timecodes are now set to 0.
+
+ Also brings across a change to appease clang in ne_read_block_additions by
+ adding an explicit assignment to data_size.
+
+ MozReview-Commit-ID: 7J8YPUUwSBp
+
+ --HG--
+ extra : rebase_source : f55bd987465baf21f383095b60e9148349936fef
+---
+ media/libnestegg/README_MOZILLA | 2 +-
+ media/libnestegg/src/nestegg.c | 8 ++++++--
+ 2 files changed, 7 insertions(+), 3 deletions(-)
+
+diff --git media/libnestegg/README_MOZILLA media/libnestegg/README_MOZILLA
+index 979b4e936dfe..632bbfaedbe0 100644
+--- media/libnestegg/README_MOZILLA
++++ media/libnestegg/README_MOZILLA
+@@ -5,4 +5,4 @@ Makefile.in build files for the Mozilla build system.
+
+ The nestegg git repository is: https://github.com/kinetiknz/nestegg
+
+-The git commit ID used was 017f480db78bcdc607e6dba36cef806b793edf2c.
++The git commit ID used was 89ed0daf2edccb25f744e5faff88b8b4684adceb.
+diff --git media/libnestegg/src/nestegg.c media/libnestegg/src/nestegg.c
+index 133732e481bc..c8939f634210 100644
+--- media/libnestegg/src/nestegg.c
++++ media/libnestegg/src/nestegg.c
+@@ -1550,8 +1550,11 @@ ne_read_block(nestegg * ctx, uint64_t block_id, uint64_t block_size, nestegg_pac
+ cluster_tc = ctx->cluster_timecode;
+
+ abs_timecode = timecode + cluster_tc;
+- if (abs_timecode < 0)
+- return -1;
++ if (abs_timecode < 0) {
++ /* Ignore the spec and negative timestamps */
++ ctx->log(ctx, NESTEGG_LOG_WARNING, "ignoring negative timecode: %lld", abs_timecode);
++ abs_timecode = 0;
++ }
+
+ pkt = ne_alloc(sizeof(*pkt));
+ if (!pkt)
+@@ -1686,6 +1689,7 @@ ne_read_block_additions(nestegg * ctx, uint64_t block_size, struct block_additio
+ add_id = 1;
+ data = NULL;
+ has_data = 0;
++ data_size = 0;
+ r = ne_read_element(ctx, &id, &size);
+ if (r != 1)
+ return r;