aboutsummaryrefslogtreecommitdiff
path: root/www/web2ldap/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-08 17:02:20 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-08 17:02:20 +0000
commit12508d5f1509268f04597ad9f12b5633a8b4ad32 (patch)
tree46f8b76ae8a919b6aab37964638f57dd9e31bff3 /www/web2ldap/Makefile
parentebbfc6fe5ccd164744a0ea6ffe7a70e2ea2a9358 (diff)
- Update to 0.15.10 [1]
- Use SUB_FILES=pkg-message - Make the package installation behave like the port's - Polish the Makefile PR: ports/80783 [1] Submitted by: maintainer [1]
Notes
Notes: svn path=/head/; revision=134869
Diffstat (limited to 'www/web2ldap/Makefile')
-rw-r--r--www/web2ldap/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/www/web2ldap/Makefile b/www/web2ldap/Makefile
index 5610060996ac..ef84152c6c1e 100644
--- a/www/web2ldap/Makefile
+++ b/www/web2ldap/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= web2ldap
-PORTVERSION= 0.15.9
+PORTVERSION= 0.15.10
CATEGORIES= www
MASTER_SITES= http://www.web2ldap.de/download/ \
http://www.tricknology.org/ports/
@@ -19,16 +19,18 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_ldap.so:${PORTSDIR}/net/py-ldap2
NO_BUILD= yes
USE_PYTHON= yes
+SUB_FILES= pkg-message
+
do-install:
@${MKDIR} ${PREFIX}/${PORTNAME}
- @${RM} -f ${WRKDIR}/${PORTNAME}-${PORTVERSION}/fcgi/web2ldap.py.orig
- @${RM} -f ${WRKDIR}/${PORTNAME}-${PORTVERSION}/scgi/web2ldap.py.orig
- @${RM} -f ${WRKDIR}/${PORTNAME}-${PORTVERSION}/etc/web2ldap/web2ldapcnf/standalone.py.orig
- @${RM} -f ${WRKDIR}/${PORTNAME}-${PORTVERSION}/etc/mime.types.orig
- @${RM} -f ${WRKDIR}/${PORTNAME}-${PORTVERSION}/sbin/compile.py.orig
- @${RM} -f ${WRKDIR}/${PORTNAME}-${PORTVERSION}/sbin/web2ldap.py.orig
+ @${RM} -f ${WRKSRC}/fcgi/web2ldap.py.orig
+ @${RM} -f ${WRKSRC}/scgi/web2ldap.py.orig
+ @${RM} -f ${WRKSRC}/etc/web2ldap/web2ldapcnf/standalone.py.orig
+ @${RM} -f ${WRKSRC}/etc/mime.types.orig
+ @${RM} -f ${WRKSRC}/sbin/compile.py.orig
+ @${RM} -f ${WRKSRC}/sbin/web2ldap.py.orig
@(cd ${WRKSRC} && ${LOCALBASE}/bin/python ./sbin/compile.py)
- @${CP} -r ${WRKDIR}/${PORTNAME}-${PORTVERSION}/ ${PREFIX}/${PORTNAME}
+ @${CP} -r ${WRKSRC}/ ${PREFIX}/${PORTNAME}
@if [ -w /var/log ]; then ${MKDIR} /var/log/web2ldap; fi
post-install: