aboutsummaryrefslogtreecommitdiff
path: root/www/webcalendar
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-06-15 03:01:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-06-15 03:01:17 +0000
commit378368be966af35cafd03ffe0ed98f024fafc2f0 (patch)
tree5997adf047ba689f06bbcf7252a306b86c5f3e06 /www/webcalendar
parent733a50e555ccdefffc47ef94123455ec812ce4d0 (diff)
downloadports-378368be966af35cafd03ffe0ed98f024fafc2f0.tar.gz
ports-378368be966af35cafd03ffe0ed98f024fafc2f0.zip
Notes
Diffstat (limited to 'www/webcalendar')
-rw-r--r--www/webcalendar/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/www/webcalendar/Makefile b/www/webcalendar/Makefile
index d53cd59c9e16..6060614f2bfc 100644
--- a/www/webcalendar/Makefile
+++ b/www/webcalendar/Makefile
@@ -32,10 +32,8 @@ OPTIONS_DEFAULT= MYSQL
DB_DESC= Database backend
DBASE_DESC= DBase database support
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:tl}
PORTDOCS= README \
WebCalendar-Database.html \
@@ -43,7 +41,6 @@ PORTDOCS= README \
WebCalendar-Styling.html \
WebCalendar-SysAdmin.html \
newwin.gif
-.endif
.if ${PORT_OPTIONS:MMYSQL}
USE_PHP+= mysql
@@ -83,17 +80,19 @@ pre-install:
@${ECHO_CMD} @dirrmtry www/data >> ${PLIST}
do-install:
- @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${PREFIX}/${WCDIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${WCDIR}
- @${FIND} ${PREFIX}/${WCDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${WCDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${WCDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${PREFIX}/${WCDIR}
+ @${FIND} ${STAGEDIR}${PREFIX}/${WCDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
@${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
${WCDIR:S|^|%D/|}' >> ${TMPPLIST}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/www/data \
+ ${STAGEDIR}${PREFIX}/www/data-dist
+ @${ECHO_CMD} '@dirrmtry www/data' >> ${TMPPLIST}
+ @${ECHO_CMD} '@dirrmtry www/data-dist' >> ${TMPPLIST}
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/docs && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC}/docs && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>