aboutsummaryrefslogtreecommitdiff
path: root/www/webcheck/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-07-13 01:51:30 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-07-13 01:51:30 +0000
commit0a9c19624a7535c6246e8a7ab17e450065726cde (patch)
tree79a6bcd7a36595978e17fe06555d6fcacff4ee53 /www/webcheck/Makefile
parent511e78f897e31e79991a6fadb40a01b2f1a71160 (diff)
Notes
Diffstat (limited to 'www/webcheck/Makefile')
-rw-r--r--www/webcheck/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/www/webcheck/Makefile b/www/webcheck/Makefile
index a2a6ab74655e..e41899f6f48f 100644
--- a/www/webcheck/Makefile
+++ b/www/webcheck/Makefile
@@ -7,17 +7,15 @@
PORTNAME= linbot
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/www/misc
EXTRACT_SUFX= .tgz
-MAINTAINER= billf@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
-
-NO_BUILD= yeah
+RUN_DEPENDS= python:${PORTSDIR}/lang/python15
do-install:
${MKDIR} ${PREFIX}/share/linbot
@@ -28,5 +26,15 @@ do-install:
${CP} ${WRKSRC}/${d}/*.py ${PREFIX}/share/linbot/${d}
.endfor
${LN} -sf ${PREFIX}/share/linbot/linbot.py ${PREFIX}/bin/linbot
+.ifndef NOPORTDOCS
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/USAGE ${DOCSDIR}
+
+do-build:
+ ${AWK} '/^Running Linbot/ { output=1 } output' \
+ < ${WRKSRC}/INSTALL > ${WRKSRC}/USAGE
+.else
+NO_BUILD= yeah
+.endif
.include <bsd.port.mk>