aboutsummaryrefslogtreecommitdiff
path: root/www/webcrawl
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-11-08 06:48:32 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-11-08 06:48:32 +0000
commit8cf924ca68b9719d203210487f1a2bb878c0339c (patch)
treee1241e9cf96ab76d75310cf4d5824c19ad1dd1c7 /www/webcrawl
parent30458d205e2c3fd1fcceefdb17bc4855a0c8ac98 (diff)
downloadports-8cf924ca68b9719d203210487f1a2bb878c0339c.tar.gz
ports-8cf924ca68b9719d203210487f1a2bb878c0339c.zip
Notes
Diffstat (limited to 'www/webcrawl')
-rw-r--r--www/webcrawl/Makefile1
-rw-r--r--www/webcrawl/files/patch-http.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/www/webcrawl/Makefile b/www/webcrawl/Makefile
index b1115668e8c0..915b48b9a69b 100644
--- a/www/webcrawl/Makefile
+++ b/www/webcrawl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= webcrawl
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/www/mirroring
diff --git a/www/webcrawl/files/patch-http.c b/www/webcrawl/files/patch-http.c
new file mode 100644
index 000000000000..bc988f9957df
--- /dev/null
+++ b/www/webcrawl/files/patch-http.c
@@ -0,0 +1,12 @@
+--- http.c Fri Apr 30 12:04:19 1999
++++ http.c.new Tue Nov 6 13:28:06 2001
+@@ -106,8 +106,7 @@
+ alarm(options.timeout);
+ }
+
+- strcpy (szRequest, "GET /"); strcat (szRequest, pszFile);
+- strcat (szRequest, " HTTP/1.0\n");
++ snprintf (szRequest, 512, "GET http://%s/%s HTTP/1.0\n", pszHost, pszFile);
+ strcat (szRequest, "User-Agent: ");
+ strcat (szRequest, options.userAgent);
+ strcat (szRequest, "\n\n");