aboutsummaryrefslogtreecommitdiff
path: root/www/webfs/Makefile
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2001-01-05 18:23:08 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2001-01-05 18:23:08 +0000
commit9a60e81fb3006d593ea91d8bf0214d5f26c18642 (patch)
tree33dc29216a5fb905a7857cb0001dbd8f3e35f589 /www/webfs/Makefile
parent3a5e6954a765ddc8853cbff662fb095d33da4ea0 (diff)
downloadports-9a60e81fb3006d593ea91d8bf0214d5f26c18642.tar.gz
ports-9a60e81fb3006d593ea91d8bf0214d5f26c18642.zip
Notes
Diffstat (limited to 'www/webfs/Makefile')
-rw-r--r--www/webfs/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/www/webfs/Makefile b/www/webfs/Makefile
index 50d3d3e44aa5..f7b043a63f56 100644
--- a/www/webfs/Makefile
+++ b/www/webfs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= webfs
PORTVERSION= 1.6
-CATEGORIES= www
+CATEGORIES= www ipv6
MASTER_SITES= http://www.strusel007.de/linux/misc/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -16,6 +16,12 @@ MAINTAINER= jedgar@FreeBSD.org
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
MAN1= webfsd.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} <= 400000
+BROKEN= "Requires FreeBSD 4.x or greater due to ipv6 support"
+.endif
+
do-configure:
@${CP} ${WRKSRC}/webfsd.man ${WRKSRC}/webfsd.1
.for file in webfsd.1 main.c Makefile
@@ -30,4 +36,4 @@ do-install:
@${ECHO} "# Insert mime types here" > ${PREFIX}/etc/webfsd/mime.types
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>