aboutsummaryrefslogtreecommitdiff
path: root/www/webgo
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-11-25 06:23:27 +0000
committerWen Heping <wen@FreeBSD.org>2010-11-25 06:23:27 +0000
commit74622cef8ec008a08944385d845859d50e00784e (patch)
tree26a5e4eed8be96f2d22f8a889f9b5468222a3095 /www/webgo
parentf82af8989d60fc5d95eb4a9c69d35cd8378c849f (diff)
downloadports-74622cef8ec008a08944385d845859d50e00784e.tar.gz
ports-74622cef8ec008a08944385d845859d50e00784e.zip
Notes
Diffstat (limited to 'www/webgo')
-rw-r--r--www/webgo/Makefile25
-rw-r--r--www/webgo/distinfo2
-rw-r--r--www/webgo/pkg-descr17
3 files changed, 44 insertions, 0 deletions
diff --git a/www/webgo/Makefile b/www/webgo/Makefile
new file mode 100644
index 000000000000..9d0fa7cce711
--- /dev/null
+++ b/www/webgo/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: webgo
+# Date created: Nov 22, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webgo
+PORTVERSION= 0.1.0.${SVNVERSION}
+CATEGORIES= www
+MASTER_SITES= LOCAL/wen
+DISTNAME= ${PORTNAME}-${SVNVERSION}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Simplest way to write web applications in the Go programming language
+
+SVNVERSION= 20101122
+WRKSRC= ${WRKDIR}/web.go
+PLIST_FILES= ${GO_LIBDIR}/web.a
+
+USE_GO= yes
+
+.include <bsd.port.pre.mk>
+.include "../../lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/www/webgo/distinfo b/www/webgo/distinfo
new file mode 100644
index 000000000000..6ec326b50e49
--- /dev/null
+++ b/www/webgo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (webgo-20101122.tar.gz) = dc9b1754f623ae6b91da8714ccbe11fcfefe1a32b496a9550901cbc3b1824c0c
+SIZE (webgo-20101122.tar.gz) = 147679
diff --git a/www/webgo/pkg-descr b/www/webgo/pkg-descr
new file mode 100644
index 000000000000..6ab7b25f7416
--- /dev/null
+++ b/www/webgo/pkg-descr
@@ -0,0 +1,17 @@
+web.go is the simplest way to write web applications in the Go programming
+language. It's ideal for writing simple, performant backend web services.
+
+web.go should be familiar to people who've developed websites with higher-level
+web frameworks like sinatra, pylons, or web.py. It is designed to be a
+lightweight web framework that doesn't impose any scaffolding on the user.
+
+Some features include:
+
+ * Routing to url handlers based on regular expressions
+ * Secure cookies
+ * Support for fastcgi and scgi
+ * Web applications are compiled to native code. This means very fast
+execution and page render speed
+ * Serving static files
+
+WWW: https://github.com/hoisie/web.go