aboutsummaryrefslogtreecommitdiff
path: root/www/webkit-gtk2/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-13 07:59:13 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-13 07:59:13 +0000
commit1ed005506f0347193918e9e02d9c8b718de2e11d (patch)
treec019647ca7be852e9ab6fc66735c160c32d6ece4 /www/webkit-gtk2/Makefile
parentfa0d8e0c18b2ef6f67e8957fb8bbde290278bd20 (diff)
downloadports-1ed005506f0347193918e9e02d9c8b718de2e11d.tar.gz
ports-1ed005506f0347193918e9e02d9c8b718de2e11d.zip
Notes
Diffstat (limited to 'www/webkit-gtk2/Makefile')
-rw-r--r--www/webkit-gtk2/Makefile45
1 files changed, 30 insertions, 15 deletions
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index 14955277e05d..27e8d2245296 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -1,11 +1,11 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/www/webkit-gtk2/Makefile,v 1.80 2011/07/11 10:14:46 kwm Exp $
+# $MCom: ports/www/webkit-gtk2/Makefile,v 1.92 2013/03/09 09:12:39 kwm Exp $
+
PORTNAME= webkit
-PORTVERSION= 1.4.3
-PORTREVISION= 2
+PORTVERSION= 1.8.3
CATEGORIES= www
-MASTER_SITES= http://webkitgtk.org/
+MASTER_SITES= http://webkitgtk.org/releases/
PKGNAMESUFFIX= -gtk2
MAINTAINER= gnome@FreeBSD.org
@@ -13,48 +13,63 @@ COMMENT= An opensource browser engine
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
+ gtkdoc-rebase:${PORTSDIR}/textproc/gtk-doc \
g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant \
+LIB_DEPENDS= enchant:${PORTSDIR}/textproc/enchant \
icutu:${PORTSDIR}/devel/icu \
- curl.6:${PORTSDIR}/ftp/curl \
- sqlite3.8:${PORTSDIR}/databases/sqlite3 \
- soup-2.4.1:${PORTSDIR}/devel/libsoup
+ curl:${PORTSDIR}/ftp/curl \
+ soup-2.4:${PORTSDIR}/devel/libsoup
+USE_XZ= yes
USE_GETTEXT= yes
USE_GSTREAMER= yes
MAKE_JOBS_SAFE= yes
-USE_XORG= xt xrender
+USE_XORG= xt
USES= bison
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_GNOME= gtk20 libxslt ltverhack
USE_PKGCONFIG= build
+USE_SQLITE= yes
USE_PERL5= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_FLEX="${LOCALBASE}/bin/flex" \
+ ZLIB_CFLAGS="-I/usr/include" \
+ ZLIB_LIBS="-L/usr/lib -lz" \
ac_cv_path_DOLT_BASH=""
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --enable-icon-database \
- --with-gtk=2.0 \
+CONFIGURE_ARGS= --with-gtk=2.0 \
+ --enable-svg-fonts \
+ --disable-geolocation \
--enable-introspection
MAKEFILE= GNUmakefile
-GLIB_SCHEMAS= org.webkitgtk-1.0.gschema.xml
BROWSER_PLUGINS_DIR?= ${LOCALBASE}/lib/browser_plugins/symlinks/webkit-gtk2
#_BROWSER_PLUGINS_DIR= ${BROWSER_PLUGINS_DIR:S|^/|"|:S|/|", "|g}",
-OPTIONS= DEBUG "Build with debug support" off
+OPTIONS_DEFINE= WEBGL DEBUG
+OPTIONS_DEFAULT=WEBGL
+WEBGL_DESC= Enable Web GL support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MWEBGL}
+USE_GL= gl
+CONFIGURE_ARGS+=--enable-webgl
+.else
+CONFIGURE_ARGS+=--disable-webgl
+.endif
+
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
.else
CONFIGURE_ARGS+=--disable-debug
.endif
+.include <bsd.port.pre.mk>
+
.if ${ARCH} == powerpc64
CFLAGS+= -mminimal-toc
.endif