aboutsummaryrefslogtreecommitdiff
path: root/www/webkit-gtk2
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-10-14 16:08:10 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-10-14 16:08:10 +0000
commitea1d6eb46087a625b72e8f59622ea0c3574e37e0 (patch)
treefe46b1bdc539941932f24e002920dd6f49d9f71b /www/webkit-gtk2
parent35bcff841b51a8280e4e3f337e54dedd4ae2b236 (diff)
downloadports-ea1d6eb46087a625b72e8f59622ea0c3574e37e0.tar.gz
ports-ea1d6eb46087a625b72e8f59622ea0c3574e37e0.zip
Notes
Diffstat (limited to 'www/webkit-gtk2')
-rw-r--r--www/webkit-gtk2/Makefile7
-rw-r--r--www/webkit-gtk2/distinfo4
-rw-r--r--www/webkit-gtk2/files/patch-Source_WebCore_plugins_gtk_PluginViewGtk.cpp18
-rw-r--r--www/webkit-gtk2/files/patch-Source_WebKit_gtk_webkit_webkitwebview.cpp22
4 files changed, 44 insertions, 7 deletions
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index e95843bca9a2..562409e41541 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= webkit
-PORTVERSION= 1.4.2
-PORTREVISION= 1
+PORTVERSION= 1.4.3
CATEGORIES= www
MASTER_SITES= http://webkitgtk.org/
PKGNAMESUFFIX= -gtk2
@@ -28,7 +27,7 @@ LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant \
USE_GETTEXT= yes
WANT_GSTREAMER= yes
MAKE_JOBS_SAFE= yes
-USE_XORG= xt
+USE_XORG= xt xrender
USE_BISON= build
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
@@ -42,8 +41,6 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-icon-database \
--with-gtk=2.0 \
- --enable-svg \
- --enable-svg-fonts \
--enable-introspection
MAKEFILE= GNUmakefile
GLIB_SCHEMAS= org.webkitgtk-1.0.gschema.xml
diff --git a/www/webkit-gtk2/distinfo b/www/webkit-gtk2/distinfo
index 2200765d8a82..2f51e59f1b05 100644
--- a/www/webkit-gtk2/distinfo
+++ b/www/webkit-gtk2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (webkit-1.4.2.tar.gz) = dee6336b5366e952f67a18a66dca2edce95a8e70f591dbc7fc30cf30b5fdb9ba
-SIZE (webkit-1.4.2.tar.gz) = 8504310
+SHA256 (webkit-1.4.3.tar.gz) = b808ace6b3edad76aba57cc746a430051abfedf301c969628b989a1128dd37e4
+SIZE (webkit-1.4.3.tar.gz) = 8512387
diff --git a/www/webkit-gtk2/files/patch-Source_WebCore_plugins_gtk_PluginViewGtk.cpp b/www/webkit-gtk2/files/patch-Source_WebCore_plugins_gtk_PluginViewGtk.cpp
new file mode 100644
index 000000000000..424dcc034db5
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-Source_WebCore_plugins_gtk_PluginViewGtk.cpp
@@ -0,0 +1,18 @@
+--- Source/WebCore/plugins/gtk/PluginViewGtk.cpp.orig 2011-08-29 22:19:17.000000000 +0200
++++ Source/WebCore/plugins/gtk/PluginViewGtk.cpp 2011-10-14 13:45:50.000000000 +0200
+@@ -68,6 +68,7 @@
+ #endif
+ #include <gtk/gtk.h>
+
++#define String XtStringType
+ #if defined(XP_UNIX)
+ #include "RefPtrCairo.h"
+ #include "gtk2xtbin.h"
+@@ -80,6 +81,7 @@
+ #include "PluginMessageThrottlerWin.h"
+ #include <gdk/gdkwin32.h>
+ #endif
++#undef String
+
+ using JSC::ExecState;
+ using JSC::Interpreter;
diff --git a/www/webkit-gtk2/files/patch-Source_WebKit_gtk_webkit_webkitwebview.cpp b/www/webkit-gtk2/files/patch-Source_WebKit_gtk_webkit_webkitwebview.cpp
new file mode 100644
index 000000000000..958014e4e0bd
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-Source_WebKit_gtk_webkit_webkitwebview.cpp
@@ -0,0 +1,22 @@
+https://bugs.webkit.org/show_bug.cgi?id=50173
+
+--- Source/WebKit/gtk/webkit/webkitwebview.cpp.orig 2011-06-14 02:10:55.000000000 +0200
++++ Source/WebKit/gtk/webkit/webkitwebview.cpp 2011-08-27 10:48:52.000000000 +0200
+@@ -4939,6 +4939,8 @@
+
+ priv->mainResource = adoptGRef(webResource);
+ priv->mainResourceIdentifier = identifier;
++
++ g_object_ref(webView);
+ }
+
+ void webkit_web_view_add_resource(WebKitWebView* webView, const char* identifier, WebKitWebResource* webResource)
+@@ -4955,6 +4957,8 @@
+ priv->mainResource = 0;
+ } else
+ g_hash_table_remove(priv->subResources.get(), identifier);
++
++ g_object_unref(webView);
+ }
+
+ WebKitWebResource* webkit_web_view_get_resource(WebKitWebView* webView, char* identifier)