aboutsummaryrefslogtreecommitdiff
path: root/www/webkit-gtk2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
commit610ae5681637c1051a0c17b54e29d97f53da2f3a (patch)
treec231a1eb74b07e444fa7363012cb84bf23d83ce0 /www/webkit-gtk2
parent15b6544926b07a98710eeb765baf03e3fc9a195c (diff)
downloadports-610ae5681637c1051a0c17b54e29d97f53da2f3a.tar.gz
ports-610ae5681637c1051a0c17b54e29d97f53da2f3a.zip
Notes
Diffstat (limited to 'www/webkit-gtk2')
-rw-r--r--www/webkit-gtk2/Makefile30
-rw-r--r--www/webkit-gtk2/distinfo6
-rw-r--r--www/webkit-gtk2/files/patch-WebKit_gtk_webkit.pc.in8
-rw-r--r--www/webkit-gtk2/files/patch-Webcore_plugins_PluginDatabase.cpp10
-rw-r--r--www/webkit-gtk2/files/patch-cairo31
-rw-r--r--www/webkit-gtk2/pkg-plist50
6 files changed, 97 insertions, 38 deletions
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index f57de73b67aa..e703e03cbde4 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -3,16 +3,15 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/webkit-gtk2/Makefile,v 1.5 2008/03/24 01:51:52 mezz Exp $
+# $MCom: ports/www/webkit-gtk2/Makefile,v 1.23 2008/10/23 02:41:54 mezz Exp $
#
PORTNAME= webkit
-PORTVERSION= 0.0.30549
-PORTREVISION= 1
+PORTVERSION= 1.0.1
+PORTREVISION= 4
CATEGORIES= www
-MASTER_SITES= http://nightly.webkit.org/files/trunk/src/
+MASTER_SITES= http://people.freedesktop.org/~alp/webkit/gtk/
PKGNAMESUFFIX= -gtk2
-DISTNAME= WebKit-r${PORTVERSION:S/0.0.//}
MAINTAINER= gnome@FreeBSD.org
COMMENT= An opensource browser engine
@@ -21,29 +20,38 @@ LIB_DEPENDS= icutu.38:${PORTSDIR}/devel/icu \
curl.4:${PORTSDIR}/ftp/curl \
sqlite3.8:${PORTSDIR}/databases/sqlite3
+WANT_GSTREAMER= yes
+USE_XORG= xt
USE_BISON= build
-USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget gtk20 libxslt
+USE_GNOME= gtk20 libxslt
USE_PERL5= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= autoconf:262 automake:110 libtool:15
-USE_GSTREAMER= gnomevfs
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-webkit-target=x11 \
--enable-icon-database \
--enable-svg \
- --enable-video
+ --enable-svg-fonts \
+ --enable-svg-experimental
MAKEFILE= GNUmakefile
+BROWSER_PLUGINS_DIR?= ${LOCALBASE}/lib/browser_plugins/symlinks/webkit-gtk2
+#_BROWSER_PLUGINS_DIR= ${BROWSER_PLUGINS_DIR:S|^/|"|:S|/|", "|g}",
+
+OPTIONS= VIDEO "Enable video support" on
+
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if defined(WITH_VIDEO)
+USE_GSTREAMER+= gnomevfs
+CONFIGURE_ARGS+=--enable-video
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|%%BROWSER_PLUGINS_DIR%%|${BROWSER_PLUGINS_DIR}|' \
+ ${WRKSRC}/WebCore/plugins/PluginDatabase.cpp
@${REINPLACE_CMD} -e 's|autoconf|${AUTOCONF}|g ; \
s|automake|${AUTOMAKE}|g ; s|aclocal|${ACLOCAL}|g ; \
s|autoheader|${AUTOHEADER}|g ; \
diff --git a/www/webkit-gtk2/distinfo b/www/webkit-gtk2/distinfo
index b91ff2311761..b36c0f022f15 100644
--- a/www/webkit-gtk2/distinfo
+++ b/www/webkit-gtk2/distinfo
@@ -1,3 +1,3 @@
-MD5 (WebKit-r30549.tar.bz2) = 081ce2cb23cf564454bfc5a3d627a4bb
-SHA256 (WebKit-r30549.tar.bz2) = 7c9b9607fcb0909298c5d4c3ec47040082db139a28aca2547b2f657afe98b6cd
-SIZE (WebKit-r30549.tar.bz2) = 8573000
+MD5 (webkit-1.0.1.tar.gz) = 4de68a5773998bea14e8939aa341c466
+SHA256 (webkit-1.0.1.tar.gz) = 9601ed57978e7f1221f770c24933d2037fdb93e4b412716d842b993507f0b856
+SIZE (webkit-1.0.1.tar.gz) = 13418752
diff --git a/www/webkit-gtk2/files/patch-WebKit_gtk_webkit.pc.in b/www/webkit-gtk2/files/patch-WebKit_gtk_webkit.pc.in
new file mode 100644
index 000000000000..006b49709b38
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-WebKit_gtk_webkit.pc.in
@@ -0,0 +1,8 @@
+--- WebKit/gtk/webkit.pc.in.orig 2008-04-01 14:46:09.251210738 -0400
++++ WebKit/gtk/webkit.pc.in 2008-04-01 14:46:21.218068816 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: gtk+-2.0
+ Libs: -L${libdir} -lwebkit-1.0
+-Cflags: -I${includedir}/webkit-1.0
++Cflags: -I${includedir}/webkit-1.0 -I${includedir}/webkit-1.0/webkit
diff --git a/www/webkit-gtk2/files/patch-Webcore_plugins_PluginDatabase.cpp b/www/webkit-gtk2/files/patch-Webcore_plugins_PluginDatabase.cpp
new file mode 100644
index 000000000000..ed0a5895fca9
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-Webcore_plugins_PluginDatabase.cpp
@@ -0,0 +1,10 @@
+--- WebCore/plugins/PluginDatabase.cpp.orig 2008-05-26 01:03:07.236973838 -0700
++++ WebCore/plugins/PluginDatabase.cpp 2008-05-26 01:03:52.356436787 -0700
+@@ -281,6 +281,7 @@
+ userPluginPath.append(String("/.netscape/plugins"));
+ paths.append(userPluginPath);
+
++ paths.append("%%BROWSER_PLUGINS%%");
+ paths.append("/usr/lib/browser/plugins");
+ paths.append("/usr/local/lib/mozilla/plugins");
+ paths.append("/usr/lib/firefox/plugins");
diff --git a/www/webkit-gtk2/files/patch-cairo b/www/webkit-gtk2/files/patch-cairo
new file mode 100644
index 000000000000..4bba0cc2a860
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-cairo
@@ -0,0 +1,31 @@
+--- WebCore/platform/graphics/BitmapImage.cpp
++++ WebCore/platform/graphics/BitmapImage.cpp
+@@ -203,7 +203,7 @@ float BitmapImage::frameDurationAtIndex(size_t index)
+ bool BitmapImage::frameHasAlphaAtIndex(size_t index)
+ {
+ if (index >= frameCount())
+- return 0;
++ return true;
+
+ if (index >= m_frames.size() || !m_frames[index].m_frame)
+ cacheFrame(index);
+--- WebCore/platform/graphics/cairo/ImageCairo.cpp
++++ WebCore/platform/graphics/cairo/ImageCairo.cpp
+@@ -76,6 +76,7 @@ BitmapImage::BitmapImage(cairo_surface_t* surface, ImageObserver* observer)
+
+ m_frames.grow(1);
+ m_frames[0].m_frame = surface;
++ m_frames[0].m_hasAlpha = cairo_surface_get_content(surface) != CAIRO_CONTENT_COLOR;
+ checkForSolidColor();
+ }
+
+--- WebCore/platform/graphics/cg/ImageCG.cpp
++++ WebCore/platform/graphics/cg/ImageCG.cpp
+@@ -87,6 +87,7 @@ BitmapImage::BitmapImage(CGImageRef cgImage, ImageObserver* observer)
+
+ m_frames.grow(1);
+ m_frames[0].m_frame = cgImage;
++ m_frames[0].m_hasAlpha = true;
+ checkForSolidColor();
+ }
+
diff --git a/www/webkit-gtk2/pkg-plist b/www/webkit-gtk2/pkg-plist
index 71b65eff0f6a..85d72c47fc5b 100644
--- a/www/webkit-gtk2/pkg-plist
+++ b/www/webkit-gtk2/pkg-plist
@@ -1,26 +1,28 @@
-include/WebKit/JavaScriptCore/JSBase.h
-include/WebKit/JavaScriptCore/JSContextRef.h
-include/WebKit/JavaScriptCore/JSObjectRef.h
-include/WebKit/JavaScriptCore/JSStringRef.h
-include/WebKit/JavaScriptCore/JSStringRefBSTR.h
-include/WebKit/JavaScriptCore/JSStringRefCF.h
-include/WebKit/JavaScriptCore/JSValueRef.h
-include/WebKit/JavaScriptCore/JavaScript.h
-include/WebKit/JavaScriptCore/JavaScriptCore.h
-include/WebKit/webkit/webkit.h
-include/WebKit/webkit/webkitdefines.h
-include/WebKit/webkit/webkitnetworkrequest.h
-include/WebKit/webkit/webkitwebbackforwardlist.h
-include/WebKit/webkit/webkitwebframe.h
-include/WebKit/webkit/webkitwebhistoryitem.h
-include/WebKit/webkit/webkitwebsettings.h
-include/WebKit/webkit/webkitwebview.h
-lib/libWebKitGtk.a
-lib/libWebKitGtk.la
-lib/libWebKitGtk.so
-lib/libWebKitGtk.so.1
+bin/jsc
+include/webkit-1.0/JavaScriptCore/JSBase.h
+include/webkit-1.0/JavaScriptCore/JSContextRef.h
+include/webkit-1.0/JavaScriptCore/JSObjectRef.h
+include/webkit-1.0/JavaScriptCore/JSStringRef.h
+include/webkit-1.0/JavaScriptCore/JSStringRefBSTR.h
+include/webkit-1.0/JavaScriptCore/JSStringRefCF.h
+include/webkit-1.0/JavaScriptCore/JSValueRef.h
+include/webkit-1.0/JavaScriptCore/JavaScript.h
+include/webkit-1.0/JavaScriptCore/JavaScriptCore.h
+include/webkit-1.0/webkit/webkit.h
+include/webkit-1.0/webkit/webkitdefines.h
+include/webkit-1.0/webkit/webkitnetworkrequest.h
+include/webkit-1.0/webkit/webkitversion.h
+include/webkit-1.0/webkit/webkitwebbackforwardlist.h
+include/webkit-1.0/webkit/webkitwebframe.h
+include/webkit-1.0/webkit/webkitwebhistoryitem.h
+include/webkit-1.0/webkit/webkitwebsettings.h
+include/webkit-1.0/webkit/webkitwebview.h
+lib/libwebkit-1.0.a
+lib/libwebkit-1.0.la
+lib/libwebkit-1.0.so
+lib/libwebkit-1.0.so.1
libdata/pkgconfig/WebKitGtk.pc
libdata/pkgconfig/webkit-1.0.pc
-@dirrm include/WebKit/webkit
-@dirrm include/WebKit/JavaScriptCore
-@dirrm include/WebKit
+@dirrm include/webkit-1.0/webkit
+@dirrm include/webkit-1.0/JavaScriptCore
+@dirrm include/webkit-1.0