aboutsummaryrefslogtreecommitdiff
path: root/www/webkit-gtk2
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-02-10 15:20:20 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-02-10 15:20:20 +0000
commit9e7bfc19b2929972d56be0750b010efee858475c (patch)
treec6acb8d4015e5a6c965623c32a470bfcd90c1dad /www/webkit-gtk2
parent3f2c80dbe49a87b01ebdbf9320f14fee5b518b51 (diff)
downloadports-9e7bfc19b2929972d56be0750b010efee858475c.tar.gz
ports-9e7bfc19b2929972d56be0750b010efee858475c.zip
Notes
Diffstat (limited to 'www/webkit-gtk2')
-rw-r--r--www/webkit-gtk2/Makefile10
-rw-r--r--www/webkit-gtk2/files/extra-patch-WebCore_platform_text_TextBreakIterator.h15
2 files changed, 23 insertions, 2 deletions
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index f1993bcde9d8..52811e7db71c 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -17,8 +17,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= An opensource browser engine
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
-LIB_DEPENDS= icutu.38:${PORTSDIR}/devel/icu \
- enchant.1:${PORTSDIR}/textproc/enchant \
+LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant \
curl.5:${PORTSDIR}/ftp/curl \
sqlite3.8:${PORTSDIR}/databases/sqlite3 \
soup-2.4.1:${PORTSDIR}/devel/libsoup
@@ -51,6 +50,13 @@ OPTIONS= VIDEO "Enable video support" on \
.include <bsd.port.pre.mk>
+.if exists (${LOCALBASE}/lib/libicutu.so.43)
+LIB_DEPENDS+= icutu.43:${PORTSDIR}/devel/icu4
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-WebCore_platform_text_TextBreakIterator.h
+.else
+LIB_DEPENDS+= icutu.38:${PORTSDIR}/devel/icu
+.endif
+
.if defined(WITH_VIDEO)
USE_GSTREAMER+= yes
CONFIGURE_ARGS+=--enable-video
diff --git a/www/webkit-gtk2/files/extra-patch-WebCore_platform_text_TextBreakIterator.h b/www/webkit-gtk2/files/extra-patch-WebCore_platform_text_TextBreakIterator.h
new file mode 100644
index 000000000000..a865035350a4
--- /dev/null
+++ b/www/webkit-gtk2/files/extra-patch-WebCore_platform_text_TextBreakIterator.h
@@ -0,0 +1,15 @@
+Pr 143718, fix build with icu 4.3
+
+--- WebCore/platform/text/TextBreakIterator.h.orig 2009-09-22 18:29:21.000000000 +0300
++++ WebCore/platform/text/TextBreakIterator.h 2010-02-10 08:49:59.000000000 +0200
+@@ -26,7 +26,7 @@
+
+ namespace WebCore {
+
+- class TextBreakIterator;
++ typedef struct UBreakIterator TextBreakIterator;
+
+ // Note: The returned iterator is good only until you get another iterator.
+
+
+