aboutsummaryrefslogtreecommitdiff
path: root/www/webkit-gtk2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /www/webkit-gtk2
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Notes
Diffstat (limited to 'www/webkit-gtk2')
-rw-r--r--www/webkit-gtk2/Makefile81
-rw-r--r--www/webkit-gtk2/distinfo6
-rw-r--r--www/webkit-gtk2/files/extra-patch-JavaScriptCore_assembler_MacroAssemblerCodeRef.h11
-rw-r--r--www/webkit-gtk2/files/extra-patch-JavaScriptCore_jit_JITOpcodes.cpp20
-rw-r--r--www/webkit-gtk2/files/extra-patch-JavaScriptCore_jit_JITStubCall.h65
-rw-r--r--www/webkit-gtk2/files/extra-patch-JavaScriptCore_jit_JITStubs.cpp11
-rw-r--r--www/webkit-gtk2/files/extra-patch-JavaScriptCore_yarr_RegexJIT.h11
-rw-r--r--www/webkit-gtk2/files/patch-GNUmakefile.in13
-rw-r--r--www/webkit-gtk2/files/patch-JavaScriptCore_wtf_Platform.h11
-rw-r--r--www/webkit-gtk2/files/patch-WebKit_gtk_webkit.pc.in8
-rw-r--r--www/webkit-gtk2/files/patch-Webcore_plugins_PluginDatabase.cpp8
-rw-r--r--www/webkit-gtk2/files/patch-cairo30
-rw-r--r--www/webkit-gtk2/files/patch-configure20
-rw-r--r--www/webkit-gtk2/pkg-plist233
14 files changed, 456 insertions, 72 deletions
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index 3ca4dd05bb4d..ad2f4c734c48 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -3,76 +3,91 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/webkit-gtk2/Makefile,v 1.23 2008/10/23 02:41:54 mezz Exp $
+# $MCom: ports/www/webkit-gtk2/Makefile,v 1.50 2009/11/28 17:35:07 kwm Exp $
#
PORTNAME= webkit
-PORTVERSION= 1.0.1
-PORTREVISION= 8
+PORTVERSION= 1.1.15.4
CATEGORIES= www
-MASTER_SITES= http://people.freedesktop.org/~alp/webkit/gtk/
+MASTER_SITES= http://webkitgtk.org/
PKGNAMESUFFIX= -gtk2
MAINTAINER= gnome@FreeBSD.org
COMMENT= An opensource browser engine
+BUILD_DEPENDS= flex:${PORTSDIR}/textproc/flex
LIB_DEPENDS= icutu.38:${PORTSDIR}/devel/icu \
+ enchant.1:${PORTSDIR}/textproc/enchant \
curl.5:${PORTSDIR}/ftp/curl \
- sqlite3.8:${PORTSDIR}/databases/sqlite3
+ sqlite3.8:${PORTSDIR}/databases/sqlite3 \
+ soup-2.4.1:${PORTSDIR}/devel/libsoup
WANT_GSTREAMER= yes
+MAKE_JOBS_SAFE= yes
USE_XORG= xt
USE_BISON= build
USE_GMAKE= yes
-USE_GNOME= gtk20 libxslt
+USE_AUTOTOOLS= libtool:22
+USE_GNOME= gtk20 libxslt ltverhack:13
USE_PERL5= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= autoconf:262 automake:110 libtool:22
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
+ ac_cv_path_FLEX="${LOCALBASE}/bin/flex" \
ac_cv_path_DOLT_BASH=""
-CONFIGURE_ARGS= --with-webkit-target=x11 \
- --enable-icon-database \
+CONFIGURE_ARGS= --enable-icon-database \
--enable-svg \
- --enable-svg-fonts \
- --enable-svg-experimental \
- --enable-static
+ --enable-svg-fonts
MAKEFILE= GNUmakefile
BROWSER_PLUGINS_DIR?= ${LOCALBASE}/lib/browser_plugins/symlinks/webkit-gtk2
#_BROWSER_PLUGINS_DIR= ${BROWSER_PLUGINS_DIR:S|^/|"|:S|/|", "|g}",
-OPTIONS= VIDEO "Enable video support" on
+OPTIONS= VIDEO "Enable video support" on \
+ DEBUG "Build with debug support" off \
+ STATIC "Enable building static library" off
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
.if defined(WITH_VIDEO)
-USE_GSTREAMER+= gnomevfs
+USE_GSTREAMER+= yes
CONFIGURE_ARGS+=--enable-video
.endif
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.else
+CONFIGURE_ARGS+=--disable-debug
+.endif
+
+.if defined(WITH_STATIC)
+CONFIGURE_ARGS+=--enable-static
+PLIST_SUB+= STATIC=""
+.else
+PLIST_SUB+= STATIC="@comment "
+.endif
+
+.if ${OSVERSION} < 700000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-JavaScriptCore_yarr_RegexJIT.h \
+ ${FILESDIR}/extra-patch-JavaScriptCore_jit_JITStubCall.h \
+ ${FILESDIR}/extra-patch-JavaScriptCore_jit_JITOpcodes.cpp \
+ ${FILESDIR}/extra-patch-JavaScriptCore_assembler_MacroAssemblerCodeRef.h \
+ ${FILESDIR}/extra-patch-JavaScriptCore_jit_JITStubs.cpp
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%BROWSER_PLUGINS_DIR%%|${BROWSER_PLUGINS_DIR}|' \
${WRKSRC}/WebCore/plugins/PluginDatabase.cpp
- @${REINPLACE_CMD} -e 's|autoconf|${AUTOCONF}|g ; \
- s|automake|${AUTOMAKE}|g ; s|aclocal|${ACLOCAL}|g ; \
- s|autoheader|${AUTOHEADER}|g ; \
- s|LIBTOOLIZE=libtoolize|LIBTOOLIZE=${LIBTOOLIZE}|g ; \
- s|$$srcdir/configure|#$$srcdir/configure|g' \
- ${WRKSRC}/autogen.sh
- @${FIND} ${WRKSRC} -name GNUmakefile.am | ${XARGS} ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name GNUmakefile.* | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
-
-pre-configure:
- @(cd ${WRKSRC} && ${SH} autogen.sh)
-
-post-install:
-# Install compat pkg-config file so we don't have to patch ports
- ${CP} ${PREFIX}/libdata/pkgconfig/webkit-1.0.pc \
- ${PREFIX}/libdata/pkgconfig/WebKitGtk.pc
+.if !defined(WITH_STATIC)
+ @${REINPLACE_CMD} -e 's|^build_old_libs=yes|build_old_libs=no|' \
+ ${WRKDIR}/gnome-libtool
+.endif
+ @${REINPLACE_CMD} -e 's|/usr/bin/gcc|${CC}|' \
+ ${WRKSRC}/WebCore/dom/make_names.pl \
+ ${WRKSRC}/WebCore/css/make-css-file-arrays.pl \
+ ${WRKSRC}/WebCore/bindings/scripts/IDLParser.pm
.include <bsd.port.post.mk>
diff --git a/www/webkit-gtk2/distinfo b/www/webkit-gtk2/distinfo
index b36c0f022f15..412335d8ad21 100644
--- a/www/webkit-gtk2/distinfo
+++ b/www/webkit-gtk2/distinfo
@@ -1,3 +1,3 @@
-MD5 (webkit-1.0.1.tar.gz) = 4de68a5773998bea14e8939aa341c466
-SHA256 (webkit-1.0.1.tar.gz) = 9601ed57978e7f1221f770c24933d2037fdb93e4b412716d842b993507f0b856
-SIZE (webkit-1.0.1.tar.gz) = 13418752
+MD5 (webkit-1.1.15.4.tar.gz) = 47301fb7120421ac38bf714db8f5d428
+SHA256 (webkit-1.1.15.4.tar.gz) = ec2511fc1d4a1e64534574cd5f9b2bc552de9bb22d7b3837dd17146fb5f1c90f
+SIZE (webkit-1.1.15.4.tar.gz) = 6093252
diff --git a/www/webkit-gtk2/files/extra-patch-JavaScriptCore_assembler_MacroAssemblerCodeRef.h b/www/webkit-gtk2/files/extra-patch-JavaScriptCore_assembler_MacroAssemblerCodeRef.h
new file mode 100644
index 000000000000..dc03dce02dc1
--- /dev/null
+++ b/www/webkit-gtk2/files/extra-patch-JavaScriptCore_assembler_MacroAssemblerCodeRef.h
@@ -0,0 +1,11 @@
+--- JavaScriptCore/assembler/MacroAssemblerCodeRef.h.orig 2009-10-19 08:34:08.000000000 -0400
++++ JavaScriptCore/assembler/MacroAssemblerCodeRef.h 2009-10-19 08:34:53.000000000 -0400
+@@ -69,7 +69,7 @@ public:
+
+ template<typename FunctionType>
+ explicit FunctionPtr(FunctionType* value)
+- : m_value(reinterpret_cast<void*>(value))
++ : m_value((void*)(value))
+ {
+ ASSERT_VALID_CODE_POINTER(m_value);
+ }
diff --git a/www/webkit-gtk2/files/extra-patch-JavaScriptCore_jit_JITOpcodes.cpp b/www/webkit-gtk2/files/extra-patch-JavaScriptCore_jit_JITOpcodes.cpp
new file mode 100644
index 000000000000..6e6ffe831486
--- /dev/null
+++ b/www/webkit-gtk2/files/extra-patch-JavaScriptCore_jit_JITOpcodes.cpp
@@ -0,0 +1,20 @@
+--- JavaScriptCore/jit/JITOpcodes.cpp.orig 2009-09-29 15:43:18.000000000 -0400
++++ JavaScriptCore/jit/JITOpcodes.cpp 2009-11-01 13:09:39.000000000 -0500
+@@ -270,7 +270,7 @@ void JIT::privateCompileCTIMachineTrampo
+ emitGetFromCallFrameHeaderPtr(RegisterFile::ReturnPC, regT1);
+ move(ImmPtr(&globalData->exceptionLocation), regT2);
+ storePtr(regT1, regT2);
+- move(ImmPtr(reinterpret_cast<void*>(ctiVMThrowTrampoline)), regT2);
++ move(ImmPtr((void*)(ctiVMThrowTrampoline)), regT2);
+ emitGetFromCallFrameHeaderPtr(RegisterFile::CallerFrame, callFrameRegister);
+ poke(callFrameRegister, OBJECT_OFFSETOF(struct JITStackFrame, callFrame) / sizeof (void*));
+ restoreReturnAddressBeforeReturn(regT2);
+@@ -1754,7 +1754,7 @@ void JIT::privateCompileCTIMachineTrampo
+ emitGetFromCallFrameHeaderPtr(RegisterFile::ReturnPC, regT1);
+ move(ImmPtr(&globalData->exceptionLocation), regT2);
+ storePtr(regT1, regT2);
+- move(ImmPtr(reinterpret_cast<void*>(ctiVMThrowTrampoline)), regT2);
++ move(ImmPtr((void*)(ctiVMThrowTrampoline)), regT2);
+ emitGetFromCallFrameHeaderPtr(RegisterFile::CallerFrame, callFrameRegister);
+ poke(callFrameRegister, OBJECT_OFFSETOF(struct JITStackFrame, callFrame) / sizeof (void*));
+ restoreReturnAddressBeforeReturn(regT2);
diff --git a/www/webkit-gtk2/files/extra-patch-JavaScriptCore_jit_JITStubCall.h b/www/webkit-gtk2/files/extra-patch-JavaScriptCore_jit_JITStubCall.h
new file mode 100644
index 000000000000..4d4a76bce3f0
--- /dev/null
+++ b/www/webkit-gtk2/files/extra-patch-JavaScriptCore_jit_JITStubCall.h
@@ -0,0 +1,65 @@
+--- JavaScriptCore/jit/JITStubCall.h.orig 2009-10-18 13:44:09.000000000 -0400
++++ JavaScriptCore/jit/JITStubCall.h 2009-10-18 13:45:53.000000000 -0400
+@@ -36,7 +36,7 @@ namespace JSC {
+ public:
+ JITStubCall(JIT* jit, JSObject* (JIT_STUB *stub)(STUB_ARGS_DECLARATION))
+ : m_jit(jit)
+- , m_stub(reinterpret_cast<void*>(stub))
++ , m_stub((void*)(stub))
+ , m_returnType(Cell)
+ , m_stackIndex(stackIndexStart)
+ {
+@@ -44,7 +44,7 @@ namespace JSC {
+
+ JITStubCall(JIT* jit, JSPropertyNameIterator* (JIT_STUB *stub)(STUB_ARGS_DECLARATION))
+ : m_jit(jit)
+- , m_stub(reinterpret_cast<void*>(stub))
++ , m_stub((void*)(stub))
+ , m_returnType(Cell)
+ , m_stackIndex(stackIndexStart)
+ {
+@@ -52,7 +52,7 @@ namespace JSC {
+
+ JITStubCall(JIT* jit, void* (JIT_STUB *stub)(STUB_ARGS_DECLARATION))
+ : m_jit(jit)
+- , m_stub(reinterpret_cast<void*>(stub))
++ , m_stub((void*)(stub))
+ , m_returnType(VoidPtr)
+ , m_stackIndex(stackIndexStart)
+ {
+@@ -60,7 +60,7 @@ namespace JSC {
+
+ JITStubCall(JIT* jit, int (JIT_STUB *stub)(STUB_ARGS_DECLARATION))
+ : m_jit(jit)
+- , m_stub(reinterpret_cast<void*>(stub))
++ , m_stub((void*)(stub))
+ , m_returnType(Int)
+ , m_stackIndex(stackIndexStart)
+ {
+@@ -68,7 +68,7 @@ namespace JSC {
+
+ JITStubCall(JIT* jit, bool (JIT_STUB *stub)(STUB_ARGS_DECLARATION))
+ : m_jit(jit)
+- , m_stub(reinterpret_cast<void*>(stub))
++ , m_stub((void*)(stub))
+ , m_returnType(Int)
+ , m_stackIndex(stackIndexStart)
+ {
+@@ -76,7 +76,7 @@ namespace JSC {
+
+ JITStubCall(JIT* jit, void (JIT_STUB *stub)(STUB_ARGS_DECLARATION))
+ : m_jit(jit)
+- , m_stub(reinterpret_cast<void*>(stub))
++ , m_stub((void*)(stub))
+ , m_returnType(Void)
+ , m_stackIndex(stackIndexStart)
+ {
+@@ -85,7 +85,7 @@ namespace JSC {
+ #if USE(JSVALUE32_64)
+ JITStubCall(JIT* jit, EncodedJSValue (JIT_STUB *stub)(STUB_ARGS_DECLARATION))
+ : m_jit(jit)
+- , m_stub(reinterpret_cast<void*>(stub))
++ , m_stub((void*)(stub))
+ , m_returnType(Value)
+ , m_stackIndex(stackIndexStart)
+ {
diff --git a/www/webkit-gtk2/files/extra-patch-JavaScriptCore_jit_JITStubs.cpp b/www/webkit-gtk2/files/extra-patch-JavaScriptCore_jit_JITStubs.cpp
new file mode 100644
index 000000000000..59229e8bc82e
--- /dev/null
+++ b/www/webkit-gtk2/files/extra-patch-JavaScriptCore_jit_JITStubs.cpp
@@ -0,0 +1,11 @@
+--- JavaScriptCore/jit/JITStubs.cpp.orig 2009-10-19 15:13:27.000000000 -0400
++++ JavaScriptCore/jit/JITStubs.cpp 2009-10-19 15:13:46.000000000 -0400
+@@ -2672,7 +2672,7 @@ DEFINE_STUB_FUNCTION(EncodedJSValue, op_
+
+ if (!handler) {
+ *stackFrame.exception = exceptionValue;
+- STUB_SET_RETURN_ADDRESS(reinterpret_cast<void*>(ctiOpThrowNotCaught));
++ STUB_SET_RETURN_ADDRESS((void*)(ctiOpThrowNotCaught));
+ return JSValue::encode(jsNull());
+ }
+
diff --git a/www/webkit-gtk2/files/extra-patch-JavaScriptCore_yarr_RegexJIT.h b/www/webkit-gtk2/files/extra-patch-JavaScriptCore_yarr_RegexJIT.h
new file mode 100644
index 000000000000..c46912d7aee8
--- /dev/null
+++ b/www/webkit-gtk2/files/extra-patch-JavaScriptCore_yarr_RegexJIT.h
@@ -0,0 +1,11 @@
+--- JavaScriptCore/yarr/RegexJIT.h.orig 2009-10-09 23:47:41.000000000 -0400
++++ JavaScriptCore/yarr/RegexJIT.h 2009-10-09 23:48:19.000000000 -0400
+@@ -73,7 +73,7 @@ public:
+
+ int execute(const UChar* input, unsigned start, unsigned length, int* output)
+ {
+- return reinterpret_cast<RegexJITCode>(m_ref.m_code.executableAddress())(input, start, length, output);
++ return ((RegexJITCode)m_ref.m_code.executableAddress())(input, start, length, output);
+ }
+
+ private:
diff --git a/www/webkit-gtk2/files/patch-GNUmakefile.in b/www/webkit-gtk2/files/patch-GNUmakefile.in
new file mode 100644
index 000000000000..53333a520d38
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-GNUmakefile.in
@@ -0,0 +1,13 @@
+--- GNUmakefile.in.orig 2009-07-28 12:36:13.000000000 +0200
++++ GNUmakefile.in 2009-07-28 12:39:13.000000000 +0200
+@@ -8154,7 +8154,9 @@ libWebCoreJS_depfiles := $(patsubst \
+ webinspectordir = ${datadir}/webkit-1.0/webinspector
+ dist_webinspector_DATA = \
+ $(WebCore)/English.lproj/localizedStrings.js \
+- $(shell ls $(WebCore)/inspector/front-end/*.{js,html,css})
++ $(shell ls $(WebCore)/inspector/front-end/*.js) \
++ $(shell ls $(WebCore)/inspector/front-end/*.html) \
++ $(shell ls $(WebCore)/inspector/front-end/*.css)
+
+ webinspectorimagesdir = ${datadir}/webkit-1.0/webinspector/Images
+ dist_webinspectorimages_DATA = \
diff --git a/www/webkit-gtk2/files/patch-JavaScriptCore_wtf_Platform.h b/www/webkit-gtk2/files/patch-JavaScriptCore_wtf_Platform.h
new file mode 100644
index 000000000000..1b4d9eec188f
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-JavaScriptCore_wtf_Platform.h
@@ -0,0 +1,11 @@
+--- JavaScriptCore/wtf/Platform.h.orig 2009-09-20 01:06:03.000000000 +0200
++++ JavaScriptCore/wtf/Platform.h 2009-09-21 22:01:16.000000000 +0200
+@@ -626,7 +626,7 @@
+ #endif
+
+ #if !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32) && !defined(WTF_USE_JSVALUE32_64)
+-#if PLATFORM(X86_64) && (PLATFORM(DARWIN) || PLATFORM(LINUX))
++#if PLATFORM(X86_64) && (PLATFORM(DARWIN) || PLATFORM(LINUX) || PLATFORM(FREEBSD))
+ #define WTF_USE_JSVALUE64 1
+ #elif PLATFORM(ARM) || PLATFORM(PPC64)
+ #define WTF_USE_JSVALUE32 1
diff --git a/www/webkit-gtk2/files/patch-WebKit_gtk_webkit.pc.in b/www/webkit-gtk2/files/patch-WebKit_gtk_webkit.pc.in
index 006b49709b38..1d41c7c8db1c 100644
--- a/www/webkit-gtk2/files/patch-WebKit_gtk_webkit.pc.in
+++ b/www/webkit-gtk2/files/patch-WebKit_gtk_webkit.pc.in
@@ -1,8 +1,8 @@
---- WebKit/gtk/webkit.pc.in.orig 2008-04-01 14:46:09.251210738 -0400
-+++ WebKit/gtk/webkit.pc.in 2008-04-01 14:46:21.218068816 -0400
-@@ -8,4 +8,4 @@
+--- WebKit/gtk/webkit.pc.in.orig 2009-05-13 20:55:10.000000000 +0800
++++ WebKit/gtk/webkit.pc.in 2009-05-19 15:09:51.000000000 +0800
+@@ -8,4 +8,4 @@ Description: Web content engine for GTK+
Version: @VERSION@
- Requires: gtk+-2.0
+ Requires: glib-2.0 gtk+-2.0 libsoup-2.4
Libs: -L${libdir} -lwebkit-1.0
-Cflags: -I${includedir}/webkit-1.0
+Cflags: -I${includedir}/webkit-1.0 -I${includedir}/webkit-1.0/webkit
diff --git a/www/webkit-gtk2/files/patch-Webcore_plugins_PluginDatabase.cpp b/www/webkit-gtk2/files/patch-Webcore_plugins_PluginDatabase.cpp
index ed0a5895fca9..2670c229d1b1 100644
--- a/www/webkit-gtk2/files/patch-Webcore_plugins_PluginDatabase.cpp
+++ b/www/webkit-gtk2/files/patch-Webcore_plugins_PluginDatabase.cpp
@@ -1,10 +1,10 @@
---- WebCore/plugins/PluginDatabase.cpp.orig 2008-05-26 01:03:07.236973838 -0700
-+++ WebCore/plugins/PluginDatabase.cpp 2008-05-26 01:03:52.356436787 -0700
-@@ -281,6 +281,7 @@
+--- WebCore/plugins/PluginDatabase.cpp.orig 2008-11-02 03:12:05.000000000 +0800
++++ WebCore/plugins/PluginDatabase.cpp 2009-05-19 15:09:51.000000000 +0800
+@@ -283,6 +283,7 @@ Vector<String> PluginDatabase::defaultPl
userPluginPath.append(String("/.netscape/plugins"));
paths.append(userPluginPath);
-+ paths.append("%%BROWSER_PLUGINS%%");
++ paths.append("%%BROWSER_PLUGINS_DIR%%");
paths.append("/usr/lib/browser/plugins");
paths.append("/usr/local/lib/mozilla/plugins");
paths.append("/usr/lib/firefox/plugins");
diff --git a/www/webkit-gtk2/files/patch-cairo b/www/webkit-gtk2/files/patch-cairo
index 4bba0cc2a860..2c4293af518e 100644
--- a/www/webkit-gtk2/files/patch-cairo
+++ b/www/webkit-gtk2/files/patch-cairo
@@ -1,31 +1,11 @@
---- WebCore/platform/graphics/BitmapImage.cpp
-+++ WebCore/platform/graphics/BitmapImage.cpp
-@@ -203,7 +203,7 @@ float BitmapImage::frameDurationAtIndex(size_t index)
- bool BitmapImage::frameHasAlphaAtIndex(size_t index)
+--- WebCore/platform/graphics/BitmapImage.cpp.orig 2009-03-04 03:34:16.000000000 +0800
++++ WebCore/platform/graphics/BitmapImage.cpp 2009-05-19 15:09:51.000000000 +0800
+@@ -202,7 +202,7 @@ bool BitmapImage::isSizeAvailable()
+ NativeImagePtr BitmapImage::frameAtIndex(size_t index)
{
if (index >= frameCount())
- return 0;
-+ return true;
++ return NULL;
if (index >= m_frames.size() || !m_frames[index].m_frame)
cacheFrame(index);
---- WebCore/platform/graphics/cairo/ImageCairo.cpp
-+++ WebCore/platform/graphics/cairo/ImageCairo.cpp
-@@ -76,6 +76,7 @@ BitmapImage::BitmapImage(cairo_surface_t* surface, ImageObserver* observer)
-
- m_frames.grow(1);
- m_frames[0].m_frame = surface;
-+ m_frames[0].m_hasAlpha = cairo_surface_get_content(surface) != CAIRO_CONTENT_COLOR;
- checkForSolidColor();
- }
-
---- WebCore/platform/graphics/cg/ImageCG.cpp
-+++ WebCore/platform/graphics/cg/ImageCG.cpp
-@@ -87,6 +87,7 @@ BitmapImage::BitmapImage(CGImageRef cgImage, ImageObserver* observer)
-
- m_frames.grow(1);
- m_frames[0].m_frame = cgImage;
-+ m_frames[0].m_hasAlpha = true;
- checkForSolidColor();
- }
-
diff --git a/www/webkit-gtk2/files/patch-configure b/www/webkit-gtk2/files/patch-configure
new file mode 100644
index 000000000000..08c05beeab7c
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2009-06-15 17:23:17.000000000 +0200
++++ configure 2009-06-15 20:19:44.000000000 +0200
+@@ -21204,7 +21204,7 @@ fi
+
+ if test "$enable_jit" = "yes"; then
+ case "$host_cpu" in
+- i*86|x86_64)
++ i*86|x86_64|amd64)
+
+ cat >>confdefs.h <<\_ACEOF
+ #define ENABLE_JIT 1
+@@ -21243,7 +21243,7 @@ cat >>confdefs.h <<\_ACEOF
+ _ACEOF
+
+ ;;
+- x86_64)
++ x86_64|amd64)
+
+ cat >>confdefs.h <<\_ACEOF
+ #define WTF_USE_JIT_STUB_ARGUMENT_REGISTER 1
diff --git a/www/webkit-gtk2/pkg-plist b/www/webkit-gtk2/pkg-plist
index 85d72c47fc5b..3e9628ce253a 100644
--- a/www/webkit-gtk2/pkg-plist
+++ b/www/webkit-gtk2/pkg-plist
@@ -8,21 +8,248 @@ include/webkit-1.0/JavaScriptCore/JSStringRefCF.h
include/webkit-1.0/JavaScriptCore/JSValueRef.h
include/webkit-1.0/JavaScriptCore/JavaScript.h
include/webkit-1.0/JavaScriptCore/JavaScriptCore.h
+include/webkit-1.0/JavaScriptCore/WebKitAvailability.h
include/webkit-1.0/webkit/webkit.h
include/webkit-1.0/webkit/webkitdefines.h
+include/webkit-1.0/webkit/webkitdownload.h
+include/webkit-1.0/webkit/webkitenumtypes.h
+include/webkit-1.0/webkit/webkiterror.h
+include/webkit-1.0/webkit/webkithittestresult.h
include/webkit-1.0/webkit/webkitnetworkrequest.h
+include/webkit-1.0/webkit/webkitnetworkresponse.h
+include/webkit-1.0/webkit/webkitsecurityorigin.h
+include/webkit-1.0/webkit/webkitsoupauthdialog.h
include/webkit-1.0/webkit/webkitversion.h
include/webkit-1.0/webkit/webkitwebbackforwardlist.h
+include/webkit-1.0/webkit/webkitwebdatabase.h
+include/webkit-1.0/webkit/webkitwebdatasource.h
include/webkit-1.0/webkit/webkitwebframe.h
include/webkit-1.0/webkit/webkitwebhistoryitem.h
+include/webkit-1.0/webkit/webkitwebinspector.h
+include/webkit-1.0/webkit/webkitwebnavigationaction.h
+include/webkit-1.0/webkit/webkitwebpolicydecision.h
+include/webkit-1.0/webkit/webkitwebresource.h
include/webkit-1.0/webkit/webkitwebsettings.h
include/webkit-1.0/webkit/webkitwebview.h
-lib/libwebkit-1.0.a
+include/webkit-1.0/webkit/webkitwebwindowfeatures.h
+%%STATIC%%lib/libwebkit-1.0.a
lib/libwebkit-1.0.la
lib/libwebkit-1.0.so
-lib/libwebkit-1.0.so.1
-libdata/pkgconfig/WebKitGtk.pc
+lib/libwebkit-1.0.so.13
libdata/pkgconfig/webkit-1.0.pc
+share/locale/de/LC_MESSAGES/webkit.mo
+share/locale/en_GB/LC_MESSAGES/webkit.mo
+share/locale/es/LC_MESSAGES/webkit.mo
+share/locale/it/LC_MESSAGES/webkit.mo
+share/locale/lt/LC_MESSAGES/webkit.mo
+share/locale/nl/LC_MESSAGES/webkit.mo
+share/locale/pt_BR/LC_MESSAGES/webkit.mo
+share/locale/ru/LC_MESSAGES/webkit.mo
+share/locale/sr/LC_MESSAGES/webkit.mo
+share/locale/sr@latin/LC_MESSAGES/webkit.mo
+share/locale/sv/LC_MESSAGES/webkit.mo
+share/locale/vi/LC_MESSAGES/webkit.mo
+share/locale/zh_CN/LC_MESSAGES/webkit.mo
+share/webkit-1.0/images/deleteButton.png
+share/webkit-1.0/images/missingImage.png
+share/webkit-1.0/images/nullPlugin.png
+share/webkit-1.0/images/panIcon.png
+share/webkit-1.0/images/textAreaResizeCorner.png
+share/webkit-1.0/images/urlIcon.png
+share/webkit-1.0/resources/error.html
+share/webkit-1.0/webinspector/BottomUpProfileDataGridTree.js
+share/webkit-1.0/webinspector/Breakpoint.js
+share/webkit-1.0/webinspector/BreakpointsSidebarPane.js
+share/webkit-1.0/webinspector/CallStackSidebarPane.js
+share/webkit-1.0/webinspector/Callback.js
+share/webkit-1.0/webinspector/ChangesView.js
+share/webkit-1.0/webinspector/Color.js
+share/webkit-1.0/webinspector/ConsoleView.js
+share/webkit-1.0/webinspector/CookieItemsView.js
+share/webkit-1.0/webinspector/DOMAgent.js
+share/webkit-1.0/webinspector/DOMStorage.js
+share/webkit-1.0/webinspector/DOMStorageDataGrid.js
+share/webkit-1.0/webinspector/DOMStorageItemsView.js
+share/webkit-1.0/webinspector/DataGrid.js
+share/webkit-1.0/webinspector/Database.js
+share/webkit-1.0/webinspector/DatabaseQueryView.js
+share/webkit-1.0/webinspector/DatabaseTableView.js
+share/webkit-1.0/webinspector/Drawer.js
+share/webkit-1.0/webinspector/ElementsPanel.js
+share/webkit-1.0/webinspector/ElementsTreeOutline.js
+share/webkit-1.0/webinspector/FontView.js
+share/webkit-1.0/webinspector/ImageView.js
+share/webkit-1.0/webinspector/Images/back.png
+share/webkit-1.0/webinspector/Images/checker.png
+share/webkit-1.0/webinspector/Images/clearConsoleButtonGlyph.png
+share/webkit-1.0/webinspector/Images/closeButtons.png
+share/webkit-1.0/webinspector/Images/consoleButtonGlyph.png
+share/webkit-1.0/webinspector/Images/cookie.png
+share/webkit-1.0/webinspector/Images/database.png
+share/webkit-1.0/webinspector/Images/databaseTable.png
+share/webkit-1.0/webinspector/Images/debuggerContinue.png
+share/webkit-1.0/webinspector/Images/debuggerPause.png
+share/webkit-1.0/webinspector/Images/debuggerStepInto.png
+share/webkit-1.0/webinspector/Images/debuggerStepOut.png
+share/webkit-1.0/webinspector/Images/debuggerStepOver.png
+share/webkit-1.0/webinspector/Images/disclosureTriangleSmallDown.png
+share/webkit-1.0/webinspector/Images/disclosureTriangleSmallDownBlack.png
+share/webkit-1.0/webinspector/Images/disclosureTriangleSmallDownWhite.png
+share/webkit-1.0/webinspector/Images/disclosureTriangleSmallRight.png
+share/webkit-1.0/webinspector/Images/disclosureTriangleSmallRightBlack.png
+share/webkit-1.0/webinspector/Images/disclosureTriangleSmallRightDown.png
+share/webkit-1.0/webinspector/Images/disclosureTriangleSmallRightDownBlack.png
+share/webkit-1.0/webinspector/Images/disclosureTriangleSmallRightDownWhite.png
+share/webkit-1.0/webinspector/Images/disclosureTriangleSmallRightWhite.png
+share/webkit-1.0/webinspector/Images/dockButtonGlyph.png
+share/webkit-1.0/webinspector/Images/elementsIcon.png
+share/webkit-1.0/webinspector/Images/enableOutlineButtonGlyph.png
+share/webkit-1.0/webinspector/Images/enableSolidButtonGlyph.png
+share/webkit-1.0/webinspector/Images/errorIcon.png
+share/webkit-1.0/webinspector/Images/errorMediumIcon.png
+share/webkit-1.0/webinspector/Images/excludeButtonGlyph.png
+share/webkit-1.0/webinspector/Images/focusButtonGlyph.png
+share/webkit-1.0/webinspector/Images/forward.png
+share/webkit-1.0/webinspector/Images/glossyHeader.png
+share/webkit-1.0/webinspector/Images/glossyHeaderPressed.png
+share/webkit-1.0/webinspector/Images/glossyHeaderSelected.png
+share/webkit-1.0/webinspector/Images/glossyHeaderSelectedPressed.png
+share/webkit-1.0/webinspector/Images/goArrow.png
+share/webkit-1.0/webinspector/Images/graphLabelCalloutLeft.png
+share/webkit-1.0/webinspector/Images/graphLabelCalloutRight.png
+share/webkit-1.0/webinspector/Images/largerResourcesButtonGlyph.png
+share/webkit-1.0/webinspector/Images/localStorage.png
+share/webkit-1.0/webinspector/Images/nodeSearchButtonGlyph.png
+share/webkit-1.0/webinspector/Images/paneBottomGrow.png
+share/webkit-1.0/webinspector/Images/paneBottomGrowActive.png
+share/webkit-1.0/webinspector/Images/paneGrowHandleLine.png
+share/webkit-1.0/webinspector/Images/paneSettingsButtons.png
+share/webkit-1.0/webinspector/Images/pauseOnExceptionButtonGlyph.png
+share/webkit-1.0/webinspector/Images/percentButtonGlyph.png
+share/webkit-1.0/webinspector/Images/profileGroupIcon.png
+share/webkit-1.0/webinspector/Images/profileIcon.png
+share/webkit-1.0/webinspector/Images/profileSmallIcon.png
+share/webkit-1.0/webinspector/Images/profilesIcon.png
+share/webkit-1.0/webinspector/Images/profilesSilhouette.png
+share/webkit-1.0/webinspector/Images/radioDot.png
+share/webkit-1.0/webinspector/Images/recordButtonGlyph.png
+share/webkit-1.0/webinspector/Images/recordToggledButtonGlyph.png
+share/webkit-1.0/webinspector/Images/reloadButtonGlyph.png
+share/webkit-1.0/webinspector/Images/resourceCSSIcon.png
+share/webkit-1.0/webinspector/Images/resourceDocumentIcon.png
+share/webkit-1.0/webinspector/Images/resourceDocumentIconSmall.png
+share/webkit-1.0/webinspector/Images/resourceJSIcon.png
+share/webkit-1.0/webinspector/Images/resourcePlainIcon.png
+share/webkit-1.0/webinspector/Images/resourcePlainIconSmall.png
+share/webkit-1.0/webinspector/Images/resourcesIcon.png
+share/webkit-1.0/webinspector/Images/resourcesSilhouette.png
+share/webkit-1.0/webinspector/Images/resourcesSizeGraphIcon.png
+share/webkit-1.0/webinspector/Images/resourcesTimeGraphIcon.png
+share/webkit-1.0/webinspector/Images/scriptsIcon.png
+share/webkit-1.0/webinspector/Images/scriptsSilhouette.png
+share/webkit-1.0/webinspector/Images/searchSmallBlue.png
+share/webkit-1.0/webinspector/Images/searchSmallBrightBlue.png
+share/webkit-1.0/webinspector/Images/searchSmallGray.png
+share/webkit-1.0/webinspector/Images/searchSmallWhite.png
+share/webkit-1.0/webinspector/Images/segment.png
+share/webkit-1.0/webinspector/Images/segmentEnd.png
+share/webkit-1.0/webinspector/Images/segmentHover.png
+share/webkit-1.0/webinspector/Images/segmentHoverEnd.png
+share/webkit-1.0/webinspector/Images/segmentSelected.png
+share/webkit-1.0/webinspector/Images/segmentSelectedEnd.png
+share/webkit-1.0/webinspector/Images/sessionStorage.png
+share/webkit-1.0/webinspector/Images/splitviewDimple.png
+share/webkit-1.0/webinspector/Images/splitviewDividerBackground.png
+share/webkit-1.0/webinspector/Images/storageIcon.png
+share/webkit-1.0/webinspector/Images/statusbarBackground.png
+share/webkit-1.0/webinspector/Images/statusbarBottomBackground.png
+share/webkit-1.0/webinspector/Images/statusbarButtons.png
+share/webkit-1.0/webinspector/Images/statusbarMenuButton.png
+share/webkit-1.0/webinspector/Images/statusbarMenuButtonSelected.png
+share/webkit-1.0/webinspector/Images/statusbarResizerHorizontal.png
+share/webkit-1.0/webinspector/Images/statusbarResizerVertical.png
+share/webkit-1.0/webinspector/Images/timelineHollowPillBlue.png
+share/webkit-1.0/webinspector/Images/timelineHollowPillGray.png
+share/webkit-1.0/webinspector/Images/timelineHollowPillGreen.png
+share/webkit-1.0/webinspector/Images/timelineHollowPillOrange.png
+share/webkit-1.0/webinspector/Images/timelineHollowPillPurple.png
+share/webkit-1.0/webinspector/Images/timelineHollowPillRed.png
+share/webkit-1.0/webinspector/Images/timelineHollowPillYellow.png
+share/webkit-1.0/webinspector/Images/timelinePillBlue.png
+share/webkit-1.0/webinspector/Images/timelinePillGray.png
+share/webkit-1.0/webinspector/Images/timelinePillGreen.png
+share/webkit-1.0/webinspector/Images/timelinePillOrange.png
+share/webkit-1.0/webinspector/Images/timelinePillPurple.png
+share/webkit-1.0/webinspector/Images/timelinePillRed.png
+share/webkit-1.0/webinspector/Images/timelinePillYellow.png
+share/webkit-1.0/webinspector/Images/tipBalloon.png
+share/webkit-1.0/webinspector/Images/tipBalloonBottom.png
+share/webkit-1.0/webinspector/Images/tipIcon.png
+share/webkit-1.0/webinspector/Images/tipIconPressed.png
+share/webkit-1.0/webinspector/Images/toolbarItemSelected.png
+share/webkit-1.0/webinspector/Images/treeDownTriangleBlack.png
+share/webkit-1.0/webinspector/Images/treeDownTriangleWhite.png
+share/webkit-1.0/webinspector/Images/treeRightTriangleBlack.png
+share/webkit-1.0/webinspector/Images/treeRightTriangleWhite.png
+share/webkit-1.0/webinspector/Images/treeUpTriangleBlack.png
+share/webkit-1.0/webinspector/Images/treeUpTriangleWhite.png
+share/webkit-1.0/webinspector/Images/undockButtonGlyph.png
+share/webkit-1.0/webinspector/Images/userInputIcon.png
+share/webkit-1.0/webinspector/Images/userInputPreviousIcon.png
+share/webkit-1.0/webinspector/Images/userInputResultIcon.png
+share/webkit-1.0/webinspector/Images/warningIcon.png
+share/webkit-1.0/webinspector/Images/warningMediumIcon.png
+share/webkit-1.0/webinspector/Images/warningsErrors.png
+share/webkit-1.0/webinspector/InjectedScript.js
+share/webkit-1.0/webinspector/InjectedScriptAccess.js
+share/webkit-1.0/webinspector/KeyboardShortcut.js
+share/webkit-1.0/webinspector/MetricsSidebarPane.js
+share/webkit-1.0/webinspector/Object.js
+share/webkit-1.0/webinspector/ObjectPropertiesSection.js
+share/webkit-1.0/webinspector/ObjectProxy.js
+share/webkit-1.0/webinspector/Panel.js
+share/webkit-1.0/webinspector/PanelEnablerView.js
+share/webkit-1.0/webinspector/Placard.js
+share/webkit-1.0/webinspector/Popup.js
+share/webkit-1.0/webinspector/ProfileDataGridTree.js
+share/webkit-1.0/webinspector/ProfileView.js
+share/webkit-1.0/webinspector/ProfilesPanel.js
+share/webkit-1.0/webinspector/PropertiesSection.js
+share/webkit-1.0/webinspector/PropertiesSidebarPane.js
+share/webkit-1.0/webinspector/Resource.js
+share/webkit-1.0/webinspector/ResourceCategory.js
+share/webkit-1.0/webinspector/ResourceView.js
+share/webkit-1.0/webinspector/ResourcesPanel.js
+share/webkit-1.0/webinspector/ScopeChainSidebarPane.js
+share/webkit-1.0/webinspector/Script.js
+share/webkit-1.0/webinspector/ScriptView.js
+share/webkit-1.0/webinspector/ScriptsPanel.js
+share/webkit-1.0/webinspector/SidebarPane.js
+share/webkit-1.0/webinspector/SidebarTreeElement.js
+share/webkit-1.0/webinspector/SourceFrame.js
+share/webkit-1.0/webinspector/SourceView.js
+share/webkit-1.0/webinspector/StatusBarButton.js
+share/webkit-1.0/webinspector/StoragePanel.js
+share/webkit-1.0/webinspector/StylesSidebarPane.js
+share/webkit-1.0/webinspector/SummaryBar.js
+share/webkit-1.0/webinspector/TextPrompt.js
+share/webkit-1.0/webinspector/TimelineAgent.js
+share/webkit-1.0/webinspector/TopDownProfileDataGridTree.js
+share/webkit-1.0/webinspector/View.js
+share/webkit-1.0/webinspector/WatchExpressionsSidebarPane.js
+share/webkit-1.0/webinspector/inspector.css
+share/webkit-1.0/webinspector/inspector.html
+share/webkit-1.0/webinspector/inspector.js
+share/webkit-1.0/webinspector/localizedStrings.js
+share/webkit-1.0/webinspector/treeoutline.js
+share/webkit-1.0/webinspector/utilities.js
+@dirrm share/webkit-1.0/webinspector/Images
+@dirrm share/webkit-1.0/webinspector
+@dirrm share/webkit-1.0/resources
+@dirrm share/webkit-1.0/images
+@dirrm share/webkit-1.0
@dirrm include/webkit-1.0/webkit
@dirrm include/webkit-1.0/JavaScriptCore
@dirrm include/webkit-1.0
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin