aboutsummaryrefslogtreecommitdiff
path: root/www/webkit-gtk2
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /www/webkit-gtk2
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'www/webkit-gtk2')
-rw-r--r--www/webkit-gtk2/Makefile19
-rw-r--r--www/webkit-gtk2/files/patch-GNUmakefile.in27
-rw-r--r--www/webkit-gtk2/pkg-plist15
3 files changed, 13 insertions, 48 deletions
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index 7bfc0f0eff29..a90fe81f59ed 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -1,6 +1,6 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/www/webkit-gtk2/Makefile,v 1.92 2013/03/09 09:12:39 kwm Exp $
+# $MCom: ports/trunk/www/webkit-gtk2/Makefile 20029 2014-11-02 20:54:47Z kwm $
PORTNAME= webkit
PORTVERSION= 1.8.3
@@ -12,9 +12,8 @@ PKGNAMESUFFIX= -gtk2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Opensource browser engine
-BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
- ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
- gtkdoc-rebase:${PORTSDIR}/textproc/gtk-doc
+BUILD_DEPENDS= flex>=0:${PORTSDIR}/textproc/flex \
+ gtkdoc-check:${PORTSDIR}/textproc/gtk-doc
LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant \
libicutu.so:${PORTSDIR}/devel/icu \
libcurl.so:${PORTSDIR}/ftp/curl \
@@ -22,7 +21,7 @@ LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant \
USE_GSTREAMER= yes
USE_XORG= xt
-USES= bison gettext gmake libtool perl5 pkgconfig tar:xz
+USES= bison gettext gmake gperf libtool perl5 pkgconfig tar:xz
USE_GNOME= gtk20 libxslt introspection:build
USE_SQLITE= yes
USE_LDCONFIG= yes
@@ -62,6 +61,10 @@ CONFIGURE_ARGS+=--enable-debug
CONFIGURE_ARGS+=--disable-debug
.endif
+.if ${ARCH} == powerpc64
+CFLAGS+= -mminimal-toc
+.endif
+
CCISCLANG!= ${CC} --version
.if !empty(CCISCLANG:M*clang*)
@@ -70,10 +73,6 @@ CPPFLAGS+= -Wno-c++11-extensions
.include <bsd.port.pre.mk>
-.if ${ARCH} == powerpc64
-CFLAGS+= -mminimal-toc
-.endif
-
.if ${PERL_LEVEL} >= 501400
BUILD_DEPENDS+= p5-Switch>0:${PORTSDIR}/lang/p5-Switch
.endif
@@ -87,7 +86,7 @@ post-patch:
${WRKSRC}/Source/WebCore/dom/make_names.pl \
${WRKSRC}/Source/WebCore/css/make-css-file-arrays.pl \
${WRKSRC}/Source/WebCore/bindings/scripts/IDLParser.pm
- @${REINPLACE_CMD} -e 's|"gperf|"${LOCALBASE}/bin/gperf|g' \
+ @${REINPLACE_CMD} -e 's|"gperf|"${GPERF}|g' \
${WRKSRC}/Source/WebCore/css/makevalues.pl \
${WRKSRC}/Source/WebCore/css/makeprop.pl \
${WRKSRC}/Source/WebCore/make-hash-tools.pl
diff --git a/www/webkit-gtk2/files/patch-GNUmakefile.in b/www/webkit-gtk2/files/patch-GNUmakefile.in
index 6071daaeaaf8..6a03d0216437 100644
--- a/www/webkit-gtk2/files/patch-GNUmakefile.in
+++ b/www/webkit-gtk2/files/patch-GNUmakefile.in
@@ -1,16 +1,6 @@
---- GNUmakefile.in.orig 2013-10-03 09:22:02.000000000 +0000
-+++ GNUmakefile.in 2013-10-03 09:23:50.000000000 +0000
-@@ -19060,8 +19060,7 @@
- libjavascriptcoregtk-@WEBKITGTK_API_MAJOR_VERSION@.@WEBKITGTK_API_MINOR_VERSION@.la \
- $(WINMM_LIBS) \
- -lm \
-- -lpthread \
-- -lstdc++
-+ -lpthread
-
- Programs_minidom_LDFLAGS = \
- -no-install \
-@@ -70033,7 +70032,7 @@
+--- GNUmakefile.in.orig 2012-07-13 11:41:16.000000000 +0200
++++ GNUmakefile.in 2012-07-13 11:46:05.000000000 +0200
+@@ -73545,7 +73545,7 @@
info-am:
@@ -19,16 +9,7 @@
install-dist_audioDATA install-dist_resourcesDATA \
install-dist_webinspectorDATA \
install-dist_webinspectorimagesDATA \
-@@ -70388,7 +70387,7 @@
- @ENABLE_INTROSPECTION_TRUE@ --pkg=gobject-2.0 \
- @ENABLE_INTROSPECTION_TRUE@ --pkg=gtk+-@GTK_API_VERSION@ \
- @ENABLE_INTROSPECTION_TRUE@ --pkg=libsoup-2.4 \
--@ENABLE_INTROSPECTION_TRUE@ --pkg-export=webkitgtk-@WEBKITGTK_API_VERSION@ \
-+@ENABLE_INTROSPECTION_TRUE@ --pkg-export=@WEBKITGTK_PC_NAME@-@WEBKITGTK_API_VERSION@ \
- @ENABLE_INTROSPECTION_TRUE@ --output=$@ \
- @ENABLE_INTROSPECTION_TRUE@ --add-include-path=$(WebKit) \
- @ENABLE_INTROSPECTION_TRUE@ --add-include-path=$(top_builddir) \
-@@ -70680,7 +70679,7 @@
+@@ -74192,7 +74192,7 @@
echo "File $$lang.po does not exist. If you are a translator, you can create it through 'msginit'." 1>&2; \
exit 1
diff --git a/www/webkit-gtk2/pkg-plist b/www/webkit-gtk2/pkg-plist
index 433949b8b000..59f19f5c0fb1 100644
--- a/www/webkit-gtk2/pkg-plist
+++ b/www/webkit-gtk2/pkg-plist
@@ -663,18 +663,3 @@ share/webkitgtk-1.0/webinspector/textViewer.css
share/webkitgtk-1.0/webinspector/timelinePanel.css
share/webkitgtk-1.0/webinspector/treeoutline.js
share/webkitgtk-1.0/webinspector/utilities.js
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrm share/webkitgtk-1.0/webinspector/UglifyJS
-@dirrm share/webkitgtk-1.0/webinspector/Images
-@dirrm share/webkitgtk-1.0/webinspector
-@dirrm share/webkitgtk-1.0/resources
-@dirrm share/webkitgtk-1.0/images
-@dirrm share/webkitgtk-1.0
-@dirrm include/webkitgtk-1.0/webkit2/WebKit2
-@dirrm include/webkitgtk-1.0/webkit2
-@dirrm include/webkitgtk-1.0/webkit
-@dirrm include/webkitgtk-1.0/JavaScriptCore
-@dirrm include/webkitgtk-1.0