aboutsummaryrefslogtreecommitdiff
path: root/www/webkit-gtk3
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-09-11 14:30:25 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-09-11 14:30:25 +0000
commit2a42319cd578b3aeea2a279e18944dbdb2f00593 (patch)
tree21501eb3dbd968fe2155a6e81e476b88d9080f83 /www/webkit-gtk3
parent6b2eda67b8fc373a5ffaf3151b3742ee7510cb5c (diff)
Notes
Diffstat (limited to 'www/webkit-gtk3')
-rw-r--r--www/webkit-gtk3/Makefile2
-rw-r--r--www/webkit-gtk3/files/patch-icu5964
2 files changed, 65 insertions, 1 deletions
diff --git a/www/webkit-gtk3/Makefile b/www/webkit-gtk3/Makefile
index afe579a18713..5b96fb69cbc2 100644
--- a/www/webkit-gtk3/Makefile
+++ b/www/webkit-gtk3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= webkit
PORTVERSION= 2.4.11
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= www
MASTER_SITES= http://webkitgtk.org/releases/
PKGNAMESUFFIX= -gtk3
diff --git a/www/webkit-gtk3/files/patch-icu59 b/www/webkit-gtk3/files/patch-icu59
new file mode 100644
index 000000000000..c9a3a7eebbd9
--- /dev/null
+++ b/www/webkit-gtk3/files/patch-icu59
@@ -0,0 +1,64 @@
+------------------------------------------------------------------------
+r216187 | annulen@yandex.ru | 2017-05-05 00:33:41 +0900 (Fri, 05 May 2017) | 28 lines
+
+Fix compilation with ICU 59.1
+https://bugs.webkit.org/show_bug.cgi?id=171612
+
+Reviewed by Mark Lam.
+
+ICU 59.1 has broken source compatibility. Now it defines UChar as
+char16_t, which does not allow automatic type conversion from unsigned
+short in C++ code.
+
+--- Source/JavaScriptCore/API/JSStringRef.cpp.orig 2016-04-10 06:48:36 UTC
++++ Source/JavaScriptCore/API/JSStringRef.cpp
+@@ -37,7 +37,7 @@ using namespace WTF::Unicode;
+ JSStringRef JSStringCreateWithCharacters(const JSChar* chars, size_t numChars)
+ {
+ initializeThreading();
+- return OpaqueJSString::create(chars, numChars).leakRef();
++ return OpaqueJSString::create(reinterpret_cast<const UChar*>(chars), numChars).leakRef();
+ }
+
+ JSStringRef JSStringCreateWithUTF8CString(const char* string)
+@@ -62,7 +62,7 @@ JSStringRef JSStringCreateWithUTF8CString(const char*
+ JSStringRef JSStringCreateWithCharactersNoCopy(const JSChar* chars, size_t numChars)
+ {
+ initializeThreading();
+- return OpaqueJSString::create(StringImpl::createWithoutCopying(chars, numChars)).leakRef();
++ return OpaqueJSString::create(StringImpl::createWithoutCopying(reinterpret_cast<const UChar*>(chars), numChars)).leakRef();
+ }
+
+ JSStringRef JSStringRetain(JSStringRef string)
+@@ -83,7 +83,7 @@ size_t JSStringGetLength(JSStringRef string)
+
+ const JSChar* JSStringGetCharactersPtr(JSStringRef string)
+ {
+- return string->characters();
++ return reinterpret_cast<const JSChar*>(string->characters());
+ }
+
+ size_t JSStringGetMaximumUTF8CStringSize(JSStringRef string)
+--- Source/JavaScriptCore/runtime/DateConversion.cpp.orig 2013-08-03 16:10:38 UTC
++++ Source/JavaScriptCore/runtime/DateConversion.cpp
+@@ -107,7 +107,8 @@ String formatDateTime(const GregorianDateTime& t, Date
+ #if OS(WINDOWS)
+ TIME_ZONE_INFORMATION timeZoneInformation;
+ GetTimeZoneInformation(&timeZoneInformation);
+- const WCHAR* timeZoneName = t.isDST() ? timeZoneInformation.DaylightName : timeZoneInformation.StandardName;
++ const WCHAR* winTimeZoneName = t.isDST() ? timeZoneInformation.DaylightName : timeZoneInformation.StandardName;
++ String timeZoneName(reinterpret_cast<const UChar*>(winTimeZoneName));
+ #else
+ struct tm gtm = t;
+ char timeZoneName[70];
+--- Source/WebKit2/Shared/API/c/WKString.cpp.orig 2016-04-10 06:48:37 UTC
++++ Source/WebKit2/Shared/API/c/WKString.cpp
+@@ -55,7 +55,7 @@ size_t WKStringGetLength(WKStringRef stringRef)
+ size_t WKStringGetCharacters(WKStringRef stringRef, WKChar* buffer, size_t bufferLength)
+ {
+ COMPILE_ASSERT(sizeof(WKChar) == sizeof(UChar), WKStringGetCharacters_sizeof_WKChar_matches_UChar);
+- return (toImpl(stringRef)->getCharacters(static_cast<UChar*>(buffer), bufferLength));
++ return (toImpl(stringRef)->getCharacters(reinterpret_cast<UChar*>(buffer), bufferLength));
+ }
+
+ size_t WKStringGetMaximumUTF8CStringSize(WKStringRef stringRef)