aboutsummaryrefslogtreecommitdiff
path: root/www/webkit-sharp/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2009-02-09 09:00:01 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2009-02-09 09:00:01 +0000
commitc1f23cd26d8ec0c157abfb1fe1f52b3aaddee6e8 (patch)
tree6bc6e9b8c27f338bda10b7f147eca039dcc7fb74 /www/webkit-sharp/Makefile
parentfe3abfcfc73764b4d8ad08d6d32c488a049a1b26 (diff)
Notes
Diffstat (limited to 'www/webkit-sharp/Makefile')
-rw-r--r--www/webkit-sharp/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/webkit-sharp/Makefile b/www/webkit-sharp/Makefile
new file mode 100644
index 000000000000..035dbfaf3e1a
--- /dev/null
+++ b/www/webkit-sharp/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: webkit-sharp
+# Date created: 2008-09-01
+# Whom: Romain Tartiere <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webkit-sharp
+PORTVERSION= 0.2
+#PORTREVISION= 0
+#PORTEPOCH= 0
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.novell.com/pub/mono/sources/${PORTNAME}/
+#MASTER_SITE_SUBDIR=
+#PKGNAMEPREFIX=
+#PKGNAMESUFFIX=
+#DISTNAME=
+#EXTRACT_SUFX=
+#DISTFILES=
+#DIST_SUBDIR= ${PORTNAME}
+#EXTRACT_ONLY=
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= Mono bindings for Webkit
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/webkit-1.0.pc:${PORTSDIR}/www/webkit-gtk2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gtksharp20
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>