aboutsummaryrefslogtreecommitdiff
path: root/www/webkit2-gtk3
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2020-01-26 17:53:56 +0000
committerKoop Mast <kwm@FreeBSD.org>2020-01-26 17:53:56 +0000
commitb41eeed6ce22f053716b238898019365c08d847c (patch)
tree0e0861702e339690bbd3349b0c1cdba738873170 /www/webkit2-gtk3
parent22bb132481e0404009593335cf84ffacbb53c052 (diff)
downloadports-b41eeed6ce22f053716b238898019365c08d847c.tar.gz
ports-b41eeed6ce22f053716b238898019365c08d847c.zip
Update webkit-gtk3 to 2.26.3.
* Fix issues while trying to play a video on NextCloud. * Make sure the GL video sink uses a valid WebKit shared GL context. * Fix vertical alignment of text containing arabic diacritics. * Fix build with icu 65.1. * Fix page loading errors with websites using HSTS. * Fix web process crash when displaying a KaTeX formula. * Fix several crashes and rendering issues. This release also fixes 3 CVE's. MFH: 2020Q1 Security: dc8cff4c-4063-11ea-8a94-3497f6939fdd
Notes
Notes: svn path=/head/; revision=524226
Diffstat (limited to 'www/webkit2-gtk3')
-rw-r--r--www/webkit2-gtk3/Makefile2
-rw-r--r--www/webkit2-gtk3/distinfo6
-rw-r--r--www/webkit2-gtk3/files/patch-Source_WTF_wtf_URLHelpers.cpp24
-rw-r--r--www/webkit2-gtk3/files/patch-Source_WebCore_dom_Document.cpp42
-rw-r--r--www/webkit2-gtk3/pkg-plist4
5 files changed, 6 insertions, 72 deletions
diff --git a/www/webkit2-gtk3/Makefile b/www/webkit2-gtk3/Makefile
index c00f910825d8..4f92b2b1aefe 100644
--- a/www/webkit2-gtk3/Makefile
+++ b/www/webkit2-gtk3/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= webkit
-PORTVERSION= 2.26.2
+PORTVERSION= 2.26.3
CATEGORIES= www
MASTER_SITES= https://webkitgtk.org/releases/
PKGNAMESUFFIX= 2-gtk3
diff --git a/www/webkit2-gtk3/distinfo b/www/webkit2-gtk3/distinfo
index 712bcd37358b..6308728133ed 100644
--- a/www/webkit2-gtk3/distinfo
+++ b/www/webkit2-gtk3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1574792040
-SHA256 (gnome/webkitgtk-2.26.2.tar.xz) = 6b80f0637a80818559ac8fd50db3b394f41cb61904fb9b3ed65fa51635806512
-SIZE (gnome/webkitgtk-2.26.2.tar.xz) = 19330000
+TIMESTAMP = 1579976981
+SHA256 (gnome/webkitgtk-2.26.3.tar.xz) = add51153943cc11d90a7038d0ea5f6332281e6c0be0640f802a211b035f0e611
+SIZE (gnome/webkitgtk-2.26.3.tar.xz) = 19331900
diff --git a/www/webkit2-gtk3/files/patch-Source_WTF_wtf_URLHelpers.cpp b/www/webkit2-gtk3/files/patch-Source_WTF_wtf_URLHelpers.cpp
deleted file mode 100644
index ae3e8ffa3d1d..000000000000
--- a/www/webkit2-gtk3/files/patch-Source_WTF_wtf_URLHelpers.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
-Regressed by https://github.com/unicode-org/icu/commit/480bec3ea652
-
-Source/WTF/wtf/URLHelpers.cpp:301:39: error: expected ';' after do/while statement
- U16_NEXT(buffer, i, length, c)
- ^
- ;
-Source/WTF/wtf/URLHelpers.cpp:303:52: error: use of undeclared identifier 'error'
- UScriptCode script = uscript_getScript(c, &error);
- ^
-Source/WTF/wtf/URLHelpers.cpp:304:13: error: use of undeclared identifier 'error'
- if (error != U_ZERO_ERROR) {
- ^
-
---- Source/WTF/wtf/URLHelpers.cpp.orig 2019-08-26 14:55:44 UTC
-+++ Source/WTF/wtf/URLHelpers.cpp
-@@ -298,7 +298,7 @@ static bool allCharactersInIDNScriptWhiteList(const UC
- Optional<UChar32> previousCodePoint;
- while (i < length) {
- UChar32 c;
-- U16_NEXT(buffer, i, length, c)
-+ U16_NEXT(buffer, i, length, c);
- UErrorCode error = U_ZERO_ERROR;
- UScriptCode script = uscript_getScript(c, &error);
- if (error != U_ZERO_ERROR) {
diff --git a/www/webkit2-gtk3/files/patch-Source_WebCore_dom_Document.cpp b/www/webkit2-gtk3/files/patch-Source_WebCore_dom_Document.cpp
deleted file mode 100644
index a2748f3053dd..000000000000
--- a/www/webkit2-gtk3/files/patch-Source_WebCore_dom_Document.cpp
+++ /dev/null
@@ -1,42 +0,0 @@
-Regressed by https://github.com/unicode-org/icu/commit/480bec3ea652
-
-In file included from DerivedSources/WebCore/unified-sources/UnifiedSource-be65d27a-6.cpp:4:
-Source/WebCore/dom/Document.cpp:5075:39: error: expected ';' after do/while statement
- U16_NEXT(characters, i, length, c)
- ^
- ;
-Source/WebCore/dom/Document.cpp:5080:43: error: expected ';' after do/while statement
- U16_NEXT(characters, i, length, c)
- ^
- ;
-Source/WebCore/dom/Document.cpp:5140:46: error: expected ';' after do/while statement
- U16_NEXT(qualifiedName, i, length, c)
- ^
- ;
-
---- Source/WebCore/dom/Document.cpp.orig 2019-08-26 14:55:45 UTC
-+++ Source/WebCore/dom/Document.cpp
-@@ -5072,12 +5072,12 @@ static bool isValidNameNonASCII(const UChar* character
- unsigned i = 0;
-
- UChar32 c;
-- U16_NEXT(characters, i, length, c)
-+ U16_NEXT(characters, i, length, c);
- if (!isValidNameStart(c))
- return false;
-
- while (i < length) {
-- U16_NEXT(characters, i, length, c)
-+ U16_NEXT(characters, i, length, c);
- if (!isValidNamePart(c))
- return false;
- }
-@@ -5137,7 +5137,7 @@ ExceptionOr<std::pair<AtomicString, AtomicString>> Doc
-
- for (unsigned i = 0; i < length; ) {
- UChar32 c;
-- U16_NEXT(qualifiedName, i, length, c)
-+ U16_NEXT(qualifiedName, i, length, c);
- if (c == ':') {
- if (sawColon)
- return Exception { InvalidCharacterError };
diff --git a/www/webkit2-gtk3/pkg-plist b/www/webkit2-gtk3/pkg-plist
index 2832f4acb9c8..9068caf15bc5 100644
--- a/www/webkit2-gtk3/pkg-plist
+++ b/www/webkit2-gtk3/pkg-plist
@@ -214,10 +214,10 @@ lib/girepository-1.0/WebKit2-4.0.typelib
lib/girepository-1.0/WebKit2WebExtension-4.0.typelib
lib/libjavascriptcoregtk-4.0.so
lib/libjavascriptcoregtk-4.0.so.18
-lib/libjavascriptcoregtk-4.0.so.18.14.7
+lib/libjavascriptcoregtk-4.0.so.18.14.8
lib/libwebkit2gtk-4.0.so
lib/libwebkit2gtk-4.0.so.37
-lib/libwebkit2gtk-4.0.so.37.39.3
+lib/libwebkit2gtk-4.0.so.37.39.4
lib/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
libdata/pkgconfig/javascriptcoregtk-4.0.pc
libdata/pkgconfig/webkit2gtk-4.0.pc