aboutsummaryrefslogtreecommitdiff
path: root/www/webreport/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-02-17 14:34:14 +0000
committerClement Laforet <clement@FreeBSD.org>2004-02-17 14:34:14 +0000
commitc3ed9d9db4dd2128269f62c2baf952249ab52498 (patch)
treed2db277cbeb61428e364b52388a081a4f904cda4 /www/webreport/Makefile
parent8d6b3d812f9108907459a7e07e6937bd812bde2c (diff)
Notes
Diffstat (limited to 'www/webreport/Makefile')
-rw-r--r--www/webreport/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/webreport/Makefile b/www/webreport/Makefile
new file mode 100644
index 000000000000..e11484c014af
--- /dev/null
+++ b/www/webreport/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: webreport
+# Date created: 06 Feb 2004
+# Whom: ismail@enderunix.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= webreport
+PORTVERSION= 1.5
+CATEGORIES= www
+MASTER_SITES= http://www.inter7.com/webreport/
+
+MAINTAINER= ismail@EnderUNIX.org
+COMMENT= WebReport is a web log statistics program for web hosting sites
+
+USE_REINPLACE= yes
+
+PORTDOCS= INSTALL
+PLIST_FILES= bin/webreport etc/webreport.conf-dist
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,ulong,unsigned long,;s,/etc/,${PREFIX}/etc/,' ${WRKSRC}/webreport.h
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/webreport ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/webreport.conf ${PREFIX}/etc/webreport.conf-dist
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g'
+
+.include <bsd.port.mk>