aboutsummaryrefslogtreecommitdiff
path: root/www/wikindx/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-26 00:08:14 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-26 00:08:14 +0000
commitc3c39d1634a8777f38daadb44949ef09a6b408e1 (patch)
treeda248b4e3df4cd5c0b2df78d937b924b430edacc /www/wikindx/Makefile
parent0b9668650e60249714f149fb4a7376741b26442f (diff)
downloadports-c3c39d1634a8777f38daadb44949ef09a6b408e1.tar.gz
ports-c3c39d1634a8777f38daadb44949ef09a6b408e1.zip
Notes
Diffstat (limited to 'www/wikindx/Makefile')
-rw-r--r--www/wikindx/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/www/wikindx/Makefile b/www/wikindx/Makefile
new file mode 100644
index 000000000000..ba8dd1688e31
--- /dev/null
+++ b/www/wikindx/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: wikindx
+# Date created: 23 Dec 2005
+# Whom: babak@farrokhi.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= wikindx
+PORTVERSION= 3.2.2
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= wikindx
+DISTNAME= wikindx3_2_2
+
+MAINTAINER= babak@farrokhi.net
+COMMENT= Bibliographic and quotations/notes management system
+
+USE_PHP= session mysql
+
+NO_BUILD= YES
+WRKSRC= ${WRKDIR}/wikindx3
+PHP4_PORT?= www/mod_php4
+WIKINDX?= www/data-dist/wikindx
+PLIST_SUB+= WIKINDX=${WIKINDX}
+#SUB_FILES= pkg-message
+ROOTFILES= config.php index.php rss.php
+ROOTDIRS= attachments core docs files languages modules \
+ papers styles templates update
+DOCFILES= CHANGELOG CUSTOMIZATION DISCLAIMER INSTALL \
+ LICENSE README README_RSS UPDATEWIKINDX
+
+do-install:
+ -${MKDIR} ${PREFIX}/${WIKINDX}
+ (cd ${WRKSRC} && ${CP} ${ROOTFILES} ${PREFIX}/${WIKINDX}/ )
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${WIKINDX}
+.for i in ${ROOTDIRS}
+ @(cd ${WRKSRC} && ${CP} -R ${i} ${PREFIX}/${WIKINDX}/ )
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${DOCFILES}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
+.endfor
+.endif
+
+#post-install:
+# @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>