aboutsummaryrefslogtreecommitdiff
path: root/www/wordpress
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-12-02 10:46:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-12-02 10:46:37 +0000
commit30d06464016c964d3a650204b36b0b1b9054ffdc (patch)
tree6cb7b0151d701f33ad44bc87af347ba8372e07cf /www/wordpress
parentd3427e537856f0157e6a0a865bc2adebc2a74306 (diff)
downloadports-30d06464016c964d3a650204b36b0b1b9054ffdc.tar.gz
ports-30d06464016c964d3a650204b36b0b1b9054ffdc.zip
Notes
Diffstat (limited to 'www/wordpress')
-rw-r--r--www/wordpress/Makefile39
-rw-r--r--www/wordpress/distinfo5
-rw-r--r--www/wordpress/pkg-message11
3 files changed, 19 insertions, 36 deletions
diff --git a/www/wordpress/Makefile b/www/wordpress/Makefile
index 42d71fa10c24..6be1dd0f9795 100644
--- a/www/wordpress/Makefile
+++ b/www/wordpress/Makefile
@@ -6,28 +6,20 @@
#
PORTNAME= wordpress
-PORTVERSION= 3.0.1
-PORTREVISION= 1
+PORTVERSION= 3.0.2
PORTEPOCH= 1
CATEGORIES= www
-MASTER_SITES= http://wordpress.org/ \
- ftp://ftp.stu.edu.tw/pub/wordpress/ \
- ftp://ftp.twaren.net/local-distfiles/wordpress/
-MASTER_SITE_SUBDIR= cafelog
-#DISTNAME= wordpress-${PORTVERSION:S/.0//}
+MASTER_SITES= http://wordpress.org/
MAINTAINER= ychsiao@ychsiao.org
COMMENT= A state-of-the-art semantic personal publishing platform
+NO_BUILD= yes
+USE_PHP= gd mysql pcre tokenizer xml zip
+WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_PHP= mysql pcre xml gd tokenizer zip
-NO_BUILD= YES
-WANT_PHP_WEB= YES
-WORDPRESS?= www/data/wordpress
-PLIST_SUB+= WORDPRESS=${WORDPRESS}
PLIST= ${WRKDIR}/pkg-plist
-
PORTDOCS= license.txt readme.html
pre-everything::
@@ -36,25 +28,18 @@ pre-everything::
@sleep 1
pre-install:
- cd ${WRKSRC} && ${FIND} -s * -type f | \
- ${SED} -e 's|^|${WORDPRESS}/|' > ${PLIST} \
- && ${FIND} -d * -type d | \
- ${SED} -e 's|^|@dirrm ${WORDPRESS}/|' >> ${PLIST} \
- && ${ECHO_CMD} @dirrm ${WORDPRESS} >> ${PLIST} \
- && ${ECHO_CMD} @dirrmtry www/data >> ${PLIST}
+ cd ${WRKSRC}/ && \
+ (${FIND} -s * -type f | ${SED} -e 's|^|%%WWWDIR%%/|'; \
+ ${FIND} -d . -type d | ${SED} -e 's|^\.|@dirrm %%WWWDIR%%|') > ${PLIST}
if [ ! -f ${WRKSRC}/wp-config-sample.php ]; then ${CP} \
${WRKSRC}/wp-config.php.sample ${WRKSRC}/wp-config.php; fi
do-install:
- -@${MKDIR} ${PREFIX}/${WORDPRESS}
- @${CHOWN} ${WWWOWN}:${WWWGRP} ${PREFIX}/${WORDPRESS}
- @${CHMOD} 755 ${PREFIX}/${WORDPRESS}
- ${CP} -R ${WRKSRC}/ ${PREFIX}/${WORDPRESS}
+ ${INSTALL} -d -g ${WWWGRP} -m 755 -o ${WWWOWN} ${WWWDIR}/
+ ${CP} -R ${WRKSRC}/ ${WWWDIR}/
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
-.endfor
+ ${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
post-install:
diff --git a/www/wordpress/distinfo b/www/wordpress/distinfo
index f38512770784..2ab8997edfda 100644
--- a/www/wordpress/distinfo
+++ b/www/wordpress/distinfo
@@ -1,3 +1,2 @@
-MD5 (wordpress-3.0.1.tar.gz) = 8fa5373ed805fb9a6ee56dfd236dcb64
-SHA256 (wordpress-3.0.1.tar.gz) = fd76fb7683c32c4f2d65f5b2cd015cb62d19f1017e3b020f34a98d1b480e1818
-SIZE (wordpress-3.0.1.tar.gz) = 2684855
+SHA256 (wordpress-3.0.2.tar.gz) = cc6f8707a4b19d44845abec890f7767ef6e053cb71e5799ac9b3705425611d4f
+SIZE (wordpress-3.0.2.tar.gz) = 2688999
diff --git a/www/wordpress/pkg-message b/www/wordpress/pkg-message
index 1e3bb52ff1f2..0fcaa079166e 100644
--- a/www/wordpress/pkg-message
+++ b/www/wordpress/pkg-message
@@ -1,7 +1,6 @@
**** NOTE ****
- Before the first use of WordPress, copy wp-config-sample.php to wp-config.php
- in ${PREFIX}/${WORDPRESS}
- And Modify it to fit your MySQL.
- Maybe you need 'mysqladmin create wordpress' first
- If you are upgrading from 1.x or 2.x to 3.x, please run
- http://your.site/wordpress/wp-admin/upgrade.php to upgrade to WordPress 3.0.0
+Before the first use of WordPress, copy wp-config-sample.php to wp-config.php
+in ${WWWDIR} and modify it to fit your MySQL.
+Maybe you need 'mysqladmin create wordpress' first.
+If you are upgrading from 1.x or 2.x to 3.x, please run
+http://your.site/wordpress/wp-admin/upgrade.php to upgrade to WordPress 3.x