aboutsummaryrefslogtreecommitdiff
path: root/www/wwwoffle
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-24 16:12:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-24 16:12:25 +0000
commite6ae54fbdd5b47cf5179d9a2f8665ca0c01e00e2 (patch)
treefa9a5655a556b905b9ec6843a4f6adc2c3b0e6ca /www/wwwoffle
parent81f1b6daea05e7741a5ef35cd06baf8f541ed2aa (diff)
- Update MASTER_SITES and WWW: line
- Add LICENSE - Add MAKE_JOBS_SAFE - Support SUB_FILES/SUB_LIST PR: 177263 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=315139
Diffstat (limited to 'www/wwwoffle')
-rw-r--r--www/wwwoffle/Makefile32
-rw-r--r--www/wwwoffle/files/pkg-message.in15
-rw-r--r--www/wwwoffle/pkg-descr2
-rw-r--r--www/wwwoffle/pkg-message15
4 files changed, 28 insertions, 36 deletions
diff --git a/www/wwwoffle/Makefile b/www/wwwoffle/Makefile
index 7ed799a861ca..f963bc560b29 100644
--- a/www/wwwoffle/Makefile
+++ b/www/wwwoffle/Makefile
@@ -1,24 +1,24 @@
-# New ports collection makefile for: wwwoffle
-# Date created: 1 Jun 1998
-# Whom: Peter Mutsaers
-#
+# Creaed by: Peter Mutsaers
# $FreeBSD$
-#
PORTNAME= wwwoffle
PORTVERSION= 2.9i
PORTREVISION= 1
CATEGORIES= www ipv6
-MASTER_SITES= http://www.gedanken.demon.co.uk/download-wwwoffle/
+MASTER_SITES= http://www.gedanken.org.uk/software/wwwoffle/download/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= A caching proxy server for HTTP and FTP designed for dial-up hosts
+COMMENT= Caching proxy server for HTTP and FTP designed for dial-up hosts
-LIB_DEPENDS= gnutls.26:${PORTSDIR}/security/gnutls
+LICENSE= GPLv2
+
+LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls
USE_PERL5= yes
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
+
USE_RC_SUBR= ${PORTNAME}d
# $SPOOL seems like a common name which could be used for other things, so
@@ -30,26 +30,18 @@ PLIST_SUB+= WWWOFFLE_SPOOL=${WWWOFFLE_SPOOL}
HAS_CONFIGURE= yes
CONFIGURE_ENV= LIBS=-lmd
CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc --with-ipv6 \
- --with-gnutls=${PREFIX} \
+ --with-gnutls=${LOCALBASE} \
--with-spooldir=${WWWOFFLE_SPOOL} \
--docdir=${DOCSDIR} \
--mandir=${MANPREFIX}/man
+SUB_FILES= pkg-message
+SUB_LIST= WWWOFFLE_SPOOL="${WWWOFFLE_SPOOL}"
+
MAN1= wwwoffle.1
MAN5= wwwoffle.conf.5
MAN8= wwwoffled.8
-.if ${WWWOFFLE_SPOOL} != "/var/spool/wwwoffle"
-# If using a non-standard spool, change all the documentation (and anything
-# else) to reflect that.
-PKGMESSAGE=${WRKDIR}/MESSAGE
-
-post-configure:
- @${SED} 's@/var/spool/wwwoffle@${WWWOFFLE_SPOOL}/wwwoffle@g' \
- ${PKGDIR}/pkg-message > ${PKGMESSAGE}
-
-.endif
-
post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/conf/upgrade-config.pl ${WWWOFFLE_SPOOL}
@${CAT} ${PKGMESSAGE}
diff --git a/www/wwwoffle/files/pkg-message.in b/www/wwwoffle/files/pkg-message.in
new file mode 100644
index 000000000000..195bd62bfc08
--- /dev/null
+++ b/www/wwwoffle/files/pkg-message.in
@@ -0,0 +1,15 @@
+NOTES:
+
+Please copy %%WWWOFFLE_SPOOL%%/wwwoffle.conf.install to
+%%WWWOFFLE_SPOOL%%/wwwoffle.conf, and edit the copy as needed.
+
+If you are upgrading from an old version of wwwoffle, you may need to
+convert the cache directory structure to work with the new version. You
+can find programs in the WWWOFFLE distribution tarball to do this, along
+with instructions about what is needed. A more common requirement is to
+run the `upgrade-config.pl' script, so you will find a copy of this in
+%%WWWOFFLE_SPOOL%%/upgrade-config.pl. You should run this on your
+configuration file, e.g.:
+
+ $ perl %%WWWOFFLE_SPOOL%%/upgrade-config.pl \
+ %%PREFIX%%/etc/wwwoffle.conf
diff --git a/www/wwwoffle/pkg-descr b/www/wwwoffle/pkg-descr
index c649926254d2..2e51534f8113 100644
--- a/www/wwwoffle/pkg-descr
+++ b/www/wwwoffle/pkg-descr
@@ -9,4 +9,4 @@ browse web pages and read them without having to remain connected.
* Control which pages can be requested when offline.
* Provides non-cached access to intranet servers.
-WWW: http://www.gedanken.demon.co.uk/wwwoffle/
+WWW: http://www.gedanken.org.uk/software/wwwoffle/
diff --git a/www/wwwoffle/pkg-message b/www/wwwoffle/pkg-message
deleted file mode 100644
index 7c5cbdaf1b13..000000000000
--- a/www/wwwoffle/pkg-message
+++ /dev/null
@@ -1,15 +0,0 @@
-NOTES:
-
-Please copy /var/spool/wwwoffle/wwwoffle.conf.install to
-/var/spool/wwwoffle/wwwoffle.conf, and edit the copy as needed.
-
-If you are upgrading from an old version of wwwoffle, you may need to
-convert the cache directory structure to work with the new version. You
-can find programs in the WWWOFFLE distribution tarball to do this, along
-with instructions about what is needed. A more common requirement is to run
-the `upgrade-config.pl' script, so you will find a copy of this in
-/var/spool/wwwoffle/upgrade-config.pl. You should run this on your
-configuration file, e.g.:
-
- $ perl /var/spool/wwwoffle/upgrade-config.pl \
- /usr/local/etc/wwwoffle.conf