aboutsummaryrefslogtreecommitdiff
path: root/www/xcache
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2012-12-10 14:48:35 +0000
committerAlex Dupre <ale@FreeBSD.org>2012-12-10 14:48:35 +0000
commite879bf0e28bd8041b3bf436362433c7fc9f35a9c (patch)
treeca4a06b3e051d1097407a6e2661beef7f1532d26 /www/xcache
parente568062c7394facdcb67b8df915b80896275c052 (diff)
downloadports-e879bf0e28bd8041b3bf436362433c7fc9f35a9c.tar.gz
ports-e879bf0e28bd8041b3bf436362433c7fc9f35a9c.zip
Notes
Diffstat (limited to 'www/xcache')
-rw-r--r--www/xcache/Makefile36
-rw-r--r--www/xcache/distinfo4
-rw-r--r--www/xcache/files/patch-xcache.ini25
-rw-r--r--www/xcache/pkg-plist35
4 files changed, 18 insertions, 82 deletions
diff --git a/www/xcache/Makefile b/www/xcache/Makefile
index c266529f6727..f79bfcd3d962 100644
--- a/www/xcache/Makefile
+++ b/www/xcache/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: xcache
-# Date created: 28 May 2006
-# Whom: Alex Dupre <ale@FreeBSD.org>
-#
+# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xcache
-DISTVERSION= 2.0.1
+DISTVERSION= 3.0.0
CATEGORIES= www
MASTER_SITES= http://xcache.lighttpd.net/pub/Releases/${DISTVERSION}/
@@ -19,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_BZIP2= yes
USE_PHP= yes
USE_PHPIZE= yes
+USE_GMAKE= yes
CONFIGURE_ARGS= --enable-xcache=shared
@@ -29,16 +26,10 @@ COVERAGER_DESC= Enable code coverage dumper
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-ADMINFILES= common-en.lang.php common-zh-simplified-utf-8.lang.php \
- common-zh-traditional-utf-8.lang.php common.php config.default.php \
- config.example.php edit.php edit.tpl.php footer.tpl.php header.tpl.php \
- help-en.lang.php help-zh-simplified-utf-8.lang.php \
- help-zh-traditional-utf-8.lang.php help.php index.php \
- mkpassword.php tablesort.js xcache.css xcache.php xcache.tpl.php
+PLIST_FILES= lib/php/%%PHP_EXT_DIR%%/xcache.so
+PLIST_DIRSTRY= lib/php/%%PHP_EXT_DIR%%
-COVERAGERFILES= common-en.lang.php common-zh-simplified-gb2312.lang.php \
- common-zh-simplified-utf-8.lang.php common.php config.php.example \
- coverager.css coverager.php coverager.tpl.php index.php
+PORTEXAMPLES= *
.include <bsd.port.options.mk>
@@ -53,10 +44,6 @@ PLIST_SUB+= COVERAGER=""
PLIST_SUB+= COVERAGER="@comment "
.endif
-post-build:
- @${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|;s|%%PHP_EXT_DIR%%|${PHP_EXT_DIR}|' \
- ${WRKSRC}/xcache.ini
-
do-install:
@${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}
${INSTALL_DATA} ${WRKSRC}/modules/${PORTNAME}.so \
@@ -64,18 +51,9 @@ do-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/xcache.ini \
${EXAMPLESDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} htdocs ${EXAMPLESDIR}
post-install:
- @${MKDIR} ${EXAMPLESDIR}/admin
-.for f in ${ADMINFILES}
- ${INSTALL_DATA} ${WRKSRC}/admin/${f} ${EXAMPLESDIR}/admin
-.endfor
-.if defined(WITH_COVERAGER)
- @${MKDIR} ${EXAMPLESDIR}/coverager
-.for f in ${COVERAGERFILES}
- ${INSTALL_DATA} ${WRKSRC}/coverager/${f} ${EXAMPLESDIR}/coverager
-.endfor
-.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/www/xcache/distinfo b/www/xcache/distinfo
index c3479d941aaa..e52e75009a18 100644
--- a/www/xcache/distinfo
+++ b/www/xcache/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xcache-2.0.1.tar.bz2) = b6e350f3b327b11e033da44f8b5f464b173e2256b5acc792a1179d29cb499289
-SIZE (xcache-2.0.1.tar.bz2) = 112352
+SHA256 (xcache-3.0.0.tar.bz2) = a0db8326c58b7fb04ea22cc40fe478f6c6fc2b23880f5739dfa7250df66bd8e0
+SIZE (xcache-3.0.0.tar.bz2) = 148899
diff --git a/www/xcache/files/patch-xcache.ini b/www/xcache/files/patch-xcache.ini
index e727ad3fb912..0e54c1f5be64 100644
--- a/www/xcache/files/patch-xcache.ini
+++ b/www/xcache/files/patch-xcache.ini
@@ -1,19 +1,12 @@
---- xcache.ini.orig 2012-08-08 16:59:55.000000000 +0200
-+++ xcache.ini 2012-08-08 17:03:46.000000000 +0200
-@@ -3,17 +3,13 @@
- ;; WARNING: zend_extension* = *xcache* MUST be the first(above) of all zend_extension*=*
- ;; using extension=xcache.so is not recommended
-
--;; non-windows example
--;; update xxx accordingly
--zend_extension = /usr/local/lib/php/extensions/non-debug-non-zts-xxx/xcache.so
--;; windows example:
--zend_extension_ts = c:/php/extensions/php_xcache.dll
--;; for newer PHP, _ts is removed, use the following line instead
--zend_extension = c:/php/extensions/php_xcache.dll
-+zend_extension = %%LOCALBASE%%/lib/php/%%PHP_EXT_DIR%%/xcache.so
-+;; for older and thread-safe PHP, _ts is needed
-+; zend_extension_ts = %%LOCALBASE%%/lib/php/%%PHP_EXT_DIR%%/xcache.so
+--- xcache.ini.orig 2012-10-10 14:05:11.000000000 +0200
++++ xcache.ini 2012-11-08 12:26:54.000000000 +0100
+@@ -1,13 +1,10 @@
+ ;; this is an example, it won't work unless properly configured into php.ini
+ [xcache-common]
+-;; non-Windows example:
+ extension = xcache.so
+-;; Windows example:
+-; extension = php_xcache.dll
[xcache.admin]
xcache.admin.enable_auth = On
diff --git a/www/xcache/pkg-plist b/www/xcache/pkg-plist
deleted file mode 100644
index 90ba29e92362..000000000000
--- a/www/xcache/pkg-plist
+++ /dev/null
@@ -1,35 +0,0 @@
-lib/php/%%PHP_EXT_DIR%%/xcache.so
-@dirrmtry lib/php/%%PHP_EXT_DIR%%
-%%EXAMPLESDIR%%/admin/common-en.lang.php
-%%EXAMPLESDIR%%/admin/common-zh-simplified-utf-8.lang.php
-%%EXAMPLESDIR%%/admin/common-zh-traditional-utf-8.lang.php
-%%EXAMPLESDIR%%/admin/common.php
-%%EXAMPLESDIR%%/admin/config.default.php
-%%EXAMPLESDIR%%/admin/config.example.php
-%%EXAMPLESDIR%%/admin/edit.php
-%%EXAMPLESDIR%%/admin/edit.tpl.php
-%%EXAMPLESDIR%%/admin/footer.tpl.php
-%%EXAMPLESDIR%%/admin/header.tpl.php
-%%EXAMPLESDIR%%/admin/help-en.lang.php
-%%EXAMPLESDIR%%/admin/help-zh-simplified-utf-8.lang.php
-%%EXAMPLESDIR%%/admin/help-zh-traditional-utf-8.lang.php
-%%EXAMPLESDIR%%/admin/help.php
-%%EXAMPLESDIR%%/admin/index.php
-%%EXAMPLESDIR%%/admin/mkpassword.php
-%%EXAMPLESDIR%%/admin/tablesort.js
-%%EXAMPLESDIR%%/admin/xcache.css
-%%EXAMPLESDIR%%/admin/xcache.php
-%%EXAMPLESDIR%%/admin/xcache.tpl.php
-%%COVERAGER%%%%EXAMPLESDIR%%/coverager/common-en.lang.php
-%%COVERAGER%%%%EXAMPLESDIR%%/coverager/common-zh-simplified-gb2312.lang.php
-%%COVERAGER%%%%EXAMPLESDIR%%/coverager/common-zh-simplified-utf-8.lang.php
-%%COVERAGER%%%%EXAMPLESDIR%%/coverager/common.php
-%%COVERAGER%%%%EXAMPLESDIR%%/coverager/config.php.example
-%%COVERAGER%%%%EXAMPLESDIR%%/coverager/coverager.css
-%%COVERAGER%%%%EXAMPLESDIR%%/coverager/coverager.php
-%%COVERAGER%%%%EXAMPLESDIR%%/coverager/coverager.tpl.php
-%%COVERAGER%%%%EXAMPLESDIR%%/coverager/index.php
-%%EXAMPLESDIR%%/xcache.ini
-@dirrm %%EXAMPLESDIR%%/admin
-%%COVERAGER%%@dirrm %%EXAMPLESDIR%%/coverager
-@dirrm %%EXAMPLESDIR%%