aboutsummaryrefslogtreecommitdiff
path: root/www/xcache
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-11-08 08:06:13 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-11-08 08:06:13 +0000
commitbdb588bb0f9c8b67dd37c483f513016b7fc4a956 (patch)
tree16bb7cbf19219a5ba42d760fb1edd268cbd4d8c9 /www/xcache
parent4aff09b21a3d765bf026b2eacd2481a7e3a2460e (diff)
downloadports-bdb588bb0f9c8b67dd37c483f513016b7fc4a956.tar.gz
ports-bdb588bb0f9c8b67dd37c483f513016b7fc4a956.zip
Notes
Diffstat (limited to 'www/xcache')
-rw-r--r--www/xcache/Makefile36
-rw-r--r--www/xcache/distinfo6
-rw-r--r--www/xcache/files/patch-xcache.ini35
-rw-r--r--www/xcache/pkg-plist11
4 files changed, 42 insertions, 46 deletions
diff --git a/www/xcache/Makefile b/www/xcache/Makefile
index 67085e3fb289..c91732968d0d 100644
--- a/www/xcache/Makefile
+++ b/www/xcache/Makefile
@@ -6,9 +6,11 @@
#
PORTNAME= xcache
-DISTVERSION= 1.0.2
+DISTVERSION= 1.2-beta2
CATEGORIES= www
-MASTER_SITES= http://210.51.190.228/pub/XCache/Releases/
+MASTER_SITES= http://210.51.190.228/pub/XCache/Releases/ \
+ http://210.51.190.228/pub/XCache/snapshots/
+DISTNAME= ${PORTNAME}-trunk-r272
MAINTAINER= ale@FreeBSD.org
COMMENT= A fast and stable php opcode cacher
@@ -25,6 +27,16 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
WRKSRC= ${WRKDIR}/${PORTNAME}
+ADMINFILES= common-en.lang.php common-zh-simplified-utf-8.lang.php \
+ common-zh-traditional-utf-8.lang.php common.php config.php.example \
+ help-en.lang.php help-zh-simplified-utf-8.lang.php \
+ help-zh-traditional-utf-8.lang.php help.php index.php \
+ tablesort.js xcache.css xcache.php xcache.tpl.php
+
+COVERAGERFILES= common-en.lang.php common-zh-simplified-gb2312.lang.php \
+ common-zh-simplified-utf-8.lang.php common.php config.php.example \
+ coverager.css coverager.php coverager.tpl.php index.php
+
.include <bsd.port.pre.mk>
.if defined(WITH_COVERAGER)
@@ -48,22 +60,14 @@ do-install:
post-install:
@${MKDIR} ${EXAMPLESDIR}/admin
- ${INSTALL_DATA} ${WRKSRC}/admin/config.php.example \
- ${WRKSRC}/admin/help.php \
- ${WRKSRC}/admin/index.php \
- ${WRKSRC}/admin/tablesort.js \
- ${WRKSRC}/admin/xcache.css \
- ${WRKSRC}/admin/xcache.php \
- ${WRKSRC}/admin/xcache.tpl.php \
- ${EXAMPLESDIR}/admin
+.for f in ${ADMINFILES}
+ ${INSTALL_DATA} ${WRKSRC}/admin/${f} ${EXAMPLESDIR}/admin
+.endfor
.if defined(WITH_COVERAGER)
@${MKDIR} ${EXAMPLESDIR}/coverager
- ${INSTALL_DATA} ${WRKSRC}/coverager/config.php.example \
- ${WRKSRC}/coverager/coverager.css \
- ${WRKSRC}/coverager/coverager.php \
- ${WRKSRC}/coverager/coverager.tpl.php \
- ${WRKSRC}/coverager/index.php \
- ${EXAMPLESDIR}/coverager
+.for f in ${COVERAGERFILES}
+ ${INSTALL_DATA} ${WRKSRC}/coverager/${f} ${EXAMPLESDIR}/coverager
+.endfor
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/www/xcache/distinfo b/www/xcache/distinfo
index 04be6b2add70..6f692e5cee04 100644
--- a/www/xcache/distinfo
+++ b/www/xcache/distinfo
@@ -1,3 +1,3 @@
-MD5 (xcache-1.0.2.tar.gz) = e28905b26ea4a588d16d260f893fc613
-SHA256 (xcache-1.0.2.tar.gz) = ed6bb6e4de7dde87202a9a2f41cadf0566fe9e79153145b2c237b1a6260802f2
-SIZE (xcache-1.0.2.tar.gz) = 71271
+MD5 (xcache-trunk-r272.tar.gz) = 6f1a9810e4ca4a2e044a2d14be683410
+SHA256 (xcache-trunk-r272.tar.gz) = 2bcf885b0a083d935a2f2b554a5615188f5fa627837a41b09423e41d3623cb22
+SIZE (xcache-trunk-r272.tar.gz) = 90607
diff --git a/www/xcache/files/patch-xcache.ini b/www/xcache/files/patch-xcache.ini
index 022445d9d233..8c0c3d74c361 100644
--- a/www/xcache/files/patch-xcache.ini
+++ b/www/xcache/files/patch-xcache.ini
@@ -1,6 +1,6 @@
---- xcache.ini.orig Sat Sep 16 04:58:10 2006
-+++ xcache.ini Wed Nov 1 13:58:43 2006
-@@ -1,19 +1,15 @@
+--- xcache.ini.orig Sun Oct 29 23:03:49 2006
++++ xcache.ini Wed Nov 8 08:49:51 2006
+@@ -1,16 +1,12 @@
[xcache-common]
-;; install as zend extension (recommended), normally "$extension_dir/xcache.so"
-zend_extension = /usr/local/lib/php/extensions/non-debug-non-zts-xxx/xcache.so
@@ -12,42 +12,23 @@
-;; or win32:
-; extension = php_xcache.dll
+;; install as zend extension (recommended, but not working yet)
-+;zend_extension = %%LOCALBASE%%/lib/php/%%PHP_EXT_DIR%%/xcache.so
-+;zend_extension_ts = %%LOCALBASE%%/lib/php/%%PHP_EXT_DIR%%/xcache.so
++; zend_extension = %%LOCALBASE%%/lib/php/%%PHP_EXT_DIR%%/xcache.so
++; zend_extension_ts = %%LOCALBASE%%/lib/php/%%PHP_EXT_DIR%%/xcache.so
+;; or install as extension
+extension = xcache.so
- ; required for >=php5.1 if you turn XCache on
- auto_globals_jit = Off
-
[xcache.admin]
-xcache.admin.user = "mOo"
+xcache.admin.user = "admin"
; xcache.admin.pass = md5($your_password)
xcache.admin.pass = ""
-@@ -21,8 +17,8 @@
- ; ini only settings, all the values here is default unless explained
+@@ -21,7 +17,7 @@
+ xcache.shm_scheme = "mmap"
; to disable: xcache.size=0
; to enable : xcache.size=64M etc (any size > 0) and your system mmap allows
-xcache.size = 0M
--; uncomment and set to cpu count (cat /proc/cpuinfo |grep -c processor)
+xcache.size = 64M
-+; uncomment and set to cpu count
+ ; set to cpu count (cat /proc/cpuinfo |grep -c processor)
xcache.count = 1
; just a hash hints, you can always store count(items) > slots
- xcache.slots = 8K
-@@ -35,12 +31,10 @@
- xcache.test = Off
- ; N/A for /dev/zero
- xcache.readonly_protection = Off
--; for win32, xcache.mmap_path=anonymous map name, not file path
- ; uncomment and change to "/tmp/xcache" for readonly protection
- ; 2 group of php won't share the same /tmp/xcache
--; for other OS, it's a file NOT directory
-+; it's a file NOT directory
- xcache.mmap_path = "/dev/zero"
--
-
- ; leave it blank(disabled) or "/tmp/phpcore/"
- ; make sure it's writable by php (without checking open_basedir)
diff --git a/www/xcache/pkg-plist b/www/xcache/pkg-plist
index 273d03e5de2c..781d1584a9b9 100644
--- a/www/xcache/pkg-plist
+++ b/www/xcache/pkg-plist
@@ -1,12 +1,23 @@
lib/php/%%PHP_EXT_DIR%%/xcache.so
@dirrmtry lib/php/%%PHP_EXT_DIR%%
+%%EXAMPLESDIR%%/admin/common-en.lang.php
+%%EXAMPLESDIR%%/admin/common-zh-simplified-utf-8.lang.php
+%%EXAMPLESDIR%%/admin/common-zh-traditional-utf-8.lang.php
+%%EXAMPLESDIR%%/admin/common.php
%%EXAMPLESDIR%%/admin/config.php.example
+%%EXAMPLESDIR%%/admin/help-en.lang.php
+%%EXAMPLESDIR%%/admin/help-zh-simplified-utf-8.lang.php
+%%EXAMPLESDIR%%/admin/help-zh-traditional-utf-8.lang.php
%%EXAMPLESDIR%%/admin/help.php
%%EXAMPLESDIR%%/admin/index.php
%%EXAMPLESDIR%%/admin/tablesort.js
%%EXAMPLESDIR%%/admin/xcache.css
%%EXAMPLESDIR%%/admin/xcache.php
%%EXAMPLESDIR%%/admin/xcache.tpl.php
+%%COVERAGER%%%%EXAMPLESDIR%%/coverager/common-en.lang.php
+%%COVERAGER%%%%EXAMPLESDIR%%/coverager/common-zh-simplified-gb2312.lang.php
+%%COVERAGER%%%%EXAMPLESDIR%%/coverager/common-zh-simplified-utf-8.lang.php
+%%COVERAGER%%%%EXAMPLESDIR%%/coverager/common.php
%%COVERAGER%%%%EXAMPLESDIR%%/coverager/config.php.example
%%COVERAGER%%%%EXAMPLESDIR%%/coverager/coverager.css
%%COVERAGER%%%%EXAMPLESDIR%%/coverager/coverager.php