aboutsummaryrefslogtreecommitdiff
path: root/www/xcache
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2012-05-02 09:52:47 +0000
committerAlex Dupre <ale@FreeBSD.org>2012-05-02 09:52:47 +0000
commit28b9e5d129ae450dc8fed7c0b86648cacfaf37f8 (patch)
tree967a269c3f58256fb2821cd4bef39432ab2d1cd9 /www/xcache
parent670adacef4a61179965358b8588b62bdb5e87b77 (diff)
downloadports-28b9e5d129ae450dc8fed7c0b86648cacfaf37f8.tar.gz
ports-28b9e5d129ae450dc8fed7c0b86648cacfaf37f8.zip
Notes
Diffstat (limited to 'www/xcache')
-rw-r--r--www/xcache/Makefile9
-rw-r--r--www/xcache/distinfo4
-rw-r--r--www/xcache/files/patch-xcache.ini15
3 files changed, 16 insertions, 12 deletions
diff --git a/www/xcache/Makefile b/www/xcache/Makefile
index b391d21fdb97..61e70e39ee53 100644
--- a/www/xcache/Makefile
+++ b/www/xcache/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xcache
-DISTVERSION= 1.3.2
+DISTVERSION= 2.0.0
CATEGORIES= www
MASTER_SITES= http://xcache.lighttpd.net/pub/Releases/${DISTVERSION}/
@@ -19,7 +19,8 @@ USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-xcache=shared
-OPTIONS= COVERAGER "Enable code coverage dumper" off
+OPTIONS= CONSTANT "Enable handling of compile time constants" off \
+ COVERAGER "Enable code coverage dumper" off
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -37,6 +38,10 @@ COVERAGERFILES= common-en.lang.php common-zh-simplified-gb2312.lang.php \
.include <bsd.port.pre.mk>
+.if defined(WITH_CONSTANT)
+CONFIGURE_ARGS+=--enable-xcache-constant
+.endif
+
.if defined(WITH_COVERAGER)
CONFIGURE_ARGS+=--enable-xcache-coverager
PLIST_SUB+= COVERAGER=""
diff --git a/www/xcache/distinfo b/www/xcache/distinfo
index 0a102cc29977..b14310836f0e 100644
--- a/www/xcache/distinfo
+++ b/www/xcache/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xcache-1.3.2.tar.bz2) = 65cb064eadce848e54f18fe7172165651d3d60c5f65a9fe446b6b8fddcabda1c
-SIZE (xcache-1.3.2.tar.bz2) = 95322
+SHA256 (xcache-2.0.0.tar.bz2) = ca26b0772d8b88223f281f5099a3b7d9f4b6597a87ae857301271c1fd5a3f64a
+SIZE (xcache-2.0.0.tar.bz2) = 108614
diff --git a/www/xcache/files/patch-xcache.ini b/www/xcache/files/patch-xcache.ini
index 7e2f78bb31e4..4e38fc4a6380 100644
--- a/www/xcache/files/patch-xcache.ini
+++ b/www/xcache/files/patch-xcache.ini
@@ -1,5 +1,5 @@
---- xcache.ini.orig Sun Oct 29 23:03:49 2006
-+++ xcache.ini Wed Nov 8 08:49:51 2006
+--- xcache.ini.orig 2012-04-12 12:05:56.000000000 +0200
++++ xcache.ini 2012-04-12 12:07:57.000000000 +0200
@@ -1,17 +1,13 @@
[xcache-common]
-;; install as zend extension (recommended), normally "$extension_dir/xcache.so"
@@ -8,14 +8,13 @@
-;; For windows users, replace xcache.so with php_xcache.dll
-zend_extension_ts = c:/php/extensions/php_xcache.dll
-;; or install as extension, make sure your extension_dir setting is correct
--; extension = xcache.so
++;; install as zend extension (recommended)
++zend_extension = %%LOCALBASE%%/lib/php/%%PHP_EXT_DIR%%/xcache.so
++zend_extension_ts = %%LOCALBASE%%/lib/php/%%PHP_EXT_DIR%%/xcache.so
++;; or install as extension
+ ; extension = xcache.so
-;; or win32:
-; extension = php_xcache.dll
-+;; install as zend extension (recommended, but not working yet)
-+; zend_extension = %%LOCALBASE%%/lib/php/%%PHP_EXT_DIR%%/xcache.so
-+; zend_extension_ts = %%LOCALBASE%%/lib/php/%%PHP_EXT_DIR%%/xcache.so
-+;; or install as extension
-+extension = xcache.so
[xcache.admin]
xcache.admin.enable_auth = On