aboutsummaryrefslogtreecommitdiff
path: root/www/xombrero
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2012-08-20 15:24:13 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2012-08-20 15:24:13 +0000
commit121bb624245b23c095308883b1409c93912e858d (patch)
tree167bcfe61aea99c2016c3d0e31b0e1b0fbb3d8d7 /www/xombrero
parentc848e5a9f61e25b817fd9cb4b56e70a8ecd4ac92 (diff)
downloadports-121bb624245b23c095308883b1409c93912e858d.tar.gz
ports-121bb624245b23c095308883b1409c93912e858d.zip
Notes
Diffstat (limited to 'www/xombrero')
-rw-r--r--www/xombrero/Makefile74
-rw-r--r--www/xombrero/distinfo2
-rw-r--r--www/xombrero/files/patch-freebsd__Makefile13
-rw-r--r--www/xombrero/files/patch-xombrero.c11
-rw-r--r--www/xombrero/files/xombrero.in22
-rw-r--r--www/xombrero/pkg-descr5
-rw-r--r--www/xombrero/pkg-plist24
7 files changed, 151 insertions, 0 deletions
diff --git a/www/xombrero/Makefile b/www/xombrero/Makefile
new file mode 100644
index 000000000000..eaa725074494
--- /dev/null
+++ b/www/xombrero/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: xxxterm
+# Date created: 2011.01.15
+# Whom: Aldis Berjoza <aldis@bsdroot.lv>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xombrero
+PORTVERSION= 1.2.2
+CATEGORIES= www
+MASTER_SITES= https://opensource.conformal.com/snapshots/xombrero/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= zeising@FreeBSD.org
+COMMENT= Minimalists vi-like web browser based on webkit and GTK+
+
+LICENCE= ISCL
+
+LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
+ soup-2.4:${PORTSDIR}/devel/libsoup \
+ webkitgtk-1:${PORTSDIR}/www/webkit-gtk2
+
+USE_PKGCONFIG= build
+USE_PERL5_BUILD=yes
+USE_GNOME= gtk20
+INSTALLS_ICONS= yes
+
+MAKE_ENV= GTK_VERSION="gtk2" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+MAN1= xombrero.1
+PORTEXAMPLES= favorites playflash.sh xombrero.conf
+
+BUILD_WRKSRC= ${WRKSRC}/freebsd
+
+OPTIONS_DEFINE= EXAMPLES
+
+SUB_FILES= xombrero
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800041
+BROKEN= does not build due to missing arc4random_buf in libc
+.endif
+
+post-patch:
+ @cd ${WRKSRC}; ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ -e 's|# ssl_ca_file|ssl_ca_file|' \
+ -e 's|/etc/ssl/cert.pem|${LOCALBASE}/share/certs/ca-root-nss.crt|' \
+ unix.c xombrero.conf
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/xombrero ${PREFIX}/bin/xombrero
+ ${INSTALL_PROGRAM} ${WRKSRC}/freebsd/xombrero ${PREFIX}/bin/xombrero-bin
+ ${INSTALL_MAN} ${WRKSRC}/xombrero.1 ${MANPREFIX}/man/man1
+.for i in 16 32 48 64 128
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/${i}x${i}/apps
+ ${INSTALL_DATA} ${WRKSRC}/xombreroicon${i}.png ${PREFIX}/share/icons/hicolor/${i}x${i}/apps
+.endfor
+ ${MKDIR} ${DATADIR}
+.for i in style.css tld-rules
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DATADIR}
+.endfor
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/xombrero.desktop ${PREFIX}/share/applications
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}
+.for i in favorites xombrero.conf
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${EXAMPLESDIR}
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/playflash.sh ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/xombrero/distinfo b/www/xombrero/distinfo
new file mode 100644
index 000000000000..f038f19f2965
--- /dev/null
+++ b/www/xombrero/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xombrero-1.2.2.tgz) = 7cd2d1174239b5e3f897473ca69efc1fb303491d6ed60bf068263adfb76b164a
+SIZE (xombrero-1.2.2.tgz) = 242038
diff --git a/www/xombrero/files/patch-freebsd__Makefile b/www/xombrero/files/patch-freebsd__Makefile
new file mode 100644
index 000000000000..fbe533f600f9
--- /dev/null
+++ b/www/xombrero/files/patch-freebsd__Makefile
@@ -0,0 +1,13 @@
+--- ./freebsd/Makefile.orig 2012-07-25 17:37:55.000000000 -0400
++++ ./freebsd/Makefile 2012-07-31 08:13:02.000000000 -0400
+@@ -9,8 +9,8 @@
+ LDADD= -lutil -lgcrypt
+ GTK_CFLAGS!= pkg-config --cflags $(LIBS)
+ GTK_LDFLAGS!= pkg-config --libs $(LIBS)
+-CFLAGS+= $(GTK_CFLAGS) -O2 -Wall -pthread
+-LDFLAGS+= $(GTK_LDFLAGS) -pthread
++CFLAGS+= $(GTK_CFLAGS) -Wall -D_GCRYPT_IN_LIBGCRYPT=1 -I.. ${PTHREAD_CFLAGS}
++LDFLAGS+= $(GTK_LDFLAGS) ${PTHREAD_LIBS}
+
+ PREFIX?= /usr/local
+ BINDIR?= $(PREFIX)/bin
diff --git a/www/xombrero/files/patch-xombrero.c b/www/xombrero/files/patch-xombrero.c
new file mode 100644
index 000000000000..70e082fc25d1
--- /dev/null
+++ b/www/xombrero/files/patch-xombrero.c
@@ -0,0 +1,11 @@
+--- ./xombrero.c.orig 2012-07-25 17:37:55.000000000 -0400
++++ ./xombrero.c 2012-07-31 08:13:02.000000000 -0400
+@@ -1423,7 +1423,7 @@
+ {
+ struct passwd *pwd;
+ int i;
+- char user[LOGIN_NAME_MAX];
++ char user[sysconf(_SC_LOGIN_NAME_MAX)];
+ const char *sc = s;
+
+ if (path == NULL || s == NULL)
diff --git a/www/xombrero/files/xombrero.in b/www/xombrero/files/xombrero.in
new file mode 100644
index 000000000000..8aa73a708da0
--- /dev/null
+++ b/www/xombrero/files/xombrero.in
@@ -0,0 +1,22 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# A wrapper script for xombrero
+# Created by HU Dong <itechbear@gmail.com>
+
+if [ ! -d "~/.xombrero" ]; then
+ mkdir -p -m 700 ~/.xombrero
+fi
+
+if [ ! -f "~/.xombrero.conf" ]; then
+ cp %%EXAMPLESDIR%%/xombrero.conf ~/.xombrero.conf
+ chmod +w ~/.xombrero.conf
+fi
+
+if [ ! -f "~/.xombrero/playflash.sh" ]; then
+ cp %%EXAMPLESDIR%%/playflash.sh ~/.xombrero/playflash.sh
+ chmod +x ~/.xombrero/playflash.sh
+fi
+
+exec %%PREFIX%%/bin/xombrero-bin
diff --git a/www/xombrero/pkg-descr b/www/xombrero/pkg-descr
new file mode 100644
index 000000000000..3edd3d180f9a
--- /dev/null
+++ b/www/xombrero/pkg-descr
@@ -0,0 +1,5 @@
+xombrero, previously known as xxxterm, is a minimalists web browser. It strives
+to be vi-like for heavy keyboard users while maintaining traditional web browser
+ behaviour. It is ISC licensed. It is based on webkit using GTK+.
+
+WWW: https://opensource.conformal.com/wiki/xombrero
diff --git a/www/xombrero/pkg-plist b/www/xombrero/pkg-plist
new file mode 100644
index 000000000000..5d9289e1b5d9
--- /dev/null
+++ b/www/xombrero/pkg-plist
@@ -0,0 +1,24 @@
+bin/xombrero
+bin/xombrero-bin
+share/applications/xombrero.desktop
+share/icons/hicolor/128x128/apps/xombreroicon128.png
+share/icons/hicolor/16x16/apps/xombreroicon16.png
+share/icons/hicolor/32x32/apps/xombreroicon32.png
+share/icons/hicolor/48x48/apps/xombreroicon48.png
+share/icons/hicolor/64x64/apps/xombreroicon64.png
+%%DATADIR%%/style.css
+%%DATADIR%%/tld-rules
+@dirrm %%DATADIR%%
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications