aboutsummaryrefslogtreecommitdiff
path: root/www/xpi-adblock/Makefile.xpi
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-03-30 07:23:11 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-03-30 07:23:11 +0000
commit382d5f0ca22307edf57dda075105bfd06fc594ee (patch)
tree72d1cec929bed41d2664c6d2da4a400fcdae7d96 /www/xpi-adblock/Makefile.xpi
parentb6e0ec8b179446626aeb24393c2153f6ef7f9b6f (diff)
Notes
Diffstat (limited to 'www/xpi-adblock/Makefile.xpi')
-rw-r--r--www/xpi-adblock/Makefile.xpi7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/xpi-adblock/Makefile.xpi b/www/xpi-adblock/Makefile.xpi
index 60b32995ee1c..232110d51c41 100644
--- a/www/xpi-adblock/Makefile.xpi
+++ b/www/xpi-adblock/Makefile.xpi
@@ -9,6 +9,7 @@
#
# XPI_ID - Extension id, might be in {12345-...} or dev@org format
+# XPI_NUM - Extension number, as in addons.mozilla.org URL
# XPI_FILES - List of files in xpi archive. This is used to produce
# PLIST_FILES. XPI_FILES can be generated by xpi-gen, but be
# sure to put chrome.manifest in ${FILESDIR} before that if you
@@ -67,6 +68,9 @@
.ifndef MASTER_SITES
MASTER_SITES?= MOZILLA_EXTENDED
+.ifdef XPI_NUM
+MASTER_SITE_SUBDIR?= addons/${XPI_NUM}
+.endif
MASTER_SITE_SUBDIR?= extensions/${XPI_DISTNAME}
.endif
PKGNAMEPREFIX?= xpi-
@@ -81,8 +85,11 @@ EXTRACT_AFTER_ARGS= -d ${WRKSRC}
XPI_DISTNAME?= ${PORTNAME}
XPI_APPS_ALL_WC= *firefox* *thunderbird* *flock*
+# *nvu* *sunbird*
XPI_APPS_ALL= firefox firefox-devel linux-firefox linux-firefox-devel \
thunderbird linux-thunderbird flock linux-flock
+# nvu linux-nvu sunbird linux-sunbird
+# Other apps: mango
# === Let's process WITH_XPI into WITH_XPI_APPS
WITH_XPI_TUPLES= ${WITH_XPI:M*?\:?*}