aboutsummaryrefslogtreecommitdiff
path: root/www/xpi-adblock
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-04-16 16:24:07 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-04-16 16:24:07 +0000
commitae65264208a3d91d01ab92279bbc76499f242efc (patch)
tree36171daa4f4b10d386320f5861b47dba17608912 /www/xpi-adblock
parent5f34a1b0f22aa94c6552d240a68518fa65299a72 (diff)
downloadports-ae65264208a3d91d01ab92279bbc76499f242efc.tar.gz
ports-ae65264208a3d91d01ab92279bbc76499f242efc.zip
Notes
Diffstat (limited to 'www/xpi-adblock')
-rw-r--r--www/xpi-adblock/Makefile23
-rw-r--r--www/xpi-adblock/Makefile.xpi81
-rw-r--r--www/xpi-adblock/distinfo3
-rw-r--r--www/xpi-adblock/pkg-descr7
4 files changed, 114 insertions, 0 deletions
diff --git a/www/xpi-adblock/Makefile b/www/xpi-adblock/Makefile
new file mode 100644
index 000000000000..41d152dfedce
--- /dev/null
+++ b/www/xpi-adblock/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: xpi-adblock
+# Date created: 28 March 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= adblock
+PORTVERSION= 0.5.3.042
+DISTVERSIONSUFFIX= -fx+fl+mz+ns
+CATEGORIES= www
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= A content filtering extension
+
+XPI_ID= {34274bf4-1d97-a289-e984-17e546307e4f}
+XPI_FILES= chrome/adblock.jar chrome.manifest components/.autoreg \
+ components/nsAdblock.js defaults/preferences/adblock.js \
+ install.js install.rdf license.txt
+XPI_DIRS= chrome components defaults/preferences defaults
+
+.include "../xpi-adblock/Makefile.xpi"
+.include <bsd.port.mk>
diff --git a/www/xpi-adblock/Makefile.xpi b/www/xpi-adblock/Makefile.xpi
new file mode 100644
index 000000000000..dcd7c5af42b2
--- /dev/null
+++ b/www/xpi-adblock/Makefile.xpi
@@ -0,0 +1,81 @@
+# New ports collection makefile for: xpi infrastructure
+# Date created: 28 March 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+# This Makefile is an alpha-version of a new xpi infrastructure.
+# It currently supports Gecko 1.8+ (Firefox 1.5+). Support for
+# Gecko 1.7x (and Seamonkey 1.0) may be merged later from
+# Thierry Thomas works (but I doubt it is worthwhile).
+#
+# A new xpi will require a PORTNAME, PORTVERSION, DISTVERSION-
+# SUFFIX and CATEGORIES. In case it is not published on the
+# mozilla.org sites, MASTER_SITES can be redefined. XPI_* vars
+# will also need to be defined manually, which helps keep the
+# infrastructure simpler.
+#
+# PKGNAMESUFFIX will probably follow the mozilla.org pattern
+# (fx for firefox, mz for mozilla) extended by abbreviations of
+# linux and devel versions, and some other things.
+#
+# An xpi compatibility with different browsers will be determined
+# from DISTVERSIONSUFFIX or manually by maintainer.
+#
+# Browsers that user want an xpi installed in can be defined by
+# WITH_XPI_BROWSERS. Employing symlinks or hardlinks may be
+# considered later, but it will complicate matters.
+#
+# In case an xpi does not have chrome.manifest, it should be
+# generated manually by a maintainer and placed in files, where
+# it will be noticed.
+
+MASTER_SITES?= ${MASTER_SITE_MOZILLA}
+MASTER_SITE_SUBDIR?= extensions/${PORTNAME}
+PKGNAMEPREFIX?= xpi-
+PKGNAMESUFFIX?= -fx
+EXTRACT_SUFX?= .xpi
+DIST_SUBDIR?= xpi
+
+USE_X_PREFIX= yes
+NO_BUILD= yes
+USE_ZIP= yes
+EXTRACT_AFTER_ARGS= -d ${WRKSRC}
+
+WITH_XPI_BROWSERS?= firefox # Try adding linux-firefox
+
+XPI_DIRS?= chrome components defaults/preferences defaults
+
+.for _BROWSER in ${WITH_XPI_BROWSERS}
+RUN_DEPENDS+= ${_BROWSER}:${PORTSDIR}/www/${_BROWSER}
+TARGET_DIRS+= lib/${_BROWSER}/extensions/${XPI_ID}
+.endfor
+
+.for _TD in ${TARGET_DIRS}
+PLIST_FILES+= ${XPI_FILES:S.^.${_TD}/.}
+PLIST_DIRS+= ${XPI_DIRS:S.^.${_TD}/.}
+PLIST_DIRS+= ${_TD}
+.endfor
+
+do-install:
+.for _TD in ${TARGET_DIRS}
+ @${INSTALL} -d ${PREFIX}/${_TD}
+ @${CP} -Rp ${WRKSRC}/ ${PREFIX}/${_TD}/
+ @if [ -d ${FILESDIR} -a -f ${FILESDIR}/chrome.manifest ] ; \
+ then ${CP} -p ${FILESDIR}/chrome.manifest ${PREFIX}/${_TD}/ ; fi
+.endfor
+
+# Maintainer section
+xpi-gen: extract
+ @${ECHO_CMD} -n 'XPI_ID='
+ @${GREP} -m1 em:id ${WRKSRC}/install.rdf | ${CUT} -f2- -d\> | \
+ ${CUT} -f1 -d\< | ${CUT} -f2 -d\"
+ @${ECHO_CMD} -n 'XPI_FILES='
+ @cd ${WRKSRC} && ${FIND} -s . -not -type d | cut -f2- -d/ | ${TR} '\n' ' '
+ @if [ -d ${FILESDIR} -a -f ${FILESDIR}/chrome.manifest ] ; \
+ then ${ECHO_CMD} chrome.manifest ; fi
+ @${ECHO_CMD}
+ @${ECHO_CMD} -n 'XPI_DIRS='
+ @cd ${WRKSRC} && ${FIND} -ds . -not -name . -type d | cut -f2- -d/ | ${TR} '\n' ' '
+ @${ECHO_CMD}
diff --git a/www/xpi-adblock/distinfo b/www/xpi-adblock/distinfo
new file mode 100644
index 000000000000..0bab0b59c6dc
--- /dev/null
+++ b/www/xpi-adblock/distinfo
@@ -0,0 +1,3 @@
+MD5 (xpi/adblock-0.5.3.042-fx+fl+mz+ns.xpi) = 6dd2d4bdec0ed4591f3f32af2677a4e2
+SHA256 (xpi/adblock-0.5.3.042-fx+fl+mz+ns.xpi) = c40a1919793ddf72a2a81a84afe512f5530acb802fd8cc9a360cc2e50d6a0455
+SIZE (xpi/adblock-0.5.3.042-fx+fl+mz+ns.xpi) = 79681
diff --git a/www/xpi-adblock/pkg-descr b/www/xpi-adblock/pkg-descr
new file mode 100644
index 000000000000..069779f951b9
--- /dev/null
+++ b/www/xpi-adblock/pkg-descr
@@ -0,0 +1,7 @@
+Adblock is a content filtering plug-in for the Mozilla and Firefox browsers.
+It is both more robust and more precise than the built-in image blocker.
+
+Adblock allows the user to specify filters, which remove unwanted content based
+on the source-address.
+
+WWW: http://adblock.mozdev.org/