aboutsummaryrefslogtreecommitdiff
path: root/www/xpi-clear_cache_button
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2011-09-16 22:04:29 +0000
committerFlorian Smeets <flo@FreeBSD.org>2011-09-16 22:04:29 +0000
commitfc000d8b9c77ff243df0788833b52aec4136f68d (patch)
tree01800164ed06bc464b44407b39515c253f2c2e51 /www/xpi-clear_cache_button
parentd956cc60c8382de665778b67571d944b0dc35172 (diff)
add xpi-clear_cache_button firefox addon
Adds a clear cache toolbar button. After installing the extension, find the clear cache button in the toolbar customization panel. WWW: http://chrisholtz.com/ PR: ports/160738 Submitted by: Barbara <barbara.xxx1975@libero.it>
Notes
Notes: svn path=/head/; revision=281868
Diffstat (limited to 'www/xpi-clear_cache_button')
-rw-r--r--www/xpi-clear_cache_button/Makefile43
-rw-r--r--www/xpi-clear_cache_button/distinfo2
-rw-r--r--www/xpi-clear_cache_button/files/pkg-message.in11
-rw-r--r--www/xpi-clear_cache_button/pkg-descr4
4 files changed, 60 insertions, 0 deletions
diff --git a/www/xpi-clear_cache_button/Makefile b/www/xpi-clear_cache_button/Makefile
new file mode 100644
index 000000000000..c34dd9c8bd15
--- /dev/null
+++ b/www/xpi-clear_cache_button/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: xpi-clear_cache_button
+# Date created: 14 September 2011
+# Whom: Barbara <barbara.xxx1975@libero.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clear_cache_button
+PORTVERSION= 0.9f
+DISTVERSIONSUFFIX= -fx
+CATEGORIES= www
+
+MAINTAINER= barbara.xxx1975@libero.it
+COMMENT= Adds a button to the toolbar that clears the browser cache
+
+SUB_FILES= pkg-message
+
+XPI_ID= {563e4790-7e70-11da-a72b-0800200c9a66}
+XPI_NUM= 1801
+XPI_FILES= chrome/content/options.js \
+ chrome/content/options.xul \
+ chrome/content/overlay.js \
+ chrome/content/overlay.xul \
+ chrome/locale/en-US/clearcache.properties \
+ chrome/locale/en-US/overlay.dtd \
+ chrome/skin/classic/logo_16.png \
+ chrome/skin/classic/logo_24.png \
+ chrome/skin/classic/logo_32.png \
+ chrome/skin/classic/overlay.css \
+ chrome.manifest \
+ install.rdf
+
+XPI_DIRS= chrome/skin/classic chrome/skin \
+ chrome/locale/en-US chrome/locale \
+ chrome/content \
+ chrome
+
+.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
+
+post-install:
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/www/xpi-clear_cache_button/distinfo b/www/xpi-clear_cache_button/distinfo
new file mode 100644
index 000000000000..cb4038620a2a
--- /dev/null
+++ b/www/xpi-clear_cache_button/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xpi/clear_cache_button-0.9f-fx.xpi) = 02c5908354a3380aa580da9188f0373d4f9173c89e8790044828e60077708b6e
+SIZE (xpi/clear_cache_button-0.9f-fx.xpi) = 10707
diff --git a/www/xpi-clear_cache_button/files/pkg-message.in b/www/xpi-clear_cache_button/files/pkg-message.in
new file mode 100644
index 000000000000..929bc866314e
--- /dev/null
+++ b/www/xpi-clear_cache_button/files/pkg-message.in
@@ -0,0 +1,11 @@
+==============================================================================
+
+Clear Cache Button has been installed.
+
+In order to get the notification working on GNOME (*),
+you have to manually install deskutils/notification-daemon
+and have %%PREFIX%%/libexec/notification-daemon started.
+
+(*) feedback appreciated for different WM/DE
+
+==============================================================================
diff --git a/www/xpi-clear_cache_button/pkg-descr b/www/xpi-clear_cache_button/pkg-descr
new file mode 100644
index 000000000000..ca550f0d58b2
--- /dev/null
+++ b/www/xpi-clear_cache_button/pkg-descr
@@ -0,0 +1,4 @@
+Adds a clear cache toolbar button. After installing the extension, find the
+clear cache button in the toolbar customization panel.
+
+WWW: http://chrisholtz.com/