aboutsummaryrefslogtreecommitdiff
path: root/www/xpi-forecastfox/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-20 16:18:23 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-20 16:18:23 +0000
commitc2c9236c65d2b1fdac697adbc93528b4fabd21a1 (patch)
tree4630397c820f26422be2ae94ddf640e66eeffa47 /www/xpi-forecastfox/Makefile
parenteccc0b6ddcddf011ecedae6e3816b95494e971cc (diff)
Notes
Diffstat (limited to 'www/xpi-forecastfox/Makefile')
-rw-r--r--www/xpi-forecastfox/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/www/xpi-forecastfox/Makefile b/www/xpi-forecastfox/Makefile
new file mode 100644
index 000000000000..a344975cd68e
--- /dev/null
+++ b/www/xpi-forecastfox/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: forecastfox
+# Date created: 2006-05-15
+# Whom: Simon Olofsson <simon@olofsson.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= forecastfox
+PORTVERSION= 0.9.0.2
+DISTVERSIONSUFFIX= -fx+fl+mz+ns+zm
+CATEGORIES= www
+
+MAINTAINER= simon@olofsson.de
+COMMENT= Get international weather forecasts and display it
+
+XPI_ID= {0538E3E3-7E9B-4d49-8831-A227C80A7AD3}
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|install = this._app.clone();|install = app.clone();|g' \
+ ${WRKSRC}/components/ffDisk.js
+ @${RM} -f ${WRKSRC}/components/ffDisk.js.bak
+
+.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
+.include <bsd.port.mk>