aboutsummaryrefslogtreecommitdiff
path: root/www/xpi-jv/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2009-04-26 07:15:27 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2009-04-26 07:15:27 +0000
commit55dd7fa6146f268f879b1c8b1b0d13d8b9015b11 (patch)
tree3308b7498eedb44be9a56b536d1d0d04240711a4 /www/xpi-jv/Makefile
parent9b4b43121964a6df346d0c07c09406e90a61dd91 (diff)
downloadports-55dd7fa6146f268f879b1c8b1b0d13d8b9015b11.tar.gz
ports-55dd7fa6146f268f879b1c8b1b0d13d8b9015b11.zip
Notes
Diffstat (limited to 'www/xpi-jv/Makefile')
-rw-r--r--www/xpi-jv/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/www/xpi-jv/Makefile b/www/xpi-jv/Makefile
new file mode 100644
index 000000000000..cddbc3458bc7
--- /dev/null
+++ b/www/xpi-jv/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: xpi-jv
+# Date created: 2009-04-26
+# Whom: Norikatsu Shigemura <nork@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jv
+PORTVERSION= 0.50
+DISTVERSIONSUFFIX= -fx
+CATEGORIES= www
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= A lightweight vim-like editor for textareas
+
+XPI_NUM= 8529
+XPI_ID= jv@eric.uhrhane
+XPI_FILES= chrome.manifest chrome/jv.jar \
+ defaults/preferences/prefs.js \
+ install.rdf \
+ jv@eric.uhrhane/chrome.manifest \
+ jv@eric.uhrhane/content/about.js \
+ jv@eric.uhrhane/content/about.xul \
+ jv@eric.uhrhane/content/jv.js \
+ jv@eric.uhrhane/content/overlay.js \
+ jv@eric.uhrhane/content/overlay.xul \
+ jv@eric.uhrhane/content/queue.js \
+ jv@eric.uhrhane/content/settings.js \
+ jv@eric.uhrhane/content/settings.xul \
+ jv@eric.uhrhane/content/sharedsettings.js \
+ jv@eric.uhrhane/content/util.js \
+ jv@eric.uhrhane/defaults/preferences/prefs.js \
+ jv@eric.uhrhane/install.rdf \
+ jv@eric.uhrhane/locale/en-US/about.dtd \
+ jv@eric.uhrhane/locale/en-US/overlay.dtd \
+ jv@eric.uhrhane/locale/en-US/settings.dtd \
+ jv@eric.uhrhane/skin/about.css \
+ jv@eric.uhrhane/skin/about.png \
+ jv@eric.uhrhane/skin/overlay.css \
+ jv@eric.uhrhane/skin/settings.css \
+ jv@eric.uhrhane/skin/statusbar-active.png \
+ jv@eric.uhrhane/skin/statusbar-inactive.png \
+ jv@eric.uhrhane/skin/statusbar-locally-inactive.png \
+ jv@eric.uhrhane/skin/statusbar-other.png
+XPI_DIRS= chrome \
+ defaults/preferences defaults \
+ jv@eric.uhrhane/content \
+ jv@eric.uhrhane/defaults/preferences \
+ jv@eric.uhrhane/defaults \
+ jv@eric.uhrhane/locale/en-US \
+ jv@eric.uhrhane/locale \
+ jv@eric.uhrhane/skin \
+ jv@eric.uhrhane
+
+post-extract:
+ @${RM} ${WRKSRC}/jv@eric.uhrhane/.install.rdf.swp
+
+.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
+.include <bsd.port.mk>