aboutsummaryrefslogtreecommitdiff
path: root/www/xshttpd-devel
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2007-06-14 17:34:23 +0000
committerJohan van Selst <johans@FreeBSD.org>2007-06-14 17:34:23 +0000
commit7419f725a1c8d20d4595fade4f73c7e573eb675a (patch)
tree560790d5c1d0179b7cf0859436f563e5910df3ea /www/xshttpd-devel
parent1aca7c370c93cba2b28dd9105009755cd9de42b6 (diff)
downloadports-7419f725a1c8d20d4595fade4f73c7e573eb675a.tar.gz
ports-7419f725a1c8d20d4595fade4f73c7e573eb675a.zip
Notes
Diffstat (limited to 'www/xshttpd-devel')
-rw-r--r--www/xshttpd-devel/Makefile18
-rw-r--r--www/xshttpd-devel/distinfo6
-rw-r--r--www/xshttpd-devel/pkg-plist41
3 files changed, 35 insertions, 30 deletions
diff --git a/www/xshttpd-devel/Makefile b/www/xshttpd-devel/Makefile
index a51368827aac..7b560238f537 100644
--- a/www/xshttpd-devel/Makefile
+++ b/www/xshttpd-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xshttpd
-DISTVERSION= 3.5b07
+DISTVERSION= 3.5b10
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.stack.nl/pub/xs-httpd/release/ \
ftp://mud.stack.nl/pub/xs-httpd/release/
@@ -16,13 +16,15 @@ DISTNAME= ${PORTNAME}-${DISTVERSION:S/.//}
MAINTAINER= johans@stack.nl
COMMENT= A webserver with CGI as own user and SSL suport
-RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support
+RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support \
+ ppmtogif:${PORTSDIR}/graphics/netpbm
-CONFLICTS+= apache-[0-9]* xshttpd-[0-9]*
+CONFLICTS+= xshttpd-[0-9]*
MAN1= clearxs.1 gfxcount.1 httpd.1 httpdc.1 imagemap.1 \
readxs.1 xsindex.1 xspasswd.1
MAN5= httpd.conf.5 xsauth.5 xsconf.5 xsscripts.5 xsredir.5
+MAN7= httpd_cgi.7 httpd_ssi.7
USE_BZIP2= yes
USE_RC_SUBR= xshttpd.sh
@@ -30,20 +32,19 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= SSL "Enable https support" On \
+ PCRE "Enable pcre rewriting support" On \
LDAP "Enable ldap support" Off \
- PCRE "Enable pcre rewriting support" Off \
CURL "Enable curl (proxy) support" Off \
M4_CONFIG "Enable m4 configuration preprocessor" Off \
PERSISTENT_PERL "Enable persistent perl interpreter" Off
PORTDOCS= README COPYING ChangeLog
+.include <bsd.port.pre.mk>
# By default XS-HTTPD stores its data in ${PREFIX}/lib/httpd
-WWWDIR?= ${PREFIX}/www
+WWWDIR?= ${PREFIX}/www/${PORTNAME}
CONFIGURE_ARGS+=--with-rootdir=${WWWDIR} --mandir=${MANPREFIX}/man
-.include <bsd.port.pre.mk>
-
.if !defined(WITHOUT_SSL)
.include <${PORTSDIR}/Mk/bsd.openssl.mk>
#USE_OPENSSL= yes
@@ -96,7 +97,8 @@ post-patch:
-e 's|nogroup|${WWWGRP}|g' \
${WRKSRC}/$i
.endfor
- @${REINPLACE_CMD} -e 's|\(MIMETYPESFILE\ "\).*|\1${LOCALBASE}/etc/mime.types"|' \
+ @${REINPLACE_CMD} \
+ -e 's|\(MIMETYPESFILE\ "\).*|\1${LOCALBASE}/etc/mime.types"|' \
${WRKSRC}/src/confuser.h
@${REINPLACE_CMD} -e 's|mime.types ||g' \
${WRKSRC}/config/Makefile.in
diff --git a/www/xshttpd-devel/distinfo b/www/xshttpd-devel/distinfo
index 410aa2f0873d..6680292593c8 100644
--- a/www/xshttpd-devel/distinfo
+++ b/www/xshttpd-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (xshttpd-35b07.tar.bz2) = c91b93d9866dc8cc85ec875d3f8f6b00
-SHA256 (xshttpd-35b07.tar.bz2) = fb67c7ba1ccda1da76751053c72c234f6c1d722b0887667f84dd3b84e2cf5b20
-SIZE (xshttpd-35b07.tar.bz2) = 211175
+MD5 (xshttpd-35b10.tar.bz2) = b7e5871b164c988643a029fc2c26d4f5
+SHA256 (xshttpd-35b10.tar.bz2) = f92eda0f4f2a041c0d70422c313ed490fa5a2a5d2b476aed4807db2ccdb1a933
+SIZE (xshttpd-35b10.tar.bz2) = 212620
diff --git a/www/xshttpd-devel/pkg-plist b/www/xshttpd-devel/pkg-plist
index ebf4cc58ce53..00766d77de94 100644
--- a/www/xshttpd-devel/pkg-plist
+++ b/www/xshttpd-devel/pkg-plist
@@ -7,6 +7,9 @@ bin/xspasswd
%%WWWDIR%%/cgi-bin/error
%%WWWDIR%%/cgi-bin/gfxcount
%%WWWDIR%%/cgi-bin/imagemap
+%%WWWDIR%%/conf/httpd.conf.sample
+%%WWWDIR%%/conf/mime.index
+%%WWWDIR%%/conf/script.methods.sample
%%WWWDIR%%/contrib/SSL-Makefile
%%WWWDIR%%/contrib/agentstats.pl
%%WWWDIR%%/contrib/caroot.pem
@@ -45,27 +48,27 @@ bin/xspasswd
%%WWWDIR%%/gfxcount/largecol7.ppm
%%WWWDIR%%/gfxcount/largecol8.ppm
%%WWWDIR%%/gfxcount/largecol9.ppm
-%%WWWDIR%%/httpd.conf.sample
-%%WWWDIR%%/htdocs/icons/xs-audio.gif
-%%WWWDIR%%/htdocs/icons/xs-back.gif
-%%WWWDIR%%/htdocs/icons/xs-base.gif
-%%WWWDIR%%/htdocs/icons/xs-bin.gif
-%%WWWDIR%%/htdocs/icons/xs-dir.gif
-%%WWWDIR%%/htdocs/icons/xs-gif.gif
-%%WWWDIR%%/htdocs/icons/xs-html.gif
-%%WWWDIR%%/htdocs/icons/xs-image.gif
-%%WWWDIR%%/htdocs/icons/xs-jpeg.gif
-%%WWWDIR%%/htdocs/icons/xs-ps.gif
-%%WWWDIR%%/htdocs/icons/xs-tar.gif
-%%WWWDIR%%/htdocs/icons/xs-txt.gif
-%%WWWDIR%%/htdocs/icons/xs-unknown.gif
-%%WWWDIR%%/htdocs/icons/xs-video.gif
-%%WWWDIR%%/htdocs/icons/xs-zip.gif
-%%WWWDIR%%/mime.index
-%%WWWDIR%%/script.methods.sample
+%%WWWDIR%%/icons/xs-audio.gif
+%%WWWDIR%%/icons/xs-back.gif
+%%WWWDIR%%/icons/xs-base.gif
+%%WWWDIR%%/icons/xs-bin.gif
+%%WWWDIR%%/icons/xs-dir.gif
+%%WWWDIR%%/icons/xs-gif.gif
+%%WWWDIR%%/icons/xs-html.gif
+%%WWWDIR%%/icons/xs-image.gif
+%%WWWDIR%%/icons/xs-jpeg.gif
+%%WWWDIR%%/icons/xs-ps.gif
+%%WWWDIR%%/icons/xs-tar.gif
+%%WWWDIR%%/icons/xs-txt.gif
+%%WWWDIR%%/icons/xs-unknown.gif
+%%WWWDIR%%/icons/xs-video.gif
+%%WWWDIR%%/icons/xs-zip.gif
+@exec mkdir -p %%WWWDIR%%/htdocs
@dirrm %%WWWDIR%%/contrib
@dirrm %%WWWDIR%%/gfxcount
@dirrmtry %%WWWDIR%%/cgi-bin
-@dirrmtry %%WWWDIR%%/htdocs/icons
+@dirrmtry %%WWWDIR%%/conf
@dirrmtry %%WWWDIR%%/htdocs
+@dirrmtry %%WWWDIR%%/icons
@dirrmtry %%WWWDIR%%/logs
+@dirrmtry %%WWWDIR%%